aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-02-27 23:13:27 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-02-27 23:13:27 +0000
commit0f7b2dec3b5bf2ed90ebed25c76bd713463c2468 (patch)
treee48b98dc553cc0930c57df9055fe7897df953ed8 /print
parent33681ef3de60a5f0debbd5df9f7042fb0c66b7ab (diff)
downloadports-0f7b2dec3b5bf2ed90ebed25c76bd713463c2468.tar.gz
ports-0f7b2dec3b5bf2ed90ebed25c76bd713463c2468.zip
- Update to 2.0.1
- Add LICENSE - Use PLIST_FILES intead of pkg-plist file - Re-gen the patches to make portlint happy
Notes
Notes: svn path=/head/; revision=463166
Diffstat (limited to 'print')
-rw-r--r--print/cups-bjnp/Makefile8
-rw-r--r--print/cups-bjnp/distinfo5
-rw-r--r--print/cups-bjnp/files/patch-bjnp-debug.c10
-rw-r--r--print/cups-bjnp/files/patch-configure6
-rw-r--r--print/cups-bjnp/pkg-plist1
5 files changed, 17 insertions, 13 deletions
diff --git a/print/cups-bjnp/Makefile b/print/cups-bjnp/Makefile
index 214137d75a18..a468b91a114c 100644
--- a/print/cups-bjnp/Makefile
+++ b/print/cups-bjnp/Makefile
@@ -1,16 +1,20 @@
# $FreeBSD$
PORTNAME= cups-bjnp
-PORTVERSION= 2.0
-PORTREVISION= 2
+PORTVERSION= 2.0.1
CATEGORIES= print
MASTER_SITES= SF
MAINTAINER= danilo@FreeBSD.org
COMMENT= CUPS backend for Canon USB over IP protocol
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libcups.so:print/cups
+PLIST_FILES= libexec/cups/backend/bjnp
+
GNU_CONFIGURE= yes
# Just to avoid a tautological pointer compare in bjnp-commands.c:187
CONFIGURE_ARGS+= --disable-Werror
diff --git a/print/cups-bjnp/distinfo b/print/cups-bjnp/distinfo
index 42b4d6698906..072952e65a01 100644
--- a/print/cups-bjnp/distinfo
+++ b/print/cups-bjnp/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cups-bjnp-2.0.tar.gz) = 2acb716680d66f1378cf8dcd45fedf7f72ccc9b66fa80214d6dcb042b5e3c9ab
-SIZE (cups-bjnp-2.0.tar.gz) = 140617
+TIMESTAMP = 1519772479
+SHA256 (cups-bjnp-2.0.1.tar.gz) = 95b5940daf6ee46120efef9c05048ade9bb855de36280c140895f9672b2946c0
+SIZE (cups-bjnp-2.0.1.tar.gz) = 143552
diff --git a/print/cups-bjnp/files/patch-bjnp-debug.c b/print/cups-bjnp/files/patch-bjnp-debug.c
index 7a7b3bfb722c..7131156b305e 100644
--- a/print/cups-bjnp/files/patch-bjnp-debug.c
+++ b/print/cups-bjnp/files/patch-bjnp-debug.c
@@ -1,4 +1,4 @@
---- bjnp-debug.c.orig 2014-09-06 12:38:15 UTC
+--- bjnp-debug.c.orig 2018-02-21 11:40:53 UTC
+++ bjnp-debug.c
@@ -20,7 +20,7 @@
@@ -9,7 +9,7 @@
#include <errno.h>
#include "bjnp.h"
-@@ -58,7 +58,7 @@
+@@ -58,7 +58,7 @@ static logtable_entry_t logtable[] = {
static bjnp_loglevel_t debug_level = LOG_ERROR;
static FILE *debug_file = NULL;
static time_t start_sec = 0;
@@ -18,7 +18,7 @@
/*
* local functions
-@@ -192,9 +192,9 @@
+@@ -192,9 +192,9 @@ bjnp_debug(bjnp_loglevel_t level, const char *fmt, ...
{
va_list ap;
char printbuf[1024];
@@ -30,7 +30,7 @@
if (level <= debug_level) {
/* print received data into a string */
-@@ -211,16 +211,16 @@
+@@ -211,16 +211,16 @@ bjnp_debug(bjnp_loglevel_t level, const char *fmt, ...
/* all log messages may go to the own logfile */
if (debug_file != NULL) {
@@ -53,7 +53,7 @@
printbuf);
fflush(debug_file);
}
-@@ -234,12 +234,12 @@
+@@ -234,12 +234,12 @@ bjnp_set_debug_level(const char *level, const char *fi
* set debug level to level (string)
*/
diff --git a/print/cups-bjnp/files/patch-configure b/print/cups-bjnp/files/patch-configure
index 3a28174e2581..e112077a9799 100644
--- a/print/cups-bjnp/files/patch-configure
+++ b/print/cups-bjnp/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2013-08-14 02:30:58.000000000 -0700
-+++ configure 2013-08-14 02:30:31.000000000 -0700
-@@ -3946,7 +3946,7 @@
+--- configure.orig 2018-02-21 17:07:41 UTC
++++ configure
+@@ -3973,7 +3973,7 @@ done
IFS=$ac_save_IFS
diff --git a/print/cups-bjnp/pkg-plist b/print/cups-bjnp/pkg-plist
deleted file mode 100644
index 64ffe127252d..000000000000
--- a/print/cups-bjnp/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-libexec/cups/backend/bjnp