aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2011-06-20 18:57:14 +0000
committerHiroki Sato <hrs@FreeBSD.org>2011-06-20 18:57:14 +0000
commit15c088992b2febdba1d18ee1e99463775334fbaf (patch)
treeabd84e987b636e4aa5655e470f2fca2fa09bf07a /print
parent9020c49ddd345e8889953659bf6ff27012f05d37 (diff)
Update CONFLICTS lines.
PR: ports/158028
Notes
Notes: svn path=/head/; revision=275918
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript7/Makefile9
-rw-r--r--print/ghostscript8/Makefile5
-rw-r--r--print/ghostscript8/files/Makefile.drivers_post4
-rw-r--r--print/ghostscript9/files/Makefile.drivers_post4
4 files changed, 12 insertions, 10 deletions
diff --git a/print/ghostscript7/Makefile b/print/ghostscript7/Makefile
index fd37aed91beb..21e6074409cc 100644
--- a/print/ghostscript7/Makefile
+++ b/print/ghostscript7/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript7
PORTVERSION= 7.07
-PORTREVISION= 23
+PORTREVISION= 24
CATEGORIES= print
MASTER_SITES= SF/ghostscript/gnu-gs/${PORTVERSION}:gs_srcs \
${MASTER_SITE_PORTS_JP:S/$/:ports_jp,ports_jp_gs/} \
@@ -30,7 +30,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/fonts/a010013l.pfb:${PORTSDIR}/print
WRKSRC= ${WRKDIR}/${PORTNAME:S,7$,,}
DATADIR= ${PREFIX}/share/${PORTNAME:S,7$,,}
-CONFLICTS= gambc-* ghostscript8-*
+CONFLICTS_INSTALL= gambc-[0-9]* ghostscript[89]-[0-9]* \
+ ghostscript[89]-*-[0-9]*
USE_BZIP2= yes
USE_GMAKE= yes
@@ -127,11 +128,11 @@ USE_XORG= xt xext
CONFIGURE_ARGS+=--with-x \
--x-includes=${X11BASE}/include \
--x-libraries=${X11BASE}/lib
-CONFLICTS+= ghostscript7-nox11-[0-9]*
+CONFLICTS_INSTALL+= ghostscript7-nox11-[0-9]*
.else
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-nox11
CONFIGURE_ARGS+=--without-x
-CONFLICTS+= ghostscript7-[0-9]*
+CONFLICTS_INSTALL+= ghostscript7-[0-9]*
.endif
.if defined(WITH_SHLIB)
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 4676b3609011..881f974adfe3 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript8
PORTVERSION= 8.71
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= print
MASTER_SITES= http://ghostscript.com/releases/:gs_srcs \
SF/ghostscript/files/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@@ -31,7 +31,8 @@ LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
tiff:${PORTSDIR}/graphics/tiff
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME:S,8,,}/fonts/a010013l.pfb:${PORTSDIR}/print/gsfonts
-CONFLICTS= gambc-[0-9]* ghostscript7-[0-9]* ghostscript7-*-[0-9]*
+CONFLICTS_INSTALL= gambc-[0-9]* ghostscript[79]-[0-9]* \
+ ghostscript[79]-*-[0-9]*
USE_XZ= yes
USE_GMAKE= yes
diff --git a/print/ghostscript8/files/Makefile.drivers_post b/print/ghostscript8/files/Makefile.drivers_post
index 34c93acb8109..c26f6566b16b 100644
--- a/print/ghostscript8/files/Makefile.drivers_post
+++ b/print/ghostscript8/files/Makefile.drivers_post
@@ -117,7 +117,7 @@ USE_XORG= xt xext
CONFIGURE_ARGS+=--with-x \
--x-includes=${X11BASE}/include \
--x-libraries=${X11BASE}/lib
-CONFLICTS+= ghostscript8-nox11-[0-9]*
+CONFLICTS_INSTALL+= ghostscript8-nox11-[0-9]*
.if defined(WITH_GTK)
USE_GNOME= atk gdkpixbuf glib20 gtk20
CONFIGURE_ARGS+=--enable-gtk
@@ -127,7 +127,7 @@ CONFIGURE_ARGS+=--disable-gtk
.else # defined(_X11_DEVS)
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-nox11
CONFIGURE_ARGS+=--without-x --disable-gtk
-CONFLICTS+= ghostscript8-[0-9]*
+CONFLICTS_INSTALL+= ghostscript8-[0-9]*
.endif # defined(_X11_DEVS)
# iconv specific
diff --git a/print/ghostscript9/files/Makefile.drivers_post b/print/ghostscript9/files/Makefile.drivers_post
index 56ed7f83123e..de2a6737be06 100644
--- a/print/ghostscript9/files/Makefile.drivers_post
+++ b/print/ghostscript9/files/Makefile.drivers_post
@@ -118,7 +118,7 @@ X11BITS= ""
CONFIGURE_ARGS+=--with-x \
--x-includes=${X11BASE}/include \
--x-libraries=${X11BASE}/lib
-CONFLICTS+= ghostscript9-nox11-[0-9]*
+CONFLICTS_INSTALL+= ghostscript9-nox11-[0-9]*
.if defined(WITH_GTK)
USE_GNOME= atk gdkpixbuf glib20 gtk20
CONFIGURE_ARGS+=--enable-gtk
@@ -128,7 +128,7 @@ CONFIGURE_ARGS+=--disable-gtk
.else # defined(_X11_DEVS)
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-nox11
CONFIGURE_ARGS+=--without-x --disable-gtk
-CONFLICTS+= ghostscript9-[0-9]*
+CONFLICTS_INSTALL+= ghostscript9-[0-9]*
X11BITS= "@comment "
.endif # defined(_X11_DEVS)