aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-06 09:18:23 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-06 09:18:23 +0000
commit50c92980a9b782c7822d5e97f2ac8c8c9dede5f2 (patch)
tree26193c92680083b31491f9b46c248e1e4581e70f /print
parent91c538221650308b5c0242aa9d00dd7daaa8aaa9 (diff)
Add latex-arydshln 1.6.20030825,
latex-arydshln gives LaTeX's array and tabular environments the capability to draw horizontal/vertical dash-lines. PR: ports/63809 Submitted by: hrs@FreeBSD.org
Notes
Notes: svn path=/head/; revision=103075
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-arydshln/Makefile56
-rw-r--r--print/latex-arydshln/distinfo8
-rw-r--r--print/latex-arydshln/pkg-descr2
-rw-r--r--print/latex-arydshln/pkg-plist11
5 files changed, 78 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index e50cc1f6bb4f..b2803561959e 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -93,6 +93,7 @@
SUBDIR += kcdlabel
SUBDIR += kover
SUBDIR += latex
+ SUBDIR += latex-arydshln
SUBDIR += latex-beamer
SUBDIR += latex-biblist
SUBDIR += latex-bibtopic
diff --git a/print/latex-arydshln/Makefile b/print/latex-arydshln/Makefile
new file mode 100644
index 000000000000..50844f70c248
--- /dev/null
+++ b/print/latex-arydshln/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: latex-arydshln
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-arydshln
+PORTVERSION= 1.6.20030825
+CATEGORIES= print
+MASTER_SITES= ftp://ftp.ctan.org/tex-archive/%SUBDIR%/ \
+ ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/arydshln
+DISTFILES= README arydshln.dtx arydshln.ins arydshln.pdf
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package that draws dash-lines in array/tabular
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX \
+ tex:${PORTSDIR}/print/teTeX \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
+ ${TEXMFLOCAL_LSR}:${PORTSDIR}/print/tex-texmflocal
+
+PLIST_SUB= MKTEXLSR=${MKTEXLSR} CLASSDIR=${CLASSDIR}
+
+TEXMFLOCAL= share/texmf-local
+TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+TEX_BIN= ${LOCALBASE}/bin/tex
+YES_CMD= /usr/bin/yes
+CLASSDIR= ${TEXMFLOCAL}/tex/latex/${PORTNAME:S/^latex-//}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/^latex-//}
+
+CLASS_FILES= arydshln.dtx arydshln.ins arydshln.sty arydshln-man.tex
+DOC_FILES= README arydshln.pdf
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${CP} ${DISTFILES} ${WRKSRC}
+
+do-build:
+ cd ${WRKSRC} && ${YES_CMD} | ${TEX_BIN} arydshln.ins
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${WRKSRC}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${WRKSRC}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ @${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-arydshln/distinfo b/print/latex-arydshln/distinfo
new file mode 100644
index 000000000000..b8255ebe597a
--- /dev/null
+++ b/print/latex-arydshln/distinfo
@@ -0,0 +1,8 @@
+MD5 (latex-arydshln/README) = eeff227402b61527ec67e9203a598439
+SIZE (latex-arydshln/README) = 1145
+MD5 (latex-arydshln/arydshln.dtx) = 93d2ef556a2a6a494ef634cd7d08c480
+SIZE (latex-arydshln/arydshln.dtx) = 193376
+MD5 (latex-arydshln/arydshln.ins) = da2a9614612013ac1752be28195cfb20
+SIZE (latex-arydshln/arydshln.ins) = 163
+MD5 (latex-arydshln/arydshln.pdf) = 207625d825a3634fb978f1816526cbc0
+SIZE (latex-arydshln/arydshln.pdf) = 399317
diff --git a/print/latex-arydshln/pkg-descr b/print/latex-arydshln/pkg-descr
new file mode 100644
index 000000000000..3f88ed8418ef
--- /dev/null
+++ b/print/latex-arydshln/pkg-descr
@@ -0,0 +1,2 @@
+latex-arydshln gives LaTeX's array and tabular environments
+the capability to draw horizontal/vertical dash-lines.
diff --git a/print/latex-arydshln/pkg-plist b/print/latex-arydshln/pkg-plist
new file mode 100644
index 000000000000..6c0ddc0e68ef
--- /dev/null
+++ b/print/latex-arydshln/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/arydshln.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/arydshln.dtx
+%%CLASSDIR%%/arydshln.ins
+%%CLASSDIR%%/arydshln.sty
+%%CLASSDIR%%/arydshln-man.tex
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%