aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2012-02-12 18:46:35 +0000
committerHiroki Sato <hrs@FreeBSD.org>2012-02-12 18:46:35 +0000
commit57f5bb7caf90c8b6d8716f71b74c2bb97f67ec65 (patch)
tree94f686a7c9c8b089b324945b1031639bd1ee0fc7 /print
parent5b71eaa441fae65461bf196777d0d91b30070e85 (diff)
Notes
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript8/Makefile4
-rw-r--r--print/ghostscript8/files/Makefile.epag7
-rw-r--r--print/ghostscript8/files/patch-epag-ert.c11
3 files changed, 15 insertions, 7 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index 1db6fd6d4d03..9d9e44b747f0 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -9,7 +9,7 @@ PORTNAME= ghostscript8
PORTVERSION= 8.71
PORTREVISION= 8
CATEGORIES= print
-MASTER_SITES= http://ghostscript.com/releases/:gs_srcs \
+MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/files/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/gs${PORTVERSION:S/.//}/:gs_srcs \
http://www.humblesoft.com/pub/:epag
@@ -183,7 +183,6 @@ pre-build: pre-build-drivers.mak
pre-su-install:
${MKDIR} ${DATADIR}
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
post-install-docs:
${MKDIR} ${WRKSRC}/contrib/japanese
@@ -203,6 +202,7 @@ post-install: post-install-fapi
.endif
post-install:
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}/${PORTVERSION}
${STRIP_CMD} ${PREFIX}/bin/gsc ${PREFIX}/bin/gsx
${LN} -sf gsc ${PREFIX}/bin/gs
${LN} -s -f ${LOCALBASE}/share/fonts/CIDFont ${CIDFONTDIR}/CIDFont
diff --git a/print/ghostscript8/files/Makefile.epag b/print/ghostscript8/files/Makefile.epag
index ad9a7a5c150a..94be6f560194 100644
--- a/print/ghostscript8/files/Makefile.epag
+++ b/print/ghostscript8/files/Makefile.epag
@@ -9,15 +9,12 @@ PORTDOC_FILES+= epag/ert.txt epag/gdevepag.txt epag/ChangeLog \
pre-build-epag:
${LN} -s -f ${WRKSRC}/${EPAG_NAME}/gdevepag.c ${WRKSRC}/base
+ ${MKDIR} ${WRKSRC}/contrib/epag
+ ${INSTALL_DATA} ${WRKSRC}/${EPAG_NAME}/* ${WRKSRC}/contrib/epag
post-build-epag:
cd ${WRKSRC}/${EPAG_NAME} && \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} Makefile
-post-install-docs-epag:
- ${MKDIR} ${WRKSRC}/contrib/epag
- ${INSTALL_DATA} ${WRKSRC}/${EPAG_NAME}/* ${WRKSRC}/contrib/epag
-
pre-build: pre-build-epag
post-build: post-build-epag
-post-install-docs: post-install-docs-epag
diff --git a/print/ghostscript8/files/patch-epag-ert.c b/print/ghostscript8/files/patch-epag-ert.c
new file mode 100644
index 000000000000..f063aeddabc2
--- /dev/null
+++ b/print/ghostscript8/files/patch-epag-ert.c
@@ -0,0 +1,11 @@
+--- epag-3.09/ert.c.orig 2000-07-08 13:33:09.000000000 +0900
++++ epag/ert.c 2012-02-13 03:38:07.000000000 +0900
+@@ -1,6 +1,8 @@
+ /* $Id: ert.c,v 1.3 1998/11/20 10:51:12 nari Exp $ */
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+
+ /*
+ * EPSON Remoteのコマンドを出力するコマンド