aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-04 13:07:40 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-04 13:07:40 +0000
commit945c98fdf861a79f327f95cfb7453c31d8f95896 (patch)
tree1b35744f0d7c32ca5d373e7aab96ed6d8ee2e10b /print
parent676d298ee18c01673284b1087a7e3c99febd1d80 (diff)
downloadports-945c98fdf861a79f327f95cfb7453c31d8f95896.tar.gz
ports-945c98fdf861a79f327f95cfb7453c31d8f95896.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/cdlabelgen/Makefile2
-rw-r--r--print/easylatex/Makefile2
-rw-r--r--print/foomatic-db-engine/Makefile2
-rw-r--r--print/html2ps/Makefile2
-rw-r--r--print/latex-ucs/Makefile3
-rw-r--r--print/latexdiff/Makefile3
-rw-r--r--print/p5-Net-CUPS/Makefile3
-rw-r--r--print/p5-Net-Printer/Makefile3
-rw-r--r--print/p5-PDF-Template/Makefile3
-rw-r--r--print/p5-XML-ApacheFOP/Makefile3
-rw-r--r--print/ps2eps/Makefile3
-rw-r--r--print/txtbdf2ps/Makefile2
12 files changed, 19 insertions, 12 deletions
diff --git a/print/cdlabelgen/Makefile b/print/cdlabelgen/Makefile
index e2abac09603f..d9ee60a3b631 100644
--- a/print/cdlabelgen/Makefile
+++ b/print/cdlabelgen/Makefile
@@ -17,7 +17,7 @@ COMMENT= Generate postscript for frontcards and traycards for CDs
MAN1= cdlabelgen.1
MANCOMPRESSED= no
-USE_PERL5= yes
+USES= perl5
MAKE_ARGS= BASE_DIR="${PREFIX}" \
LIB_DIR="${DATADIR}" \
INSTALL="${INSTALL_SCRIPT}" \
diff --git a/print/easylatex/Makefile b/print/easylatex/Makefile
index f5c7b99067b9..7c1d9067be2a 100644
--- a/print/easylatex/Makefile
+++ b/print/easylatex/Makefile
@@ -18,7 +18,7 @@ COMMENT= Perl script which transforms "pseudo-LaTeX" into proper LaTeX
RUN_DEPENDS= p5-Getopt-Declare>=0:${PORTSDIR}/devel/p5-Getopt-Declare
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
post-patch:
@${REINPLACE_CMD} -e 's,/usr/lib/easylatex,${DATADIR},' \
diff --git a/print/foomatic-db-engine/Makefile b/print/foomatic-db-engine/Makefile
index de8c24dba7ac..c57bf8384b64 100644
--- a/print/foomatic-db-engine/Makefile
+++ b/print/foomatic-db-engine/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl
PROJECTHOST= bsdistfiles
USE_GNOME= libxml2
-USE_PERL5= yes
+USES= perl5
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PERL=${PERL} LIBDIR=${PREFIX}/share/foomatic/
diff --git a/print/html2ps/Makefile b/print/html2ps/Makefile
index 68c337738dc9..c5830770967c 100644
--- a/print/html2ps/Makefile
+++ b/print/html2ps/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= mogrify:${PORTSDIR}/graphics/ImageMagick \
paperconf:${PORTSDIR}/print/libpaper
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
USE_GHOSTSCRIPT_RUN= yes
SUB_FILES= html2psrc
diff --git a/print/latex-ucs/Makefile b/print/latex-ucs/Makefile
index 884fc6ed5b68..812f32ac79af 100644
--- a/print/latex-ucs/Makefile
+++ b/print/latex-ucs/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= hrs@FreeBSD.org
COMMENT= A LaTeX package for using UTF-8 as input encoding
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_TEX= latex
PLIST_SUB= MKTEXLSR="${MKTEXLSR}" CLASSDIR=${CLASSDIR}
diff --git a/print/latexdiff/Makefile b/print/latexdiff/Makefile
index 08f47fe091eb..87292ebbd15f 100644
--- a/print/latexdiff/Makefile
+++ b/print/latexdiff/Makefile
@@ -18,7 +18,8 @@ COMMENT= Determine and mark up significant differences between latex files
RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_ZIP= yes
NO_BUILD= yes
diff --git a/print/p5-Net-CUPS/Makefile b/print/p5-Net-CUPS/Makefile
index 557c66a5182f..4b890d703e46 100644
--- a/print/p5-Net-CUPS/Makefile
+++ b/print/p5-Net-CUPS/Makefile
@@ -18,7 +18,8 @@ COMMENT= Interface to the CUPS API
BUILD_DEPENDS= cups-config:${PORTSDIR}/print/cups-client
LIB_DEPENDS= cupsimage.2:${PORTSDIR}/print/cups-image
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::CUPS.3 \
Net::CUPS::Destination.3 \
diff --git a/print/p5-Net-Printer/Makefile b/print/p5-Net-Printer/Makefile
index ae57077292c0..73e71fc99770 100644
--- a/print/p5-Net-Printer/Makefile
+++ b/print/p5-Net-Printer/Makefile
@@ -12,7 +12,8 @@ COMMENT= Perl extension for direct-to-lpd printing
LICENSE= BSD
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Printer.3
diff --git a/print/p5-PDF-Template/Makefile b/print/p5-PDF-Template/Makefile
index 7da97f010a0c..1bea77625c0d 100644
--- a/print/p5-PDF-Template/Makefile
+++ b/print/p5-PDF-Template/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS+= pdflib-perl>=0:${PORTSDIR}/print/pdflib-perl \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PDF::Template::Element::Weblink.3 \
PDF::Template::Container::Scope.3 \
diff --git a/print/p5-XML-ApacheFOP/Makefile b/print/p5-XML-ApacheFOP/Makefile
index 49c10749a6a6..15299b023784 100644
--- a/print/p5-XML-ApacheFOP/Makefile
+++ b/print/p5-XML-ApacheFOP/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Java>=0:${PORTSDIR}/devel/p5-Java \
${LOCALBASE}/share/java/fop/build/fop.jar:${PORTSDIR}/textproc/fop
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::ApacheFOP.3
diff --git a/print/ps2eps/Makefile b/print/ps2eps/Makefile
index c2398184c069..81c1ccfab3d6 100644
--- a/print/ps2eps/Makefile
+++ b/print/ps2eps/Makefile
@@ -18,7 +18,8 @@ COMMENT= Generate Encapsulated Postscript file from Postscript document
WRKSRC= ${WRKDIR}/ps2eps
USE_GHOSTSCRIPT_RUN= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
MAN1= ps2eps.1 bbox.1
do-build:
diff --git a/print/txtbdf2ps/Makefile b/print/txtbdf2ps/Makefile
index 3c360b1e1920..75d1e48c61eb 100644
--- a/print/txtbdf2ps/Makefile
+++ b/print/txtbdf2ps/Makefile
@@ -19,7 +19,7 @@ COMMENT= Translator TXT + BDF to PS
PROJECTHOST= ak-various-projects
PLIST_FILES= bin/txtbdf2ps
-USE_PERL5= yes
+USES= perl5
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= ${WRKDIR}