aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-07-06 13:40:29 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-07-06 13:40:29 +0000
commitbe4c0abfa01a87ba12bcfa2985e519ebfc4d8290 (patch)
treef76a2d5032e9655dffa92aed33e566e1b43b4bd8 /print
parent08fd71c50af9819626db5ac817660e81f0f1b344 (diff)
downloadports-be4c0abfa01a87ba12bcfa2985e519ebfc4d8290.tar.gz
ports-be4c0abfa01a87ba12bcfa2985e519ebfc4d8290.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/hp2xx/Makefile32
-rw-r--r--print/hp2xx/pkg-plist1
2 files changed, 20 insertions, 13 deletions
diff --git a/print/hp2xx/Makefile b/print/hp2xx/Makefile
index 002597d34495..efacf521f671 100644
--- a/print/hp2xx/Makefile
+++ b/print/hp2xx/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A HPGL to vector- and raster formats converter and previewer for X11
+COMMENT= HPGL to vector and raster formats converter and previewer for X11
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/${DISTNAME}/sources
@@ -20,21 +20,29 @@ USES= makeinfo
MAKE_ENV= DEFINES="${CPPFLAGS}" ALL_LIBS="${LDFLAGS}" \
PREVIEWER="${PREVIEWER}"
-MAN1= hp2xx.1
+PLIST_FILES= bin/hp2xx man/man1/hp2xx.1.gz
INFO= hp2xx
CPPFLAGS+= -DUNIX -I${LOCALBASE}/include
LDFLAGS+= -lm -L${LOCALBASE}/lib -ltiff -lpng -lz
-.if defined(WITHOUT_X11)
-PKGNAMESUFFIX= -nox11
-PREVIEWER= no_prev
-.else
-USE_XORG= x11
-CPPFLAGS+= -DHAS_UNIX_X11 -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lX11
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT=X11
+
+X11_USE= XORG=x11
+X11_CPPFLAGS= -DHAS_UNIX_X11 -I${LOCALBASE}/include
+X11_LDFLAGS= -L${LOCALBASE}/lib -lX11
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
PREVIEWER= to_x11
+.else
+PREVIEWER= no_prev
.endif
-NO_STAGE= yes
+post-patch:
+ @${REINPLACE_CMD} -E 's,(bin|info|man1)dir),DESTDIR)$$(&,' \
+ ${WRKSRC}/Makefile
+
.include <bsd.port.mk>
diff --git a/print/hp2xx/pkg-plist b/print/hp2xx/pkg-plist
deleted file mode 100644
index 8ef583811cf7..000000000000
--- a/print/hp2xx/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/hp2xx