aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
commit1bf9457272318a99eb550ee7603ef85903c36cea (patch)
tree30969701cc82a93abc61c62dd66cf03666bbe585 /print
parentb4990c3eb608adca7aab250206f47b154ccd7711 (diff)
downloadports-1bf9457272318a99eb550ee7603ef85903c36cea.tar.gz
ports-1bf9457272318a99eb550ee7603ef85903c36cea.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/hplip/Makefile13
-rw-r--r--print/py-reportlab/Makefile12
-rw-r--r--print/py-trml2pdf/Makefile2
3 files changed, 6 insertions, 21 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 31dcfc9d04de..8dbb006cd59a 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -53,6 +53,7 @@ FAX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}reportlab>=0:print/py-reportlab@${PY_FLA
FAX_CONFIGURE_ENABLE= fax-build
SCAN_DESC= Scanning support
+SCAN_RUN_DEPENDS= ${PY_PILLOW}
SCAN_LIB_DEPENDS= libsane.so:graphics/sane-backends
SCAN_CONFIGURE_ENABLE= scan-build
@@ -82,16 +83,6 @@ CONFIGURE_ARGS+= --disable-qt5
BROKEN= The X11 option requires the QT5 option
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MSCAN}
-.if ${PYTHON_REL} < 3500
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-.endif
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldld||g;' \
-e 's|-ldl||g' \
@@ -153,4 +144,4 @@ post-install-SCAN-on:
${MV} ${STAGEDIR}${PREFIX}/etc/sane.d/dll.conf \
${STAGEDIR}${PREFIX}/etc/sane.d/dll.d/hpaio
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/py-reportlab/Makefile b/print/py-reportlab/Makefile
index 4960ef48b28b..10b7822577a5 100644
--- a/print/py-reportlab/Makefile
+++ b/print/py-reportlab/Makefile
@@ -17,6 +17,8 @@ COMMENT= Library to create PDF documents using the Python language
LICENSE= BSD3CLAUSE
+RUN_DEPENDS= ${PY_PILLOW}
+
USES= python
USE_PYTHON= distutils autoplist
@@ -41,14 +43,6 @@ CJK_DESC= Adobe CMaps
CJK_RUN_DEPENDS= ${LOCALBASE}/share/fonts/adobe-cmaps/ac15/cid2code.txt:print/adobe-cmaps
FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3500
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%DISTDIR%%|${DISTDIR}|' \
-e 's|%%PFBFER%%|${PFBFER}|' \
@@ -71,4 +65,4 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/docs/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/py-trml2pdf/Makefile b/print/py-trml2pdf/Makefile
index 5908b9b64410..d2841eccd822 100644
--- a/print/py-trml2pdf/Makefile
+++ b/print/py-trml2pdf/Makefile
@@ -16,7 +16,7 @@ LICENSE= LGPL21
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR} \
+RUN_DEPENDS= ${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}reportlab>=0:print/py-reportlab@${PY_FLAVOR}
USES= python:2.7 shebangfix tar:bzip2