aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-04 17:35:18 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-04 17:35:18 +0000
commit2a0b64c7341e1c013ce6958160a24e2452a4c6c9 (patch)
tree1f86cc582c2ad43d4c632315c51db0626c5a1005 /print
parent55ba0a2277c2739f61cf1f464a7051fadb36a60c (diff)
downloadports-2a0b64c7341e1c013ce6958160a24e2452a4c6c9.tar.gz
ports-2a0b64c7341e1c013ce6958160a24e2452a4c6c9.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/tex-aleph/Makefile8
-rw-r--r--print/tex-aleph/pkg-plist4
-rw-r--r--print/tex-dvipdfmx/Makefile22
-rw-r--r--print/tex-dvipdfmx/pkg-plist4
-rw-r--r--print/tex-dvipsk/Makefile11
-rw-r--r--print/tex-dvipsk/pkg-plist2
-rw-r--r--print/tex-formats/Makefile2
-rw-r--r--print/tex-jadetex/Makefile4
-rw-r--r--print/tex-luatex/Makefile7
-rw-r--r--print/tex-mfpic/Makefile14
-rw-r--r--print/tex-xdvik/Makefile12
-rw-r--r--print/tex-xdvik/pkg-plist1
-rw-r--r--print/tex-xetex/Makefile6
-rw-r--r--print/tex-xmltex/Makefile5
-rw-r--r--print/tex-xmltex/pkg-plist1
-rw-r--r--print/texlive-base/Makefile19
-rw-r--r--print/texlive-base/pkg-plist3
-rw-r--r--print/texlive-texmf/Makefile6
18 files changed, 74 insertions, 57 deletions
diff --git a/print/tex-aleph/Makefile b/print/tex-aleph/Makefile
index d341f73919dd..1d93c5dfab0c 100644
--- a/print/tex-aleph/Makefile
+++ b/print/tex-aleph/Makefile
@@ -2,7 +2,7 @@
PORTNAME= aleph
PORTVERSION= 0.0.r.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2012/
PKGNAMEPREFIX= tex-
@@ -24,7 +24,7 @@ EXTRACT_FILES= \
libs/obsdcompat \
libs/xpdf \
texk/web2c
-EXTRACT_AFTER_ARGS_TEXMF=| ${TAR} -xf - -C ${PREFIX}/share \
+EXTRACT_AFTER_ARGS_TEXMF=| ${TAR} -xf - -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner \
${EXTRACT_FILES_TEXMF:S,^,${DISTNAME_TEXMF}/,}
DISTVERSION_TEXLIVE= 20120701
@@ -75,7 +75,6 @@ MLINKS= aleph.1 lamed.1 \
dvitype.1 odvitype.1 \
tangle.1 otangle.1
-NO_STAGE= yes
pre-configure:
for D in libs/obsdcompat libs/xpdf; do \
cd ${WRKDIR}/${DISTNAME}/$$D && \
@@ -86,4 +85,7 @@ pre-su-install:
${CAT} ${DISTDIR}/${DIST_SUBDIR}/texlive-${DISTVERSION_TEXLIVE}-texmf${EXTRACT_SUFX} \
${EXTRACT_AFTER_ARGS_TEXMF}
+post-install:
+ ${RM} -f ${STAGEDIR}${PREFIX}/man/man1/*
+
.include <bsd.port.mk>
diff --git a/print/tex-aleph/pkg-plist b/print/tex-aleph/pkg-plist
index 3df3f26855fb..c5bbd29dbb1c 100644
--- a/print/tex-aleph/pkg-plist
+++ b/print/tex-aleph/pkg-plist
@@ -8,6 +8,10 @@ bin/otp2ocp
bin/outocp
bin/mkocp
bin/mkofm
+bin/ofm2opl
+bin/opl2ofm
+bin/ovf2ovp
+bin/ovp2ovf
%%TEXMFDISTDIR%%/tex/plain/config/aleph.ini
%%TEXMFDISTDIR%%/doc/aleph/base/readme.txt
%%TEXMFDISTDIR%%/doc/aleph/base/News
diff --git a/print/tex-dvipdfmx/Makefile b/print/tex-dvipdfmx/Makefile
index 443a78179738..cd6e143e6092 100644
--- a/print/tex-dvipdfmx/Makefile
+++ b/print/tex-dvipdfmx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dvipdfmx
PORTVERSION= 20120420
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2012/
PKGNAMEPREFIX= tex-
@@ -33,7 +33,7 @@ EXTRACT_FILES= \
texk/dvipdfmx \
texk/kpathsea
EXTRACT_AFTER_ARGS_TEXMF= \
- | ${TAR} -xf - -C ${PREFIX}/share \
+ | ${TAR} -xf - -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner \
${EXCLUDE_FILES_TEXMF:S,^,--exclude ${DISTNAME_TEXMF}/,} \
${EXTRACT_FILES_TEXMF:S,^,${DISTNAME_TEXMF}/,}
@@ -60,20 +60,18 @@ CONFIGURE_ARGS= --with-paper \
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpaper -L${LOCALBASE}/lib
-NO_MANCOMPRESS= yes
-MAN1= dvipdfm.1 dvipdft.1 ebb.1 extractbb.1
-
-NO_STAGE= yes
-pre-su-install:
+pre-install:
${CAT} ${DISTDIR}/${DIST_SUBDIR}/texlive-${DISTVERSION_TEXMF}-texmf${EXTRACT_SUFX} \
${EXTRACT_AFTER_ARGS_TEXMF}
- ${MKDIR} ${PREFIX}/${TEXMFDISTDIR}/fonts/map/dvipdfmx \
- ${PREFIX}/${TEXMFDIR}/fonts/map/dvipdfmx/updmap
- ${TOUCH} ${PREFIX}/${TEXMFDISTDIR}/fonts/map/dvipdfmx/.keep_me \
- ${PREFIX}/${TEXMFDIR}/fonts/map/dvipdfmx/updmap/.keep_me
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/map/dvipdfmx \
+ ${STAGEDIR}${PREFIX}/${TEXMFDIR}/fonts/map/dvipdfmx/updmap
+ ${TOUCH} ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/map/dvipdfmx/.keep_me \
+ ${STAGEDIR}${PREFIX}/${TEXMFDIR}/fonts/map/dvipdfmx/updmap/.keep_me
post-install:
${LN} -f -s ${LOCALBASE}/share/fonts/adobe-cmaps \
- ${PREFIX}/${TEXMFDIR}/fonts/cmap/adobe-cmaps
+ ${STAGEDIR}${PREFIX}/${TEXMFDIR}/fonts/cmap/adobe-cmaps
+ ${RM} -f ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/map/glyphlist/glyphlist.txt \
+ ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/map/glyphlist/pdfglyphlist.txt
.include <bsd.port.mk>
diff --git a/print/tex-dvipdfmx/pkg-plist b/print/tex-dvipdfmx/pkg-plist
index 386ffcad749c..f6f542ef87dc 100644
--- a/print/tex-dvipdfmx/pkg-plist
+++ b/print/tex-dvipdfmx/pkg-plist
@@ -3,6 +3,10 @@ bin/dvipdfmx
bin/dvipdft
bin/ebb
bin/extractbb
+man/man1/dvipdfm.1.gz
+man/man1/dvipdft.1.gz
+man/man1/ebb.1.gz
+man/man1/extractbb.1.gz
%%TEXMFDISTDIR%%/fonts/map/dvipdfm/lm/lm-ec.map
%%TEXMFDISTDIR%%/fonts/map/dvipdfm/lm/lm-texnansi.map
%%TEXMFDISTDIR%%/fonts/map/dvipdfm/lm/lm-rm.map
diff --git a/print/tex-dvipsk/Makefile b/print/tex-dvipsk/Makefile
index e8a123c92347..625b8a41ec47 100644
--- a/print/tex-dvipsk/Makefile
+++ b/print/tex-dvipsk/Makefile
@@ -2,7 +2,7 @@
PORTNAME= dvipsk
PORTVERSION= 5.992
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2012/
PKGNAMEPREFIX= tex-
@@ -31,7 +31,7 @@ EXTRACT_FILES= \
texk/lcdf-typetools \
texk/kpathsea
EXTRACT_AFTER_ARGS_TEXMF= \
- | ${TAR} -xf - -C ${PREFIX}/share \
+ | ${TAR} -xf - -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner \
${EXTRACT_FILES_TEXMF:S,^,${DISTNAME_TEXMF}/,}
DISTVERSION_TEXMF= 20120701
@@ -56,16 +56,13 @@ CONFIGURE_ARGS= --with-paper \
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpaper -L${LOCALBASE}/lib
-NO_MANCOMPRESS= yes
-MAN1= afm2tfm.1 dvips.1
INFO= dvips
-NO_STAGE= yes
-pre-su-install:
+pre-install:
${CAT} ${DISTDIR}/${DIST_SUBDIR}/texlive-${DISTVERSION_TEXMF}-texmf${EXTRACT_SUFX} \
${EXTRACT_AFTER_ARGS_TEXMF}
post-install:
- ${INSTALL_DATA} ${WRKDIR}/texlive-${DISTVERSION_TEXMF}-source/texk/lcdf-typetools/7t.enc ${PREFIX}/${TEXMFDISTDIR}/fonts/enc/dvips/base/7t.enc
+ ${INSTALL_DATA} ${WRKDIR}/texlive-${DISTVERSION_TEXMF}-source/texk/lcdf-typetools/7t.enc ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/fonts/enc/dvips/base/7t.enc
.include <bsd.port.mk>
diff --git a/print/tex-dvipsk/pkg-plist b/print/tex-dvipsk/pkg-plist
index 4ad25d772396..c2a3a173fe09 100644
--- a/print/tex-dvipsk/pkg-plist
+++ b/print/tex-dvipsk/pkg-plist
@@ -1,5 +1,7 @@
bin/afm2tfm
bin/dvips
+man/man1/afm2tfm.1.gz
+man/man1/dvips.1.gz
%%TEXMFDISTDIR%%/fonts/map/dvips/gfsneohellenic/gfsneohellenic.map
%%TEXMFDISTDIR%%/fonts/map/dvips/adfsymbols/ArrowsADF.map
%%TEXMFDISTDIR%%/fonts/map/dvips/adfsymbols/BulletsADF.map
diff --git a/print/tex-formats/Makefile b/print/tex-formats/Makefile
index 91b046524e97..cd9a38924096 100644
--- a/print/tex-formats/Makefile
+++ b/print/tex-formats/Makefile
@@ -2,7 +2,7 @@
PORTNAME= formats
PORTVERSION= 20120701
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= #empty
PKGNAMEPREFIX= tex-
diff --git a/print/tex-jadetex/Makefile b/print/tex-jadetex/Makefile
index 046072753b56..c0aa41fd267f 100644
--- a/print/tex-jadetex/Makefile
+++ b/print/tex-jadetex/Makefile
@@ -2,6 +2,7 @@
PORTNAME= jadetex
PORTVERSION= 3.13
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2012/
PKGNAMEPREFIX= tex-
@@ -15,7 +16,7 @@ COMMENT= TeX backend for Jade, DSSSL processor for SGML/XML documents
USE_XZ= yes
USE_TEX= texlive texmf pdftex xmltex fmtutil
TEXHASHDIRS= ${TEXMFDISTDIR}
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - -C ${PREFIX}/share \
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner \
${EXTRACT_FILES:S,^,${DISTNAME}/,}
EXTRACT_FILES= \
@@ -26,7 +27,6 @@ NO_WRKSRC= yes
NO_BUILD= yes
TEX_FORMATS= jadetex
-NO_STAGE= yes
do-install:
${CAT} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX} \
${EXTRACT_AFTER_ARGS}
diff --git a/print/tex-luatex/Makefile b/print/tex-luatex/Makefile
index 2e5d429bfac0..557a67f086d6 100644
--- a/print/tex-luatex/Makefile
+++ b/print/tex-luatex/Makefile
@@ -2,7 +2,7 @@
PORTNAME= luatex
PORTVERSION= 0.70.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2012/
PKGNAMEPREFIX= tex-
@@ -31,7 +31,7 @@ EXTRACT_FILES= \
libs/obsdcompat \
libs/xpdf \
texk/web2c
-EXTRACT_AFTER_ARGS_TEXMF=| ${TAR} -xf - -C ${PREFIX}/share \
+EXTRACT_AFTER_ARGS_TEXMF=| ${TAR} -xf - -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner \
${EXTRACT_FILES_TEXMF:S,^,${DISTNAME_TEXMF}/,}
DISTVERSION_TEXMF=20120701
@@ -86,14 +86,13 @@ CFLAGS+= -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE= yes
TEX_FORMATS= luatex
-NO_STAGE= yes
pre-configure:
for D in libs/obsdcompat libs/xpdf; do \
cd ${WRKDIR}/${DISTNAME}/$$D && \
${SETENV} ${CONFIGURE_ENV} ${SH} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; \
done
-pre-su-install:
+pre-install:
${CAT} ${DISTDIR}/${DIST_SUBDIR}/texlive-${DISTVERSION_TEXMF}-texmf${EXTRACT_SUFX} \
${EXTRACT_AFTER_ARGS_TEXMF}
diff --git a/print/tex-mfpic/Makefile b/print/tex-mfpic/Makefile
index 62dc412acf8c..5f9e8fe5a6fd 100644
--- a/print/tex-mfpic/Makefile
+++ b/print/tex-mfpic/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}106
DIST_SUBDIR= teTeX
MAINTAINER= hrs@FreeBSD.org
-COMMENT= A TeX package that supports drawing pictures
+COMMENT= TeX package that supports drawing pictures
USES= zip
USE_TEX= latex
@@ -41,18 +41,14 @@ DOC_FILES= README changes.txt install.txt doc/coil.mps \
doc/mfpdoc.sty doc/mfpguide.pdf doc/mfpguide.tex \
doc/mfpic-doc.pdf doc/mfpic-doc.tex
-NO_STAGE= yes
do-build:
cd ${WRKDIR} && ${YES_CMD} | ${TEX_BIN} mfpic.ins
do-install:
cd ${WRKDIR} && \
- ${INSTALL_DATA} ${CLASS_FILES} ${PREFIX}/${CLASSDIR} && \
- ${INSTALL_DATA} ${MP_FILES} ${PREFIX}/${MPDIR} && \
- ${INSTALL_DATA} ${MF_FILES} ${PREFIX}/${MFDIR} && \
- ${INSTALL_DATA} ${DOC_FILES} ${PREFIX}/${DDIR}
-
-post-install:
- @${MKTEXLSR} ${LOCALBASE}/${TEXMFDIR}
+ ${INSTALL_DATA} ${CLASS_FILES} ${STAGEDIR}${PREFIX}/${CLASSDIR} && \
+ ${INSTALL_DATA} ${MP_FILES} ${STAGEDIR}${PREFIX}/${MPDIR} && \
+ ${INSTALL_DATA} ${MF_FILES} ${STAGEDIR}${PREFIX}/${MFDIR} && \
+ ${INSTALL_DATA} ${DOC_FILES} ${STAGEDIR}${PREFIX}/${DDIR}
.include <bsd.port.mk>
diff --git a/print/tex-xdvik/Makefile b/print/tex-xdvik/Makefile
index ceb278b68cf9..d1a354f077f1 100644
--- a/print/tex-xdvik/Makefile
+++ b/print/tex-xdvik/Makefile
@@ -43,23 +43,15 @@ PLIST_SUB= TEXMFDIR=${TEXMFDIR} TEXMFCONFIGDIR=${TEXMFDIR}-config
CONFLICTS_INSTALL= xdvi-[0-9]* xdvi-*-[0-9]* *-xdvi-[0-9]* \
xdvik-[0-9]* ja-xdvik-*-[0-9]*
-MAN1= xdvi.1
-
PORTDOCS= BUGS CHANGES INSTALL README README.CVS README.coding \
README.config README.cross README.distro README.hacking \
README.layout README.xdvik README_maintainer TODO
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKDIR}/${DISTNAME} && \
- ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/print/tex-xdvik/pkg-plist b/print/tex-xdvik/pkg-plist
index 5aaaab7e38ba..6006376cc30a 100644
--- a/print/tex-xdvik/pkg-plist
+++ b/print/tex-xdvik/pkg-plist
@@ -1,5 +1,6 @@
bin/xdvi
bin/xdvi-motif
+man/man1/xdvi.1.gz
%%TEXMFDIR%%/xdvi/XDvi
%%TEXMFDIR%%/xdvi/config.xdvi
%%TEXMFDIR%%/xdvi/pixmaps/toolbar.xpm
diff --git a/print/tex-xetex/Makefile b/print/tex-xetex/Makefile
index 38d4043d2661..0751d1167032 100644
--- a/print/tex-xetex/Makefile
+++ b/print/tex-xetex/Makefile
@@ -33,7 +33,7 @@ EXTRACT_FILES= \
libs/harfbuzz \
texk/web2c
EXTRACT_AFTER_ARGS_TEXMF= \
- | ${TAR} -xf - -C ${PREFIX}/share \
+ | ${TAR} -xf - -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner \
${EXTRACT_FILES_TEXMF:S,^,${DISTNAME_TEXMF}/,}
DISTNAME_TEXMF= texlive-20120701-texmf
@@ -79,14 +79,14 @@ CFLAGS+= -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE= yes
TEX_FORMATS= xetex
-NO_STAGE= yes
pre-configure:
for D in libs/harfbuzz libs/xpdf; do \
cd ${WRKDIR}/${DISTNAME}/$$D && \
${SETENV} ${CONFIGURE_ENV} ${SH} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; \
done
-pre-su-install:
+pre-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share
${CAT} ${DISTDIR}/${DIST_SUBDIR}/texlive-20120701-texmf${EXTRACT_SUFX} \
${EXTRACT_AFTER_ARGS_TEXMF}
diff --git a/print/tex-xmltex/Makefile b/print/tex-xmltex/Makefile
index 40f7ba366c85..a2cd5d35fdef 100644
--- a/print/tex-xmltex/Makefile
+++ b/print/tex-xmltex/Makefile
@@ -12,10 +12,10 @@ EXTRACT_ONLY=
MAINTAINER= hrs@FreeBSD.org
COMMENT= Non-validating XML parser, written in TeX
-USE_XZ= yes
+USES= tar:xz
USE_TEX= texlive texmf pdftex fmtutil
TEXHASHDIRS= ${TEXMFDISTDIR}
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - -C ${PREFIX}/share \
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - -C ${STAGEDIR}${PREFIX}/share \
--strip-components 1 --no-same-permission --no-same-owner \
${EXTRACT_FILES:S,^,${DISTNAME}/,}
EXTRACT_FILES= \
@@ -26,7 +26,6 @@ NO_WRKSRC= yes
NO_BUILD= yes
TEX_FORMATS= xmltex
-NO_STAGE= yes
do-install:
${CAT} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX} \
${EXTRACT_AFTER_ARGS}
diff --git a/print/tex-xmltex/pkg-plist b/print/tex-xmltex/pkg-plist
index 9b3008e6c3a3..3bf442e4e647 100644
--- a/print/tex-xmltex/pkg-plist
+++ b/print/tex-xmltex/pkg-plist
@@ -43,6 +43,7 @@
@dirrm %%TEXMFDISTDIR%%/doc/otherformats/xmltex/xmlplay
@dirrm %%TEXMFDISTDIR%%/doc/otherformats/xmltex/base
@dirrm %%TEXMFDISTDIR%%/doc/otherformats/xmltex
+@dirrm %%TEXMFDISTDIR%%/doc/otherformats
@dirrm %%TEXMFDISTDIR%%/tex/xmltex/xmlplay
@dirrm %%TEXMFDISTDIR%%/tex/xmltex/passivetex
@dirrm %%TEXMFDISTDIR%%/tex/xmltex/config
diff --git a/print/texlive-base/Makefile b/print/texlive-base/Makefile
index c3dae19bc3da..707aed1d476c 100644
--- a/print/texlive-base/Makefile
+++ b/print/texlive-base/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= libicuio.so:${PORTSDIR}/devel/icu \
libpoppler.so:${PORTSDIR}/graphics/poppler
USE_TEX= texlive web2c kpathsea ptexenc texhash-bootstrap
-USES= gmake pkgconfig perl5 tar:xz
+USES= gmake pkgconfig perl5 shebangfix tar:xz
USE_AUTOTOOLS= autoconf
USE_GHOSTSCRIPT=yes
USE_PERL5= run
@@ -97,6 +97,20 @@ CFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/ptexenc
PLIST_SUB= INSTALL_DATA="${INSTALL_DATA}"
+SHEBANG_FILES= texk/texlive/linked_scripts/*/*.pl \
+ texk/texlive/linked_scripts/findhyph/findhyph \
+ texk/texlive/linked_scripts/de-macro/de-macro \
+ texk/texlive/linked_scripts/uptex/convbkmk.rb \
+ texk/texlive/linked_scripts/accfonts/vpl2vpl \
+ texk/texlive/linked_scripts/exceltex/exceltex \
+ texk/texlive/linked_scripts/texdirflatten/texdirflatten \
+ texk/texlive/linked_scripts/bibexport/bibexport.sh \
+ texk/texlive/linked_scripts/urlbst/urlbst \
+ texk/texlive/linked_scripts/accfonts/mkt1font \
+ texk/texlive/linked_scripts/splitindex/perl/splitindex.pl \
+ texk/texlive/linked_scripts/accfonts/vpl2ovp \
+ texk/texlive/linked_scripts/installfont/installfont-tl
+
INFO= dvipng
post-patch:
@@ -109,8 +123,11 @@ post-patch:
post-install-fmtutil:
${MKDIR} ${STAGEDIR}${PREFIX}/${TEXMFCONFIGDIR}/web2c
${TOUCH} ${STAGEDIR}${PREFIX}/${TEXMFCONFIGDIR}/web2c/.keep_me
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${TEXMFLOCALDIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${TEXMFVARDIR}
${INSTALL_DATA} ${STAGEDIR}${PREFIX}/${TEXMFDIR}/web2c/fmtutil.cnf \
${STAGEDIR}${PREFIX}/${FMTUTIL_CNF}
+ ${CHMOD} 644 ${STAGEDIR}${PREFIX}/${TEXMFDIR}/web2c/fmtutil.cnf
post-install: post-install-fmtutil
.ORDER: post-install-fmtutil do-texhash
diff --git a/print/texlive-base/pkg-plist b/print/texlive-base/pkg-plist
index 791cab00275c..168640a2d928 100644
--- a/print/texlive-base/pkg-plist
+++ b/print/texlive-base/pkg-plist
@@ -417,8 +417,7 @@ man/man5/updmap.cfg.5.gz
%%TEXMFDIR%%/scripts/texlive/tlmgr.pl
%%TEXMFDIR%%/web2c/fmtutil.cnf
%%TEXMFCONFIGDIR%%/web2c/.keep_me
-@exec %%INSTALL_DATA%% %D/%%TEXMFDIR%%/web2c/fmtutil.cnf %D/%%FMTUTIL_CNF%%
-@unexec /bin/rm -f %D/%%FMTUTIL_CNF%%
+%%FMTUTIL_CNF%%
@dirrmtry %%TEXMFCONFIGDIR%%/web2c
@dirrmtry %%TEXMFCONFIGDIR%%
@dirrmtry %%TEXMFDISTDIR%%/scripts/accfonts
diff --git a/print/texlive-texmf/Makefile b/print/texlive-texmf/Makefile
index 42d9a11b10fb..f53839d6ae34 100644
--- a/print/texlive-texmf/Makefile
+++ b/print/texlive-texmf/Makefile
@@ -175,5 +175,11 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/$$D/doc && \
${TOUCH} ${STAGEDIR}${PREFIX}/$$D/doc/.keep_me; \
done
+ ${RM} -f ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/ls-R \
+ ${STAGEDIR}${PREFIX}/${TEXMFDIR}/ls-R \
+ ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/scripts/checkcites/checkcites.lua \
+ ${STAGEDIR}${PREFIX}/${TEXMFDIR}/scripts/texdoc/texdoc.tlu \
+ ${STAGEDIR}${PREFIX}/${TEXMFDIR}/scripts/texlive/rungs.tlu \
+ ${STAGEDIR}${PREFIX}/${TEXMFDIR}/scripts/texlive/tlmgr.pl
.include <bsd.port.mk>