aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-02-20 00:06:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-02-20 00:06:41 +0000
commita8f36b0b94273f8f437da188515a556e98f8d15f (patch)
tree94a9aec5a58b8f8fffc2bc5b089a070773dae586 /print
parent91769996e5679e36c416604b43aa31bdd719d7a1 (diff)
downloadports-a8f36b0b94273f8f437da188515a556e98f8d15f.tar.gz
ports-a8f36b0b94273f8f437da188515a556e98f8d15f.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/html2ps-letter/Makefile38
-rw-r--r--print/html2ps-letter/distinfo4
-rw-r--r--print/html2ps-letter/files/html2psrc.in23
-rw-r--r--print/html2ps-letter/files/patch-aa49
-rw-r--r--print/html2ps-letter/pkg-plist5
-rw-r--r--print/html2ps-letter/scripts/pre-configure9
6 files changed, 54 insertions, 74 deletions
diff --git a/print/html2ps-letter/Makefile b/print/html2ps-letter/Makefile
index 69ecc43f8b28..2f44496439ee 100644
--- a/print/html2ps-letter/Makefile
+++ b/print/html2ps-letter/Makefile
@@ -6,32 +6,52 @@
#
PORTNAME= html2ps
-DISTVERSION= 1.0b5
-PORTREVISION= 4
+DISTVERSION= 1.0b7
PORTEPOCH= 1
CATEGORIES= print www perl5
-MASTER_SITES= http://user.it.uu.se/~jan/
+MASTER_SITES= http://user.it.uu.se/~jan/ \
+ http://fossies.org/unix/www/
PKGNAMESUFFIX= -${PAPERSIZE}
MAINTAINER= ports@FreeBSD.org
COMMENT= HTML to PostScript converter
-USE_GHOSTSCRIPT_BUILD= yes
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= mogrify:${PORTSDIR}/graphics/ImageMagick \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
weblint:${PORTSDIR}/www/weblint
-USE_PERL5= YES
-NO_BUILD= YES
+NO_BUILD= yes
+USE_PERL5= yes
+USE_GHOSTSCRIPT_RUN= yes
-PAPERSIZE?= letter
+SUB_FILES= html2psrc
+SUB_LIST= PAPERSIZE="${PAPERSIZE}"
MAN1= html2ps.1
MAN5= html2psrc.5
-SCRIPTS_ENV+= PERL=${PERL} PAPERSIZE=${PAPERSIZE}
+PLIST_FILES= bin/html2ps \
+ %%DATADIR%%/html2ps.html \
+ %%DATADIR%%/html2psrc \
+ %%DATADIR%%/hyphen.tex
+PLIST_DIRS= %%DATADIR%%
+
+PAPERSIZE?= letter
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|exec perl|exec ${PERL}| ; \
+ s|/it/sw/share/www/lib/html2ps|${DATADIR}|' ${WRKSRC}/html2ps
do-install:
- @cd ${WRKSRC}; ${PERL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/html2ps ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/html2ps.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/html2psrc.5 ${MAN5PREFIX}/man/man5
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/html2psrc ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/html2ps.html ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/hyphen.tex ${DATADIR}
.include <bsd.port.mk>
diff --git a/print/html2ps-letter/distinfo b/print/html2ps-letter/distinfo
index 6cb941c4dc37..74e21c9b5e70 100644
--- a/print/html2ps-letter/distinfo
+++ b/print/html2ps-letter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (html2ps-1.0b5.tar.gz) = f71e425d5db2eda9578f4f4b019b14da42d39f69a802e5bdb9d4609ae8903e93
-SIZE (html2ps-1.0b5.tar.gz) = 128059
+SHA256 (html2ps-1.0b7.tar.gz) = d553980468a14bae738982c384c17f426ecf77dafd9a4e2499d520953f156f14
+SIZE (html2ps-1.0b7.tar.gz) = 128451
diff --git a/print/html2ps-letter/files/html2psrc.in b/print/html2ps-letter/files/html2psrc.in
new file mode 100644
index 000000000000..59f0b411c97b
--- /dev/null
+++ b/print/html2ps-letter/files/html2psrc.in
@@ -0,0 +1,23 @@
+/* Global configuration file for html2ps */
+
+@html2ps {
+ package {
+ ImageMagick: 1;
+ PerlMagick: 1;
+ djpeg: 1;
+ TeX: 1;
+ dvips: 1;
+ Ghostscript: 1;
+ check: weblint;
+ libwww-perl: 1;
+ path: "%%LOCALBASE%%/bin";
+ }
+ paper {
+ type: %%PAPERSIZE%%;
+ }
+ hyphenation {
+ en {
+ file: "%%DATADIR%%/hyphen.tex";
+ }
+ }
+}
diff --git a/print/html2ps-letter/files/patch-aa b/print/html2ps-letter/files/patch-aa
deleted file mode 100644
index fdda82ff61c5..000000000000
--- a/print/html2ps-letter/files/patch-aa
+++ /dev/null
@@ -1,49 +0,0 @@
---- install.orig Thu Aug 17 00:42:03 2000
-+++ install Thu Jan 4 17:23:05 2001
-@@ -1,5 +1,5 @@
- : # Use perl
--eval 'exec perl -S $0 "$@"'
-+eval 'exec !!PERL5!! -S $0 "$@"'
- if $running_under_some_shell;
-
- $vid=103;
-@@ -17,7 +17,7 @@
- $pathsep = ':';
- $dirsep = '/';
- $sys = 'unix';
-- $prefix = '/usr/local';
-+ $prefix = "!!PREFIX!!";
- } elsif (-e 'nul') {
- $pathsep = ';';
- $dirsep = '\\';
-@@ -198,9 +198,9 @@
- $ht = "\nTo use the automatic hyphenation feature, hyphenation pattern files\n"
- ."from the TeX distribution are needed.";
- $cophy = 1;
--if($exist{'TeX'}) {
-+if($exist{'share'}) {
- $hfile = "";
-- ($texdir = $dir{'TeX'}) =~ s|/bin$||;
-+ ($texdir = $dir{'share'}) =~ s|/bin$||;
- SW:for("texmf/tex/generic/hyphen","macros","inputs","lib/macros",
- "lib/inputs","lib/tex/macros","lib/tex/inputs") {
- if(-f "$texdir/$_/ushyph1.tex") {
-@@ -272,7 +272,7 @@
- &makedir($html,$def);
-
- $paper = "";
--&getval($format, "A4",
-+&getval($format, "!!PAPERSIZE!!",
- "\nEnter the default paper type, possible choices are:\nA0, A1, A2, A3, A4,"
- ." A5, A6, A7, A8, A9, A10,\nB0, B1, B2, B3, B4, B5, B6, B7, B8, B9, B10,\n"
- ."letter, legal, arche, archd, archc, archb, archa,\nflsa, flse, halfletter,"
-@@ -419,8 +419,7 @@
-
- sub getval {
- $text = $_[1]? "$_[2] [$_[1]]": $_[2];
-- print "$text: ";
-- ($_[0] = <STDIN>) =~ s/^\s+|[\/\s]+$//g;
-+ print "$text: $_[1]\n";
- $_[0] = $_[1] if(!$_[0]);
- }
- sub inst {
diff --git a/print/html2ps-letter/pkg-plist b/print/html2ps-letter/pkg-plist
deleted file mode 100644
index 6e4081c393ac..000000000000
--- a/print/html2ps-letter/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/html2ps
-lib/html2ps/html2ps.html
-lib/html2ps/html2psrc
-lib/html2ps/hyphen.tex
-@dirrm lib/html2ps
diff --git a/print/html2ps-letter/scripts/pre-configure b/print/html2ps-letter/scripts/pre-configure
deleted file mode 100644
index 96c9dabee87e..000000000000
--- a/print/html2ps-letter/scripts/pre-configure
+++ /dev/null
@@ -1,9 +0,0 @@
-#! /bin/sh
-
-perl -pi -e "s=!!PREFIX!!=$PREFIX=" ${WRKSRC}/install
-perl -pi -e "s=!!PERL5!!=$PERL=" ${WRKSRC}/install
-perl -pi -e "s=!!PAPERSIZE!!=$PAPERSIZE=" ${WRKSRC}/install
-perl -pi -e "s=!!PREFIX!!=$PREFIX=" ${WRKSRC}/html2ps
-perl -pi -e "s=!!PERL5!!=$PERL=" ${WRKSRC}/html2ps
-
-exit 0