aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 17:56:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 18:11:25 +0000
commita815dd9f694c1b41db13be1f799fc3820827bd46 (patch)
tree71d9df08c216d6c252aa2e130b26411cf9b7b88e /print
parentb4706be5aa7d4aae4ce4cdbab549980f0aa3bff4 (diff)
downloadports-a815dd9f694c1b41db13be1f799fc3820827bd46.tar.gz
ports-a815dd9f694c1b41db13be1f799fc3820827bd46.zip
print/py-ttfautohint-py: Update to 0.5.0
- Change MASTER_SITES to CHEESESHOP Changes: https://github.com/fonttools/ttfautohint-py/releases
Diffstat (limited to 'print')
-rw-r--r--print/py-ttfautohint-py/Makefile12
-rw-r--r--print/py-ttfautohint-py/distinfo6
-rw-r--r--print/py-ttfautohint-py/files/patch-setup.py47
3 files changed, 5 insertions, 60 deletions
diff --git a/print/py-ttfautohint-py/Makefile b/print/py-ttfautohint-py/Makefile
index 87e5b09596f5..b6f70680e57e 100644
--- a/print/py-ttfautohint-py/Makefile
+++ b/print/py-ttfautohint-py/Makefile
@@ -1,11 +1,9 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= ttfautohint-py
-PORTVERSION= 0.4.3
-PORTREVISION= 1
-DISTVERSIONPREFIX= v
-DISTVERSIONSUFFIX= .post1
+PORTVERSION= 0.5.0
CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
@@ -22,10 +20,4 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-GH_ACCOUNT= fonttools
-USE_GITHUB= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/print/py-ttfautohint-py/distinfo b/print/py-ttfautohint-py/distinfo
index 31084f45da81..aae89606bc35 100644
--- a/print/py-ttfautohint-py/distinfo
+++ b/print/py-ttfautohint-py/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1632664364
-SHA256 (fonttools-ttfautohint-py-v0.4.3.post1_GH0.tar.gz) = f26c92a3fde57bc66c526237f37d89c4d13c886b2d1fa9044bc391c0cdd3494c
-SIZE (fonttools-ttfautohint-py-v0.4.3.post1_GH0.tar.gz) = 186678
+TIMESTAMP = 1646058104
+SHA256 (ttfautohint-py-0.5.0.tar.gz) = 0212be8d5590bab2f0e47d827b5f84b5a7124089d94a1d8106ea5d4e155af639
+SIZE (ttfautohint-py-0.5.0.tar.gz) = 188072
diff --git a/print/py-ttfautohint-py/files/patch-setup.py b/print/py-ttfautohint-py/files/patch-setup.py
deleted file mode 100644
index ea98b5613b88..000000000000
--- a/print/py-ttfautohint-py/files/patch-setup.py
+++ /dev/null
@@ -1,47 +0,0 @@
---- setup.py.orig 2021-08-12 11:55:42 UTC
-+++ setup.py
-@@ -11,19 +11,8 @@ from io import open
-
-
- cmdclass = {}
--try:
-- from wheel.bdist_wheel import bdist_wheel
--except ImportError:
-- print("warning: wheel package is not installed", file=sys.stderr)
--else:
-- class UniversalBdistWheel(bdist_wheel):
-
-- def get_tag(self):
-- return ('py2.py3', 'none',) + bdist_wheel.get_tag(self)[2:]
-
-- cmdclass['bdist_wheel'] = UniversalBdistWheel
--
--
- class SharedLibrary(Extension):
-
- if sys.platform == "darwin":
-@@ -74,7 +63,6 @@ class SharedLibBuildExt(build_ext):
- verbose=self.verbose, dry_run=self.dry_run)
-
-
--cmdclass['build_ext'] = SharedLibBuildExt
-
- env = dict(os.environ)
- if sys.platform == "win32":
-@@ -109,7 +97,7 @@ with open("README.rst", "r", encoding="utf-8") as read
-
- setup(
- name="ttfautohint-py",
-- use_scm_version=True,
-+ use_scm_version={"fallback_version": "%%PORTVERSION%%"},
- description=("Python wrapper for ttfautohint, "
- "a free auto-hinter for TrueType fonts"),
- long_description=long_description,
-@@ -120,7 +108,6 @@ setup(
- platforms=["posix", "nt"],
- package_dir={"": "src/python"},
- packages=find_packages("src/python"),
-- ext_modules=[libttfautohint],
- zip_safe=False,
- cmdclass=cmdclass,
- setup_requires=['setuptools_scm'],