aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-15 13:40:35 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-15 13:40:35 +0000
commit9ec4f304417c2ebe6113d826c3649750962d928d (patch)
tree79144d18e17e0c4b222a16ae76bc1d295a0e890a /print
parent70d7d5dbbb06c8cd9ee402482200dc44a88902f9 (diff)
downloadports-9ec4f304417c2ebe6113d826c3649750962d928d.tar.gz
ports-9ec4f304417c2ebe6113d826c3649750962d928d.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/dviselect/Makefile9
-rw-r--r--print/dviselect/files/patch-ab20
-rw-r--r--print/dviselect/files/patch-lib::error.c53
3 files changed, 55 insertions, 27 deletions
diff --git a/print/dviselect/Makefile b/print/dviselect/Makefile
index 13c991d03e16..581267568e5f 100644
--- a/print/dviselect/Makefile
+++ b/print/dviselect/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dviselect
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= jmz
@@ -20,10 +21,4 @@ SCRIPTS_ENV= CFLAGS="${CFLAGS}"
MAN1= dviselect.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/dviselect/files/patch-ab b/print/dviselect/files/patch-ab
deleted file mode 100644
index 711f6f2ab1dc..000000000000
--- a/print/dviselect/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/error.c.orig Wed Nov 15 04:19:40 1989
-+++ lib/error.c Wed Sep 4 19:20:59 2002
-@@ -19,6 +19,7 @@
-
- #include <stdio.h>
- #include <varargs.h>
-+#include <errno.h>
-
- #ifdef lint
-
-@@ -31,9 +32,6 @@
- #else lint
-
- extern char *ProgName;
--extern int errno;
--extern char *sys_errlist[];
--extern int sys_nerr;
-
- error(va_alist)
- va_dcl
diff --git a/print/dviselect/files/patch-lib::error.c b/print/dviselect/files/patch-lib::error.c
new file mode 100644
index 000000000000..6e9fb918a4c3
--- /dev/null
+++ b/print/dviselect/files/patch-lib::error.c
@@ -0,0 +1,53 @@
+--- lib/error.c.orig Wed Nov 15 04:19:40 1989
++++ lib/error.c Wed Oct 15 06:38:57 2003
+@@ -18,7 +18,8 @@
+ */
+
+ #include <stdio.h>
+-#include <varargs.h>
++#include <stdarg.h>
++#include <errno.h>
+
+ #ifdef lint
+
+@@ -31,20 +32,15 @@
+ #else lint
+
+ extern char *ProgName;
+-extern int errno;
+-extern char *sys_errlist[];
+-extern int sys_nerr;
+
+-error(va_alist)
+- va_dcl
++error(char *fmt,...)
+ {
+ va_list l;
+ int quit, e;
+- char *fmt;
+
+ (void) fflush(stdout); /* sync error messages */
+ (void) fprintf(stderr, "%s: ", ProgName);
+- va_start(l);
++ va_start(l,fmt);
+ /* pick up the constant arguments: quit, errno, printf format */
+ quit = va_arg(l, int);
+ e = va_arg(l, int);
+@@ -69,15 +65,13 @@
+ exit(quit);
+ }
+
+-panic(va_alist)
+- va_dcl
++panic(char *fmt,...)
+ {
+ va_list l;
+- char *fmt;
+
+ (void) fflush(stdout);
+ (void) fprintf(stderr, "%s: panic: ", ProgName);
+- va_start(l);
++ va_start(l,fmt);
+ /* pick up the constant argument: printf format */
+ fmt = va_arg(l, char *);
+ #if defined(sys5) || defined(HAVE_VPRINTF)