aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-07-28 15:42:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-07-28 15:42:29 +0000
commitc6aea69ca8840747c23a808dab13ac1271545df2 (patch)
treee42832f7ac0acb8dffff6c64465f6bcd4bde9241 /print
parent13c47d46220c90bc7b2730dc3083d1c45cc4c165 (diff)
downloadports-c6aea69ca8840747c23a808dab13ac1271545df2.tar.gz
ports-c6aea69ca8840747c23a808dab13ac1271545df2.zip
Notes
Diffstat (limited to 'print')
-rw-r--r--print/pslib/Makefile25
-rw-r--r--print/pslib/distinfo4
-rw-r--r--print/pslib/pkg-plist4
3 files changed, 27 insertions, 6 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 68c4506c581b..de53e24fb331 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= pslib
-PORTVERSION= 0.2.5
+PORTVERSION= 0.2.6
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,10 +19,29 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_GNOME= gnomehack gnometarget intlhack pkgconfig
-USE_GETTEXT= yes
+USE_REINPLACE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB= GETTEXT=""
+.else
+PLIST_SUB= GETTEXT="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} < 500000)
+BROKEN= Doesn't build on < 5.x
+.endif
+
+post-configure:
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -E 's|(SUBDIRS = data include src) po|\1|' \
+ ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/print/pslib/distinfo b/print/pslib/distinfo
index 250a3ad381e7..0aa8e2f1635e 100644
--- a/print/pslib/distinfo
+++ b/print/pslib/distinfo
@@ -1,2 +1,2 @@
-MD5 (pslib-0.2.5.tar.gz) = 12cf52461658fe32524975896771b66d
-SIZE (pslib-0.2.5.tar.gz) = 477049
+MD5 (pslib-0.2.6.tar.gz) = 6727e5086c7e6795e7b0db6f49442a2e
+SIZE (pslib-0.2.6.tar.gz) = 486812
diff --git a/print/pslib/pkg-plist b/print/pslib/pkg-plist
index 4d9584fcb130..1de64ae5ab72 100644
--- a/print/pslib/pkg-plist
+++ b/print/pslib/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
include/libps/pslib-mp.h
include/libps/pslib.h
include/libps/psversion.h
@@ -5,7 +6,8 @@ lib/libps.a
lib/libps.so
lib/libps.so.2
libdata/pkgconfig/libps.pc
-share/locale/de/LC_MESSAGES/pslib.mo
+%%GETTEXT%%share/locale/de/LC_MESSAGES/pslib.mo
+%%GETTEXT%%@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
%%DATADIR%%/draft.ps
%%DATADIR%%/exectime.ps
%%DATADIR%%/grid.ps