aboutsummaryrefslogtreecommitdiff
path: root/russian/netscape4.language/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2000-08-10 09:39:39 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2000-08-10 09:39:39 +0000
commitaa2682a6a8837acdd9760c7a801d4ec24ae5ffa1 (patch)
tree05cb97140aa26a4b4ed78f31d98eaa4a6be7235b /russian/netscape4.language/Makefile
parentb010bfac91a2785fd8c4e91cc51292967cd4fa90 (diff)
downloadports-aa2682a6a8837acdd9760c7a801d4ec24ae5ffa1.tar.gz
ports-aa2682a6a8837acdd9760c7a801d4ec24ae5ffa1.zip
Notes
Diffstat (limited to 'russian/netscape4.language/Makefile')
-rw-r--r--russian/netscape4.language/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/russian/netscape4.language/Makefile b/russian/netscape4.language/Makefile
index f573894f97ff..57a66bc2e883 100644
--- a/russian/netscape4.language/Makefile
+++ b/russian/netscape4.language/Makefile
@@ -6,34 +6,32 @@
#
PORTNAME= netscape
-PORTVERSION= 3.01
+PORTVERSION= 4.7
+MASTER_SITES= http://koi8.pp.ru/
+DISTFILES= v4.7.subject.patch.txt
CATEGORIES= russian www
EXTRACT_ONLY= # empty
MAINTAINER= ache@FreeBSD.org
RUN_DEPENDS+= ${X11BASE}/lib/X11/nls/ru_SU.KOI8-R:${PORTSDIR}/russian/X.language
-RUN_DEPENDS+= netscape:${PORTSDIR}/www/netscape3
+RUN_DEPENDS+= netscape:${PORTSDIR}/www/netscape47-communicator
-RESTRICTED= "Includes a copyrighted file from Netscape"
NO_BUILD= YES
NO_WRKSUBDIR= YES
USE_X_PREFIX= YES
APPDEF= ${X11BASE}/lib/X11/app-defaults
-# no distfile to fetch
-do-fetch:
-
do-install:
if [ -f ${APPDEF}/Netscape ] ; then \
- ${GREP} -q '\.version:.*3\.01$$' ${APPDEF}/Netscape || \
+ ${GREP} -q '\.version:.*4\.7' ${APPDEF}/Netscape || \
${RM} ${APPDEF}/Netscape; \
fi
if [ ! -f ${APPDEF}/Netscape ] ; then \
- ${CP} /usr/local/lib/netscape/Netscape.ad ${APPDEF}/Netscape; \
+ ${CP} ${LOCALBASE}/lib/netscape/Netscape.ad ${APPDEF}/Netscape; \
fi
cd ${APPDEF}; ${GREP} -q koi8-r=BOLD Netscape || \
- patch < ${FILESDIR}/koi8-r_patch;
+ patch < ${DISTDIR}/${DISTFILES}
.include <bsd.port.mk>