aboutsummaryrefslogtreecommitdiff
path: root/russian/prawda
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-07-31 07:18:23 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-07-31 07:18:23 +0000
commitdcefc9c7b20afdc79b0a8ded99c4eb34a132cc17 (patch)
tree8c5c20abd2f1bf471c62aa42a5f7530c5b2894d8 /russian/prawda
parentf4c6e2cfe75b2de15c6639a39ba8085499925311 (diff)
downloadports-dcefc9c7b20afdc79b0a8ded99c4eb34a132cc17.tar.gz
ports-dcefc9c7b20afdc79b0a8ded99c4eb34a132cc17.zip
Notes
Diffstat (limited to 'russian/prawda')
-rw-r--r--russian/prawda/Makefile39
-rw-r--r--russian/prawda/distinfo2
-rw-r--r--russian/prawda/files/patch-aa158
-rw-r--r--russian/prawda/files/patch-bin-makefile10
-rw-r--r--russian/prawda/files/patch-src-face-dir.cpp12
-rw-r--r--russian/prawda/pkg-descr5
-rw-r--r--russian/prawda/pkg-plist196
7 files changed, 422 insertions, 0 deletions
diff --git a/russian/prawda/Makefile b/russian/prawda/Makefile
new file mode 100644
index 000000000000..37d0fef9d93e
--- /dev/null
+++ b/russian/prawda/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: prawda
+# Date created: 2004-07-28
+# Whom: Roman Bogorodskiy <bogordskiy@inbox.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= prawda
+PORTVERSION= 0.3.0
+CATEGORIES= russian
+MASTER_SITES= http://www.prawda.newmail.ru/
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= English-Russian translator
+
+USE_BZIP2= yes
+NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+CXXFLAGS+= -I${X11BASE}/include
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400010
+LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|ulong|unsigned long|g;;s|malloc.h|stdlib.h|g" ${WRKSRC}/src/face/video_x.cpp
+ @${REINPLACE_CMD} -e "s|g++|${CXX} ${CXXFLAGS}|g" ${WRKSRC}/src/bin/makefile.exe
+ @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" ${WRKSRC}/bin/makefile ${WRKSRC}/src/face/main.cpp
+
+do-build:
+ @cd ${WRKSRC}/bin && ${MAKE}
+
+do-install:
+ @cd ${WRKSRC}/bin && ${MAKE} install
+
+.include <bsd.port.post.mk>
diff --git a/russian/prawda/distinfo b/russian/prawda/distinfo
new file mode 100644
index 000000000000..998f9d0ae220
--- /dev/null
+++ b/russian/prawda/distinfo
@@ -0,0 +1,2 @@
+MD5 (prawda-0.3.0.tar.bz2) = bc07b0b816385d2179fff2bf27b76863
+SIZE (prawda-0.3.0.tar.bz2) = 5135365
diff --git a/russian/prawda/files/patch-aa b/russian/prawda/files/patch-aa
new file mode 100644
index 000000000000..476ab160ecbf
--- /dev/null
+++ b/russian/prawda/files/patch-aa
@@ -0,0 +1,158 @@
+--- src/face/common.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/face/common.cpp Wed Jul 28 19:39:14 2004
+@@ -9,7 +9,6 @@
+ # include <stdio.h>
+ # include <string.h>
+ # include <stdlib.h>
+-# include <malloc.h>
+ # include "mylib.h"
+ # include "video.h"
+ # include "color.h"
+--- src/face/edit1.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/face/edit1.cpp Wed Jul 28 19:39:29 2004
+@@ -7,7 +7,6 @@
+ /***************************************************************************/
+
+ # include <stdio.h>
+-# include <malloc.h>
+ # include <string.h>
+
+ # include "mylib.h"
+--- src/face/menu.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/face/menu.cpp Wed Jul 28 19:39:39 2004
+@@ -7,7 +7,6 @@
+ /*******************************************************************/
+
+ # include <stdio.h>
+-# include <malloc.h>
+ # include <string.h>
+
+ # include "mylib.h"
+--- src/face/slowo.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/face/slowo.cpp Wed Jul 28 19:39:51 2004
+@@ -7,7 +7,6 @@
+ /***************************************************************************/
+
+ # include <stdio.h>
+-# include <malloc.h>
+ # include <string.h>
+ # include <dirent.h>
+ # include <sys/types.h>
+--- src/face/slowo1.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/face/slowo1.cpp Wed Jul 28 19:40:03 2004
+@@ -6,7 +6,6 @@
+ // Анисимов Д.В. сегодня
+ /***************************************************************************/
+ # include <stdio.h>
+-# include <malloc.h>
+ # include <string.h>
+ # include <stdlib.h>
+ # include <dirent.h>
+--- src/face/slowo1.h.orig Wed Jul 28 19:36:02 2004
++++ src/face/slowo1.h Wed Jul 28 19:40:11 2004
+@@ -9,7 +9,6 @@
+ # define SLOWO1_H
+
+ # include <stdio.h>
+-# include <malloc.h>
+ # include <string.h>
+ # include <stdlib.h>
+ # include <dirent.h>
+--- src/face/video_os2.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/face/video_os2.cpp Wed Jul 28 19:40:24 2004
+@@ -6,7 +6,6 @@
+ // Анисимов Д.В. сегодня
+ /*******************************************************************/
+
+-# include <malloc.h>
+ # include <string.h>
+ # include <conio.h>
+ # include <mylib.h>
+--- src/face/video_t.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/face/video_t.cpp Wed Jul 28 19:47:21 2004
+@@ -6,7 +6,6 @@
+ // Анисимов Д.В. сегодня
+ /*******************************************************************/
+
+-# include <malloc.h>
+ # include <string.h>
+ # include <curses.h>
+ # include <mylib.h>
+@@ -470,7 +469,7 @@
+ { char shift=6 ;
+ int shift1=0 ;
+
+-# ifndef _SUN_
++# if !defined(_SUN_) && !defined(__FreeBSD__)
+ if( TermType==CONSOLE )
+ {
+ ioctl( 0,TIOCLINUX,&shift );
+--- src/trans/factorial.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/trans/factorial.cpp Wed Jul 28 19:38:06 2004
+@@ -1,5 +1,4 @@
+ # include <stdio.h>
+-# include <malloc.h>
+
+ struct t_Factorial
+ { short n, // величина факториала n!
+--- src/trans/grammar.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/trans/grammar.cpp Wed Jul 28 19:37:55 2004
+@@ -6,7 +6,6 @@
+ // Анисимов Д.В. сегодня
+ /***************************************************************************/
+ # include <stdio.h>
+-# include <malloc.h>
+ # include <string.h>
+ # include <stdlib.h>
+ # include <mylib.h>
+--- src/trans/list.h.orig Wed Jul 28 19:36:02 2004
++++ src/trans/list.h Wed Jul 28 19:38:13 2004
+@@ -8,8 +8,6 @@
+ # ifndef LIST_HPP
+ # define LIST_HPP
+
+-# include <malloc.h>
+-
+ void list_error( void );
+
+ # define DECLARE_LIST_TYPE( t,t1 ) \
+--- src/trans/mylib.h.orig Wed Jul 28 19:36:02 2004
++++ src/trans/mylib.h Wed Jul 28 19:38:25 2004
+@@ -9,7 +9,6 @@
+ # define MYLIB_H
+
+ # include <stdio.h>
+-# include <malloc.h>
+ # include <stdlib.h>
+
+ # define Err_Memory -2
+--- src/trans/slowo3.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/trans/slowo3.cpp Wed Jul 28 19:38:33 2004
+@@ -7,7 +7,6 @@
+ /***************************************************************************/
+
+ # include <stdio.h>
+-# include <malloc.h>
+ # include <string.h>
+ # include <stdlib.h>
+
+--- src/utils/kod.c.orig Wed Jul 28 19:36:02 2004
++++ src/utils/kod.c Wed Jul 28 19:54:22 2004
+@@ -3,7 +3,6 @@
+ */
+ # include <stdio.h>
+ # include <string.h>
+-# include <malloc.h>
+ # include <stdlib.h>
+
+ # include <dirent.h>
+--- src/utils/zdicts_compress.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/utils/zdicts_compress.cpp Wed Jul 28 19:54:41 2004
+@@ -38,7 +38,6 @@
+ *****************************************************************************/
+ # include <stdio.h>
+ # include <string.h>
+-# include <malloc.h>
+ # include <stdlib.h>
+ # include <mylib.cpp>
+
diff --git a/russian/prawda/files/patch-bin-makefile b/russian/prawda/files/patch-bin-makefile
new file mode 100644
index 000000000000..8c5802d47397
--- /dev/null
+++ b/russian/prawda/files/patch-bin-makefile
@@ -0,0 +1,10 @@
+--- bin/makefile.orig Thu Jul 29 06:55:15 2004
++++ bin/makefile Thu Jul 29 06:55:26 2004
+@@ -32,7 +32,6 @@
+ cp -r ../dicts/* /usr/local/share/prawda/dicts
+ cp -r ../grammar/* /usr/local/share/prawda/grammar
+ cp ../fonts/* /usr/local/share/prawda/fonts
+- /usr/sbin/chkfontpath -q -a /usr/local/share/prawda/fonts
+ cp ../language.rc /usr/local/share/prawda
+ cp ../prawdarc.local /usr/local/share/prawda
+ cp ../prawdarc.root /usr/local/share/prawda
diff --git a/russian/prawda/files/patch-src-face-dir.cpp b/russian/prawda/files/patch-src-face-dir.cpp
new file mode 100644
index 000000000000..e60a385c5ebb
--- /dev/null
+++ b/russian/prawda/files/patch-src-face-dir.cpp
@@ -0,0 +1,12 @@
+--- src/face/dir.cpp.orig Wed Jul 28 19:36:02 2004
++++ src/face/dir.cpp Wed Jul 28 19:45:24 2004
+@@ -329,7 +329,7 @@
+ short i,i1,j ;
+ char c[10] ;
+
+-struct tm *tm1 = localtime( &file.date );
++struct tm *tm1 = localtime( (const time_t*)&file.date );
+ minut = tm1->tm_min ;
+ uhr = tm1->tm_hour ;
+ tag = tm1->tm_mday ;
+
diff --git a/russian/prawda/pkg-descr b/russian/prawda/pkg-descr
new file mode 100644
index 000000000000..b7873dde7be1
--- /dev/null
+++ b/russian/prawda/pkg-descr
@@ -0,0 +1,5 @@
+Prawda is the first open-source translator (as it's author says). It supports
+english to russian and esperanto to russain translation and it has x11 and
+ncurses based user interface.
+
+WWW: http://www.prawda.newmail.ru/
diff --git a/russian/prawda/pkg-plist b/russian/prawda/pkg-plist
new file mode 100644
index 000000000000..a3bf7f0086ff
--- /dev/null
+++ b/russian/prawda/pkg-plist
@@ -0,0 +1,196 @@
+bin/prawda
+bin/prawda_x
+%%DATADIR%%/language.rc
+%%DATADIR%%/prawdarc.local
+%%DATADIR%%/prawdarc.root
+%%DATADIR%%/version
+%%DATADIR%%/z_man.rc
+%%DATADIR%%/z_preproc.rc
+%%DATADIR%%/dicts/zform/english/en_be
+%%DATADIR%%/dicts/zform/english/en_modal
+%%DATADIR%%/dicts/zform/english/en_tiny
+%%DATADIR%%/dicts/zform/english/en_sub_r
+%%DATADIR%%/dicts/zform/english/en_verb_r
+%%DATADIR%%/dicts/zform/esperanto/es_verb_r
+%%DATADIR%%/dicts/zform/esperanto/es_esti
+%%DATADIR%%/dicts/zform/esperanto/es_pronoun
+%%DATADIR%%/dicts/zform/esperanto/es_qadj
+%%DATADIR%%/dicts/zform/esperanto/es_qsub
+%%DATADIR%%/dicts/zform/esperanto/es_rel
+%%DATADIR%%/dicts/zform/esperanto/es_sub_r
+%%DATADIR%%/dicts/zform/esperanto/es_adj_r
+%%DATADIR%%/dicts/zform/russkij/ru_verb_r
+%%DATADIR%%/dicts/zform/russkij/ru_modal
+%%DATADIR%%/dicts/zform/russkij/ru_num
+%%DATADIR%%/dicts/zform/russkij/ru_num2
+%%DATADIR%%/dicts/zform/russkij/ru_order
+%%DATADIR%%/dicts/zform/russkij/ru_pronoun_1
+%%DATADIR%%/dicts/zform/russkij/ru_pronoun_2
+%%DATADIR%%/dicts/zform/russkij/ru_pronoun_3
+%%DATADIR%%/dicts/zform/russkij/ru_pronoun_4
+%%DATADIR%%/dicts/zform/russkij/ru_pronoun_i
+%%DATADIR%%/dicts/zform/russkij/ru_quest
+%%DATADIR%%/dicts/zform/russkij/ru_quest_a
+%%DATADIR%%/dicts/zform/russkij/ru_quest_s
+%%DATADIR%%/dicts/zform/russkij/ru_tiny
+%%DATADIR%%/dicts/zform/russkij/ru_adj_r
+%%DATADIR%%/dicts/zform/russkij/ru_sub_r
+%%DATADIR%%/dicts/zform/russkij/ru_esti
+%%DATADIR%%/dicts/esperanto_russkij/base_esru
+%%DATADIR%%/dicts/esperanto_russkij/base_esru1
+%%DATADIR%%/dicts/esperanto_russkij/bokarev
+%%DATADIR%%/dicts/esperanto_russkij/es_macro
+%%DATADIR%%/dicts/english_russian/base_fverb
+%%DATADIR%%/dicts/english_russian/base_enru1
+%%DATADIR%%/dicts/english_russian/base_fverb_be
+%%DATADIR%%/dicts/english_russian/base_enru
+%%DATADIR%%/dicts/english_russian/base_pre
+%%DATADIR%%/dicts/english_russian/base_post
+%%DATADIR%%/dicts/english_russian/muller
+%%DATADIR%%/grammar/esperanto_russkij/lang.txt
+%%DATADIR%%/grammar/esperanto_russkij/adv.h
+%%DATADIR%%/grammar/esperanto_russkij/atom.h
+%%DATADIR%%/grammar/esperanto_russkij/core1.h
+%%DATADIR%%/grammar/esperanto_russkij/core.h
+%%DATADIR%%/grammar/esperanto_russkij/format_es.h
+%%DATADIR%%/grammar/esperanto_russkij/format_r.h
+%%DATADIR%%/grammar/esperanto_russkij/imperativ.h
+%%DATADIR%%/grammar/esperanto_russkij/lang.cpp
+%%DATADIR%%/grammar/esperanto_russkij/lang.h
+%%DATADIR%%/grammar/esperanto_russkij/main.h
+%%DATADIR%%/grammar/esperanto_russkij/mklang
+%%DATADIR%%/grammar/esperanto_russkij/num.h
+%%DATADIR%%/grammar/esperanto_russkij/patch.h
+%%DATADIR%%/grammar/esperanto_russkij/sub.h
+%%DATADIR%%/grammar/esperanto_russkij/unorder.h
+%%DATADIR%%/grammar/esperanto_russkij/verb1.h
+%%DATADIR%%/grammar/esperanto_russkij/verb.h
+%%DATADIR%%/grammar/esperanto_russkij/verb_modal.h
+%%DATADIR%%/grammar/esperanto_russkij/w_frasa.h
+%%DATADIR%%/grammar/esperanto_russkij/adj.h
+%%DATADIR%%/grammar/english_russian/lang.txt
+%%DATADIR%%/grammar/english_russian/adv.h
+%%DATADIR%%/grammar/english_russian/atom.h
+%%DATADIR%%/grammar/english_russian/core.h
+%%DATADIR%%/grammar/english_russian/dis_quest.h
+%%DATADIR%%/grammar/english_russian/format_a.h
+%%DATADIR%%/grammar/english_russian/format_r.h
+%%DATADIR%%/grammar/english_russian/lang.cpp
+%%DATADIR%%/grammar/english_russian/lang.h
+%%DATADIR%%/grammar/english_russian/mklang
+%%DATADIR%%/grammar/english_russian/next_chance.h
+%%DATADIR%%/grammar/english_russian/num.h
+%%DATADIR%%/grammar/english_russian/sub.h
+%%DATADIR%%/grammar/english_russian/tail.h
+%%DATADIR%%/grammar/english_russian/tail_is.h
+%%DATADIR%%/grammar/english_russian/verb_be.h
+%%DATADIR%%/grammar/english_russian/verb_c.h
+%%DATADIR%%/grammar/english_russian/verb.h
+%%DATADIR%%/grammar/english_russian/verb_have.h
+%%DATADIR%%/grammar/english_russian/verb_mod_be.h
+%%DATADIR%%/grammar/english_russian/verb_mod.h
+%%DATADIR%%/grammar/english_russian/verb_mod_have.h
+%%DATADIR%%/grammar/english_russian/verb_there_is.h
+%%DATADIR%%/grammar/english_russian/wh_frasa.h
+%%DATADIR%%/grammar/english_russian/adj.h
+%%DATADIR%%/fonts/koi6x13.pcf.gz
+%%DATADIR%%/fonts/fonts.dir
+%%DOCSDIR%%/help/about.html
+%%DOCSDIR%%/help/tip9.html
+%%DOCSDIR%%/help/tip8.html
+%%DOCSDIR%%/help/tip7.html
+%%DOCSDIR%%/help/tip6.html
+%%DOCSDIR%%/help/tip5.html
+%%DOCSDIR%%/help/tip4.html
+%%DOCSDIR%%/help/tip3.html
+%%DOCSDIR%%/help/tip2.html
+%%DOCSDIR%%/help/tip1.html
+%%DOCSDIR%%/help/tip0.html
+%%DOCSDIR%%/help/src.html
+%%DOCSDIR%%/help/slowo3.html
+%%DOCSDIR%%/help/slowo1.html
+%%DOCSDIR%%/help/slowo.html
+%%DOCSDIR%%/help/path.html
+%%DOCSDIR%%/help/newwords1.html
+%%DOCSDIR%%/help/newwords.html
+%%DOCSDIR%%/help/menu.html
+%%DOCSDIR%%/help/index.html
+%%DOCSDIR%%/help/howto.html
+%%DOCSDIR%%/help/help.html
+%%DOCSDIR%%/help/grammar.html
+%%DOCSDIR%%/help/first.html
+%%DOCSDIR%%/help/empty.html
+%%DOCSDIR%%/help/edit.html
+%%DOCSDIR%%/help/debug.html
+%%DOCSDIR%%/help/base_enru.html
+%%DOCSDIR%%/help/windows.html
+%%DOCSDIR%%/latex/source.ps
+%%DOCSDIR%%/latex/lang.ps
+%%DOCSDIR%%/latex/interface.ps
+%%DOCSDIR%%/latex/idea.ps
+%%DOCSDIR%%/latex/grammar.ps
+%%DOCSDIR%%/latex/esperanto.ps
+%%DOCSDIR%%/html_grammar/esperanto/index.html
+%%DOCSDIR%%/html_grammar/esperanto/atom.h.html
+%%DOCSDIR%%/html_grammar/esperanto/num.h.html
+%%DOCSDIR%%/html_grammar/esperanto/sub.h.html
+%%DOCSDIR%%/html_grammar/esperanto/adj.h.html
+%%DOCSDIR%%/html_grammar/esperanto/adv.h.html
+%%DOCSDIR%%/html_grammar/esperanto/verb.h.html
+%%DOCSDIR%%/html_grammar/esperanto/verb1.h.html
+%%DOCSDIR%%/html_grammar/esperanto/verb_modal.h.html
+%%DOCSDIR%%/html_grammar/esperanto/unorder.h.html
+%%DOCSDIR%%/html_grammar/esperanto/core.h.html
+%%DOCSDIR%%/html_grammar/esperanto/core1.h.html
+%%DOCSDIR%%/html_grammar/esperanto/w_frasa.h.html
+%%DOCSDIR%%/html_grammar/esperanto/patch.h.html
+%%DOCSDIR%%/html_grammar/esperanto/main.h.html
+%%DOCSDIR%%/html_grammar/esperanto/lang.cpp.html
+%%DOCSDIR%%/html_grammar/esperanto/lang.h.html
+%%DOCSDIR%%/html_grammar/english/index.html
+%%DOCSDIR%%/html_grammar/english/atom.h.html
+%%DOCSDIR%%/html_grammar/english/num.h.html
+%%DOCSDIR%%/html_grammar/english/sub.h.html
+%%DOCSDIR%%/html_grammar/english/adj.h.html
+%%DOCSDIR%%/html_grammar/english/adv.h.html
+%%DOCSDIR%%/html_grammar/english/verb.h.html
+%%DOCSDIR%%/html_grammar/english/verb_be.h.html
+%%DOCSDIR%%/html_grammar/english/verb_there_is.h.html
+%%DOCSDIR%%/html_grammar/english/verb_have.h.html
+%%DOCSDIR%%/html_grammar/english/verb_mod.h.html
+%%DOCSDIR%%/html_grammar/english/verb_mod_be.h.html
+%%DOCSDIR%%/html_grammar/english/verb_mod_have.h.html
+%%DOCSDIR%%/html_grammar/english/verb_c.h.html
+%%DOCSDIR%%/html_grammar/english/tail.h.html
+%%DOCSDIR%%/html_grammar/english/tail_is.h.html
+%%DOCSDIR%%/html_grammar/english/wh_frasa.h.html
+%%DOCSDIR%%/html_grammar/english/core.h.html
+%%DOCSDIR%%/html_grammar/english/dis_quest.h.html
+%%DOCSDIR%%/html_grammar/english/next_chance.h.html
+%%DOCSDIR%%/html_grammar/english/lang.cpp.html
+%%DOCSDIR%%/html_grammar/english/lang.h.html
+%%DOCSDIR%%/html_grammar/index.html
+%%DOCSDIR%%/releasenote.txt
+%%DOCSDIR%%/programmer.txt
+%%DOCSDIR%%/preproc.txt
+%%DOCSDIR%%/install.txt
+%%DOCSDIR%%/comrade.txt
+%%DOCSDIR%%/about.txt
+@dirrm %%DATADIR%%/dicts/english_russian
+@dirrm %%DATADIR%%/dicts/esperanto_russkij
+@dirrm %%DATADIR%%/dicts/zform/english
+@dirrm %%DATADIR%%/dicts/zform/esperanto
+@dirrm %%DATADIR%%/dicts/zform/russkij
+@dirrm %%DATADIR%%/dicts/zform
+@dirrm %%DATADIR%%/dicts
+@dirrm %%DATADIR%%/grammar/english_russian
+@dirrm %%DATADIR%%/grammar/esperanto_russkij
+@dirrm %%DATADIR%%/grammar
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%/help
+@dirrm %%DOCSDIR%%/latex
+@dirrm %%DOCSDIR%%/html_grammar/english
+@dirrm %%DOCSDIR%%/html_grammar/esperanto
+@dirrm %%DOCSDIR%%/html_grammar
+@dirrm %%DOCSDIR%%