aboutsummaryrefslogtreecommitdiff
path: root/russian/xruskb/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-05 23:04:04 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-05 23:04:04 +0000
commitbda690a1548fa9a25780c149bd5c1ffa660ec43c (patch)
tree4e0b2ea6590b68dcd17a0f0415dd116d38b9247d /russian/xruskb/Makefile
parentd7dfe6c7698fdefa7004042c558ea680682286fe (diff)
downloadports-bda690a1548fa9a25780c149bd5c1ffa660ec43c.tar.gz
ports-bda690a1548fa9a25780c149bd5c1ffa660ec43c.zip
Notes
Diffstat (limited to 'russian/xruskb/Makefile')
-rw-r--r--russian/xruskb/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/russian/xruskb/Makefile b/russian/xruskb/Makefile
index 84763ae466b9..bd8168db3ff9 100644
--- a/russian/xruskb/Makefile
+++ b/russian/xruskb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xruskb
PORTVERSION= 1.15.3
+PORTREVISION= 1
CATEGORIES= russian x11
MASTER_SITES= ftp://ftp.yars.free.net/pub/software/unix/X11/
@@ -17,15 +18,28 @@ USE_X_PREFIX= YES
USE_BZIP2= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --datadir=${PREFIX}/share
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.if defined(WITH_MOTIF)
+CONFIGURE_ARGS+= --with-toolkit=motif
+LIB_DEPENDS= Xm.3:${PORTSDIR}/x11-toolkits/open-motif
+.else
+CONFIGURE_ARGS+= --with-toolkit=none
+
+pre-configure:
+ @${ECHO_MSG} "*"
+ @${ECHO_MSG} "* Use WITH_MOTIF=yes to enable using pixmaps in indicator icon"
+ @${ECHO_MSG} "*"
+.endif
MAN1= xrus.1
+DOCS= FAQ NEWS README* TODO xrus.doc-*
post-install:
${INSTALL_DATA} ${WRKSRC}/Xrus.ad ${PREFIX}/lib/X11/app-defaults/Xrus
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/xruskb
- ${INSTALL_DATA} ${WRKSRC}/xrus.doc-english ${PREFIX}/share/doc/xruskb
- ${INSTALL_DATA} ${WRKSRC}/xrus.doc-koi8 ${PREFIX}/share/doc/xruskb
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>