aboutsummaryrefslogtreecommitdiff
path: root/russian
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /russian
parent42651c13cd4978964674808cab47a30c8726769b (diff)
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'russian')
-rw-r--r--russian/p5-XML-Parser-encodings/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/russian/p5-XML-Parser-encodings/Makefile b/russian/p5-XML-Parser-encodings/Makefile
index e8d5f7cb3549..b29bc73aaf21 100644
--- a/russian/p5-XML-Parser-encodings/Makefile
+++ b/russian/p5-XML-Parser-encodings/Makefile
@@ -27,8 +27,8 @@ PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
post-extract:
.for ICONVPORT in iconv iconv-extra
@${LN} -sfh \
- `cd ${PORTSDIR}/converters/${ICONVPORT} && ${MAKE} -V WRKSRC`/ccs \
- ${WRKSRC}/${ICONVPORT}
+ `cd ${PORTSDIR}/converters/${ICONVPORT} && ${MAKE} -V WRKSRC`/ccs \
+ ${WRKSRC}/${ICONVPORT}
.endfor
do-configure:
@@ -47,7 +47,7 @@ do-build:
.endfor
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/XML/Parser/Encodings
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/XML/Parser/Encodings
${INSTALL_DATA} ${WRKSRC}/*.enc \
${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/XML/Parser/Encodings