aboutsummaryrefslogtreecommitdiff
path: root/russian
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2004-05-22 17:38:21 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2004-05-22 17:38:21 +0000
commit85493fa2cb2efea4b72de94ababbc1e2edc65962 (patch)
treed5f1ed9e709efd151ace461d696a0b8b6ca84a21 /russian
parent29684deb824cbcda5b59ad331748b896011efe12 (diff)
downloadports-85493fa2cb2efea4b72de94ababbc1e2edc65962.tar.gz
ports-85493fa2cb2efea4b72de94ababbc1e2edc65962.zip
Notes
Diffstat (limited to 'russian')
-rw-r--r--russian/apache13-modssl/Makefile6
-rw-r--r--russian/apache13-modssl/distinfo9
-rw-r--r--russian/apache13-modssl/files/patch-mod_access.c113
-rw-r--r--russian/apache13-modssl/pkg-plist16
4 files changed, 20 insertions, 124 deletions
diff --git a/russian/apache13-modssl/Makefile b/russian/apache13-modssl/Makefile
index da8719e9a61e..559ff60dbf7f 100644
--- a/russian/apache13-modssl/Makefile
+++ b/russian/apache13-modssl/Makefile
@@ -55,9 +55,9 @@ DOCSDIR= ${PREFIX}/share/doc/apache
.include <bsd.port.pre.mk>
-VERSION_APACHE= 1.3.29
-VERSION_MODSSL= 2.8.16
-VERSION_RA= 30.19
+VERSION_APACHE= 1.3.31
+VERSION_MODSSL= 2.8.17
+VERSION_RA= 30.20
#
# some defaults
diff --git a/russian/apache13-modssl/distinfo b/russian/apache13-modssl/distinfo
index 25f00c8c5b30..5bbf1390a443 100644
--- a/russian/apache13-modssl/distinfo
+++ b/russian/apache13-modssl/distinfo
@@ -1,3 +1,6 @@
-MD5 (apache_1.3.29.tar.gz) = e97fe9bf51dc2c9c233d53f63b1347e3
-MD5 (mod_ssl-2.8.16-1.3.29.tar.gz) = 4f6c580ffa07d33e8584406132b98e86
-MD5 (patches_1.3.29rusPL30.19.tar.gz) = 58d4c5305cc80cf76d744a9722958320
+MD5 (apache_1.3.31.tar.gz) = bd548a06ac48dda496b4e613572bb020
+SIZE (apache_1.3.31.tar.gz) = 2467371
+MD5 (mod_ssl-2.8.17-1.3.31.tar.gz) = 6c3f726b336f497793567591717d2a6b
+SIZE (mod_ssl-2.8.17-1.3.31.tar.gz) = 754472
+MD5 (patches_1.3.31rusPL30.20.tar.gz) = da983bb4a4e983cba55390afe4569f04
+SIZE (patches_1.3.31rusPL30.20.tar.gz) = 138924
diff --git a/russian/apache13-modssl/files/patch-mod_access.c b/russian/apache13-modssl/files/patch-mod_access.c
deleted file mode 100644
index f01bb6890292..000000000000
--- a/russian/apache13-modssl/files/patch-mod_access.c
+++ /dev/null
@@ -1,113 +0,0 @@
---- src/modules/standard/mod_access.c 2004/02/20 20:37:40 1.46
-+++ src/modules/standard/mod_access.c 2004/03/07 21:47:14 1.47
-@@ -39,8 +39,8 @@
- union {
- char *from;
- struct {
-- unsigned long net;
-- unsigned long mask;
-+ struct in_addr net;
-+ struct in_addr mask;
- } ip;
- } x;
- enum allowdeny_type type;
-@@ -124,14 +124,14 @@
-
- }
- else if ((s = strchr(where, '/'))) {
-- unsigned long mask;
-+ struct in_addr mask;
-
- a->type = T_IP;
- /* trample on where, we won't be using it any more */
- *s++ = '\0';
-
- if (!is_ip(where)
-- || (a->x.ip.net = ap_inet_addr(where)) == INADDR_NONE) {
-+ || (a->x.ip.net.s_addr = ap_inet_addr(where)) == INADDR_NONE) {
- a->type = T_FAIL;
- return "syntax error in network portion of network/netmask";
- }
-@@ -143,24 +143,26 @@
- }
- /* is it in /a.b.c.d form? */
- if (strchr(s, '.')) {
-- mask = ap_inet_addr(s);
-- if (mask == INADDR_NONE) {
-+ mask.s_addr = ap_inet_addr(s);
-+ if (mask.s_addr == INADDR_NONE) {
- a->type = T_FAIL;
- return "syntax error in mask portion of network/netmask";
- }
- }
- else {
-+ int i;
-+
- /* assume it's in /nnn form */
-- mask = atoi(s);
-- if (mask > 32 || mask <= 0) {
-+ i = atoi(s);
-+ if (i > 32 || i <= 0) {
- a->type = T_FAIL;
- return "invalid mask in network/netmask";
- }
-- mask = 0xFFFFFFFFUL << (32 - mask);
-- mask = htonl(mask);
-+ mask.s_addr = 0xFFFFFFFFUL << (32 - i);
-+ mask.s_addr = htonl(mask.s_addr);
- }
- a->x.ip.mask = mask;
-- a->x.ip.net = (a->x.ip.net & mask); /* pjr - This fixes PR 4770 */
-+ a->x.ip.net.s_addr = (a->x.ip.net.s_addr & mask.s_addr); /* pjr - This fixes PR 4770 */
- }
- else if (ap_isdigit(*where) && is_ip(where)) {
- /* legacy syntax for ip addrs: a.b.c. ==> a.b.c.0/24 for example */
-@@ -171,8 +173,8 @@
- a->type = T_IP;
- /* parse components */
- s = where;
-- a->x.ip.net = 0;
-- a->x.ip.mask = 0;
-+ a->x.ip.net.s_addr = 0;
-+ a->x.ip.mask.s_addr = 0;
- shift = 24;
- while (*s) {
- t = s;
-@@ -191,6 +193,7 @@
- return "invalid ip address";
- }
- if (shift < 0) {
-+ a->type = T_FAIL;
- return "invalid ip address, only 4 octets allowed";
- }
- octet = atoi(s);
-@@ -198,13 +201,13 @@
- a->type = T_FAIL;
- return "each octet must be between 0 and 255 inclusive";
- }
-- a->x.ip.net |= octet << shift;
-- a->x.ip.mask |= 0xFFUL << shift;
-+ a->x.ip.net.s_addr |= (unsigned int)octet << shift;
-+ a->x.ip.mask.s_addr |= 0xFFUL << shift;
- s = t;
- shift -= 8;
- }
-- a->x.ip.net = ntohl(a->x.ip.net);
-- a->x.ip.mask = ntohl(a->x.ip.mask);
-+ a->x.ip.net.s_addr = ntohl(a->x.ip.net.s_addr);
-+ a->x.ip.mask.s_addr = ntohl(a->x.ip.mask.s_addr);
- }
- else {
- a->type = T_HOST;
-@@ -272,9 +275,9 @@
- return 1;
-
- case T_IP:
-- if (ap[i].x.ip.net != INADDR_NONE
-+ if (ap[i].x.ip.net.s_addr != INADDR_NONE
- && (r->connection->remote_addr.sin_addr.s_addr
-- & ap[i].x.ip.mask) == ap[i].x.ip.net) {
-+ & ap[i].x.ip.mask.s_addr) == ap[i].x.ip.net.s_addr) {
- return 1;
- }
- break;
diff --git a/russian/apache13-modssl/pkg-plist b/russian/apache13-modssl/pkg-plist
index 4830452279bc..e8a312a5e338 100644
--- a/russian/apache13-modssl/pkg-plist
+++ b/russian/apache13-modssl/pkg-plist
@@ -244,6 +244,7 @@ libexec/apache/mod_digest.so
libexec/apache/mod_expires.so
libexec/apache/mod_headers.so
libexec/apache/mod_info.so
+libexec/apache/mod_log_forensic.so
libexec/apache/mod_mime_magic.so
libexec/apache/mod_mmap_static.so
libexec/apache/mod_rewrite.so
@@ -295,6 +296,7 @@ sbin/rotatelogs
%%DOCSDIR%%/index.html.es
%%DOCSDIR%%/index.html.fr
%%DOCSDIR%%/index.html.he.iso8859-8
+%%DOCSDIR%%/index.html.hu
%%DOCSDIR%%/index.html.it
%%DOCSDIR%%/index.html.ja.jis
%%DOCSDIR%%/index.html.kr.iso-kr
@@ -316,7 +318,6 @@ sbin/rotatelogs
%%DOCSDIR%%/index.html.se
%%DOCSDIR%%/index.html.zh-tw.big5
%%DOCSDIR%%/manual/LICENSE
-%%DOCSDIR%%/manual/FAQ.html
%%DOCSDIR%%/manual/bind.html.en
%%DOCSDIR%%/manual/bind.html.fr
%%DOCSDIR%%/manual/bind.html.html
@@ -390,7 +391,9 @@ sbin/rotatelogs
%%DOCSDIR%%/manual/keepalive.html.en
%%DOCSDIR%%/manual/keepalive.html.html
%%DOCSDIR%%/manual/keepalive.html.ja.jis
-%%DOCSDIR%%/manual/location.html
+%%DOCSDIR%%/manual/location.html.en
+%%DOCSDIR%%/manual/location.html.html
+%%DOCSDIR%%/manual/location.html.ja.jis
%%DOCSDIR%%/manual/logs.html
%%DOCSDIR%%/manual/man-template.html
%%DOCSDIR%%/manual/misc/API.html
@@ -460,7 +463,9 @@ sbin/rotatelogs
%%DOCSDIR%%/manual/mod/mod_auth_db.html
%%DOCSDIR%%/manual/mod/mod_auth_dbm.html
%%DOCSDIR%%/manual/mod/mod_auth_digest.html
-%%DOCSDIR%%/manual/mod/mod_autoindex.html
+%%DOCSDIR%%/manual/mod/mod_autoindex.html.en
+%%DOCSDIR%%/manual/mod/mod_autoindex.html.html
+%%DOCSDIR%%/manual/mod/mod_autoindex.html.ja.jis
%%DOCSDIR%%/manual/mod/mod_browser.html
%%DOCSDIR%%/manual/mod/mod_cern_meta.html
%%DOCSDIR%%/manual/mod/mod_cgi.html.en
@@ -489,6 +494,8 @@ sbin/rotatelogs
%%DOCSDIR%%/manual/mod/mod_log_config.html.en
%%DOCSDIR%%/manual/mod/mod_log_config.html.html
%%DOCSDIR%%/manual/mod/mod_log_config.html.ja.jis
+%%DOCSDIR%%/manual/mod/mod_log_forensic.html.en
+%%DOCSDIR%%/manual/mod/mod_log_forensic.html.html
%%DOCSDIR%%/manual/mod/mod_log_referer.html
%%DOCSDIR%%/manual/mod/mod_mime.html.en
%%DOCSDIR%%/manual/mod/mod_mime.html.html
@@ -615,7 +622,6 @@ sbin/rotatelogs
%%DOCSDIR%%/manual/programs/suexec.html.html
%%DOCSDIR%%/manual/programs/suexec.html.ja.jis
%%DOCSDIR%%/manual/readme-tpf.html
-%%DOCSDIR%%/manual/search/manual-index.cgi
%%DOCSDIR%%/manual/sections.html.en
%%DOCSDIR%%/manual/sections.html.html
%%DOCSDIR%%/manual/sections.html.ja.jis
@@ -661,6 +667,7 @@ sbin/rotatelogs
%%DOCSDIR%%/manual/win_service.html.html
%%DOCSDIR%%/manual/win_service.html.ja.jis
%%DOCSDIR%%/manual/windows.html.en
+%%DOCSDIR%%/manual/windows.html.html
%%DOCSDIR%%/manual/windows.html.ja.jis
www/cgi-bin.default/printenv
www/cgi-bin.default/test-cgi
@@ -909,7 +916,6 @@ www/icons/world2.png
@dirrm %%DOCSDIR%%/manual/mod/mod_ssl
@dirrm %%DOCSDIR%%/manual/mod
@dirrm %%DOCSDIR%%/manual/programs
-@dirrm %%DOCSDIR%%/manual/search
@dirrm %%DOCSDIR%%/manual/vhosts
@dirrm %%DOCSDIR%%/manual
@dirrm %%DOCSDIR%%