aboutsummaryrefslogtreecommitdiff
path: root/russian
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2013-09-12 15:12:49 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2013-09-12 15:12:49 +0000
commita8125260aa8cb21285ce1ba54a59a4b5d80790ed (patch)
tree5ce55c29175b60d55490b221b7147c6c374f2577 /russian
parenta49546124d8b81611ec8c4087617e9e9b1ad7a72 (diff)
downloadports-a8125260aa8cb21285ce1ba54a59a4b5d80790ed.tar.gz
ports-a8125260aa8cb21285ce1ba54a59a4b5d80790ed.zip
Notes
Diffstat (limited to 'russian')
-rw-r--r--russian/prawda/Makefile9
-rw-r--r--russian/prawda/files/patch-src-face-main.cpp11
2 files changed, 14 insertions, 6 deletions
diff --git a/russian/prawda/Makefile b/russian/prawda/Makefile
index 723d01b94742..9e2d45bf0a24 100644
--- a/russian/prawda/Makefile
+++ b/russian/prawda/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: prawda
-# Date created: 2004-07-28
-# Whom: Roman Bogorodskiy <bogordskiy@inbox.ru>
-#
# $FreeBSD$
-#
PORTNAME= prawda
PORTVERSION= 0.3.0
@@ -11,7 +6,7 @@ PORTREVISION= 4
CATEGORIES= russian
MASTER_SITES= http://www.prawda.newmail.ru/
-MAINTAINER= novel@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= English-Russian translator
USE_BZIP2= yes
@@ -22,6 +17,8 @@ CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e "s|ulong|unsigned long|g;;s|malloc.h|stdlib.h|g" ${WRKSRC}/src/face/video_x.cpp
@${REINPLACE_CMD} -e "s|g++|${CXX} ${CXXFLAGS}|g" ${WRKSRC}/src/bin/makefile.exe
+ @${FIND} ${WRKSRC} -name makefile | ${XARGS} \
+ ${REINPLACE_CMD} -e "s|g++|${CXX} ${CXXFLAGS}|g"
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" ${WRKSRC}/bin/makefile ${WRKSRC}/src/face/main.cpp
do-build:
diff --git a/russian/prawda/files/patch-src-face-main.cpp b/russian/prawda/files/patch-src-face-main.cpp
new file mode 100644
index 000000000000..3c514660b064
--- /dev/null
+++ b/russian/prawda/files/patch-src-face-main.cpp
@@ -0,0 +1,11 @@
+--- src/face/main.cpp.orig 2013-09-12 18:53:29.000000000 +0400
++++ src/face/main.cpp 2013-09-12 18:53:35.000000000 +0400
+@@ -223,7 +223,7 @@
+ /***************************************************************************/
+
+ /***************************************************************************/
+-int main( short argc, char *argv[] )
++int main( int argc, char *argv[] )
+ { char r,r1 ;
+ char Str[200]="" ;
+ short sx=80,sy=50 ;