aboutsummaryrefslogtreecommitdiff
path: root/russian
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:31:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 06:00:48 +0000
commit915dbfaa562e20c8402d3873f8bfbf07899f9f8a (patch)
tree31846497e11ce47118708aa782fe87dbb6a7599f /russian
parentaa9edcc217007fd4a39e10ee17805dd350c25381 (diff)
downloadports-915dbfaa562e20c8402d3873f8bfbf07899f9f8a.tar.gz
ports-915dbfaa562e20c8402d3873f8bfbf07899f9f8a.zip
*/*hyphen: Avoid using %% in Makefile
Use ${DATAIDR} instead of %%DATADIR%%
Diffstat (limited to 'russian')
-rw-r--r--russian/hyphen/Makefile4
-rw-r--r--russian/hyphen/Makefile 27
2 files changed, 29 insertions, 2 deletions
diff --git a/russian/hyphen/Makefile b/russian/hyphen/Makefile
index a3f215d658d4..0c9ce1c8ea9b 100644
--- a/russian/hyphen/Makefile
+++ b/russian/hyphen/Makefile
@@ -16,8 +16,8 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/hyph_ru_RU.dic \
- %%DATADIR%%/hyph_ru_UA.dic
+PLIST_FILES= ${DATADIR}/hyph_ru_RU.dic \
+ ${DATADIR}/hyph_ru_UA.dic
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/russian/hyphen/Makefile b/russian/hyphen/Makefile
new file mode 100644
index 000000000000..a3f215d658d4
--- /dev/null
+++ b/russian/hyphen/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= hyphen
+PORTVERSION= 2004.04.15
+PORTREVISION= 1
+CATEGORIES= russian textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+DISTNAME= hyph_ru_RU-${PORTVERSION:C/\.//g}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Russian hyphenation rules
+
+LICENSE= LGPL21
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/hyph_ru_RU.dic \
+ %%DATADIR%%/hyph_ru_UA.dic
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/hyph_ru_RU.dic ${STAGEDIR}${DATADIR}/
+ ${LN} -s hyph_ru_RU.dic ${STAGEDIR}${DATADIR}/hyph_ru_UA.dic
+
+.include <bsd.port.mk>