aboutsummaryrefslogtreecommitdiff
path: root/science/abinit
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-14 05:49:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-14 05:49:39 +0000
commit2e455aebc4eebd66ae77327663cbff4d35ba50b2 (patch)
treeb7643444c1c8ca2745fe46c2fa20f8e42ae950a4 /science/abinit
parentc2f895e6303687746e4ac1f2c9eb752c480c7136 (diff)
downloadports-2e455aebc4eebd66ae77327663cbff4d35ba50b2.tar.gz
ports-2e455aebc4eebd66ae77327663cbff4d35ba50b2.zip
Re-add port: science/abinit: Full-featured atomic-scale first-principles simulation software
I couldn't make MPI work, created a bug report. Will add DOCS and EXAMPLES options later. PR: 219025
Notes
Notes: svn path=/head/; revision=472353
Diffstat (limited to 'science/abinit')
-rw-r--r--science/abinit/Makefile27
-rw-r--r--science/abinit/distinfo3
-rw-r--r--science/abinit/files/patch-Makefile.in11
-rw-r--r--science/abinit/files/patch-src_02__clib_md5.c11
-rw-r--r--science/abinit/pkg-descr14
-rw-r--r--science/abinit/pkg-plist23
6 files changed, 89 insertions, 0 deletions
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
new file mode 100644
index 000000000000..1bf6fa3557e7
--- /dev/null
+++ b/science/abinit/Makefile
@@ -0,0 +1,27 @@
+# Created by: NAKATA Maho <maho@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= abinit
+DISTVERSION= 8.8.2
+CATEGORIES= science
+MASTER_SITES= https://www.abinit.org/sites/default/files/packages/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Full-featured atomic-scale first-principles simulation software
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+ONLY_FOR_ARCHS= amd64 i386
+
+LIB_DEPENDS= liblapack.so:math/lapack \
+ libblas.so:math/blas
+RUN_DEPENDS= atompaw:science/atompaw
+
+USES= fortran gmake localbase:ldflags
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-shared --disable-static
+
+FCFLAGS+= -ffree-line-length-none
+
+.include <bsd.port.mk>
diff --git a/science/abinit/distinfo b/science/abinit/distinfo
new file mode 100644
index 000000000000..09bdff9fb15a
--- /dev/null
+++ b/science/abinit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1528909182
+SHA256 (abinit-8.8.2.tar.gz) = 15216703bd56a799a249a112b336d07d733627d3756487a4b1cb48ebb625c3e7
+SIZE (abinit-8.8.2.tar.gz) = 82546807
diff --git a/science/abinit/files/patch-Makefile.in b/science/abinit/files/patch-Makefile.in
new file mode 100644
index 000000000000..05da3e07cc89
--- /dev/null
+++ b/science/abinit/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2018-06-14 05:16:42 UTC
++++ Makefile.in
+@@ -876,7 +876,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
+ @abi_ac_distcheck@ \
+ PYFLAGS="@PYFLAGS@ -B"
+
+-SUBDIRS = fallbacks src abichecks tests
++SUBDIRS = fallbacks src abichecks
+
+ # Additional files to clean
+ CLEANFILES = config.optim config.fc_info.tmp
diff --git a/science/abinit/files/patch-src_02__clib_md5.c b/science/abinit/files/patch-src_02__clib_md5.c
new file mode 100644
index 000000000000..f40bca3c14f3
--- /dev/null
+++ b/science/abinit/files/patch-src_02__clib_md5.c
@@ -0,0 +1,11 @@
+--- src/02_clib/md5.c.orig 2017-02-28 12:02:53 UTC
++++ src/02_clib/md5.c
+@@ -47,7 +47,7 @@
+ #ifdef HAVE_MALLOC_MALLOC_H
+ # include <malloc/malloc.h>
+ #else
+-# include <malloc.h>
++# include <stdlib.h>
+ #endif
+
+ #include "md5.h"
diff --git a/science/abinit/pkg-descr b/science/abinit/pkg-descr
new file mode 100644
index 000000000000..2cb92bc2a7c6
--- /dev/null
+++ b/science/abinit/pkg-descr
@@ -0,0 +1,14 @@
+ABINIT is a package whose main program allows one to find the total energy,
+charge density and electronic structure of systems made of electrons and nuclei
+(molecules and periodic solids) within Density Functional Theory (DFT), using
+pseudopotentials and a planewave or wavelet basis. ABINIT also includes options
+to optimize the geometry according to the DFT forces and stresses, or to perform
+molecular dynamics simulations using these forces, or to generate dynamical
+matrices, Born effective charges, and dielectric tensors, based on
+Density-Functional Perturbation Theory, and many more properties. Excited states
+can be computed within the Many-Body Perturbation Theory (the GW approximation
+and the Bethe-Salpeter equation), and Time-Dependent Density Functional Theory
+(for molecules). In addition to the main ABINIT code, different utility programs
+are provided.
+
+WWW: https://www.abinit.org
diff --git a/science/abinit/pkg-plist b/science/abinit/pkg-plist
new file mode 100644
index 000000000000..007b179620fe
--- /dev/null
+++ b/science/abinit/pkg-plist
@@ -0,0 +1,23 @@
+bin/abinit
+bin/aim
+bin/anaddb
+bin/band2eps
+bin/bsepostproc
+bin/conducti
+bin/cut3d
+bin/dummy_tests
+bin/fftprof
+bin/fold2Bloch
+bin/ioprof
+bin/lapackprof
+bin/macroave
+bin/mrgddb
+bin/mrgdv
+bin/mrggkk
+bin/mrgscr
+bin/multibinit
+bin/optic
+bin/tdep
+bin/ujdet
+bin/vdw_kernelgen
+libdata/pkgconfig/abinit.pc