aboutsummaryrefslogtreecommitdiff
path: root/science/at
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-12 08:47:45 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-12 08:47:45 +0000
commit868910fb14696646840f85dc1e7cb4b4601179e2 (patch)
treeddaca0a0c59a342cbc7c6140a2ed2ab759f117d3 /science/at
parent6858d87aad369772a40a12e239f31149cd7b4d08 (diff)
downloadports-868910fb14696646840f85dc1e7cb4b4601179e2.tar.gz
ports-868910fb14696646840f85dc1e7cb4b4601179e2.zip
Notes
Diffstat (limited to 'science/at')
-rw-r--r--science/at/Makefile15
-rw-r--r--science/at/files/patch-Kraken+covar.f24
-rw-r--r--science/at/files/patch-Kraken+krakenc.f13
-rw-r--r--science/at/files/patch-aa192
4 files changed, 162 insertions, 82 deletions
diff --git a/science/at/Makefile b/science/at/Makefile
index 2e5ca75efe49..dab29bdc4d9d 100644
--- a/science/at/Makefile
+++ b/science/at/Makefile
@@ -6,6 +6,7 @@
PORTNAME= at
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://www.hlsresearch.com/oalib/Modes/AcousticsToolbox/
DISTNAME= at_Unix
@@ -15,6 +16,20 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The Acoustic ToolBox includes four acoustic models
WRKSRC= ${WRKDIR}/at
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%FC%%|${FC}|g" -e "s|%%F77%%|${F77}|g" -e "s|%%FFLAGS%%|${FFLAGS}|g" ${WRKSRC}/Bellhop/Makefile
+ @${REINPLACE_CMD} -e "s|%%FC%%|${FC}|g" -e "s|%%F77%%|${F77}|g" -e "s|%%FFLAGS%%|${FFLAGS}|g" ${WRKSRC}/Kraken/Makefile
+ @${REINPLACE_CMD} -e "s|%%FC%%|${FC}|g" -e "s|%%F77%%|${F77}|g" -e "s|%%FFLAGS%%|${FFLAGS}|g" ${WRKSRC}/KrakenZ/Makefile
+ @${REINPLACE_CMD} -e "s|%%FC%%|${FC}|g" -e "s|%%F77%%|${F77}|g" -e "s|%%FFLAGS%%|${FFLAGS}|g" ${WRKSRC}/Scooter/Makefile
+ @${REINPLACE_CMD} -e "s|%%FC%%|${FC}|g" -e "s|%%F77%%|${F77}|g" -e "s|%%FFLAGS%%|${FFLAGS}|g" ${WRKSRC}/global/Makefile
+ @${REINPLACE_CMD} -e "s|%%FC%%|${FC}|g" -e "s|%%F77%%|${F77}|g" -e "s|%%FFLAGS%%|${FFLAGS}|g" ${WRKSRC}/misc/Makefile
+ @${REINPLACE_CMD} -e "s|%%FC%%|${FC}|g" -e "s|%%F77%%|${F77}|g" -e "s|%%FFLAGS%%|${FFLAGS}|g" ${WRKSRC}/tslib/Makefile
+ @${REINPLACE_CMD} -e "s|%%FC%%|${FC}|g" -e "s|%%F77%%|${F77}|g" -e "s|%%FFLAGS%%|${FFLAGS}|g" -e "s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/bb/Makefile
do-build:
cd ${WRKSRC}; ${MAKE} install
diff --git a/science/at/files/patch-Kraken+covar.f b/science/at/files/patch-Kraken+covar.f
new file mode 100644
index 000000000000..663a96008a07
--- /dev/null
+++ b/science/at/files/patch-Kraken+covar.f
@@ -0,0 +1,24 @@
+--- Kraken/covar.f~ Thu Feb 26 14:42:17 1998
++++ Kraken/covar.f Fri Jan 12 17:40:53 2007
+@@ -252,8 +252,8 @@
+ COMPLEX NOISE( * )
+
+ DO IRD = 1, NRD
+- X = RAN( ISEED ) + 0.000001
+- Y = RAN( ISEED )
++ X = RAN( ISEED(1) ) + 0.000001
++ Y = RAN( ISEED(1) )
+
+ NOISE( IRD ) = SIGMA *
+ & SQRT( -LOG( X ) ) * EXP( CI * 2.0 * PI * Y )
+@@ -287,8 +287,8 @@
+ DO MODE = 1, M
+
+ C --- compute the random coefficient
+- X = RAN( ISEED ) + 0.000001
+- Y = RAN( ISEED )
++ X = RAN( ISEED(1) ) + 0.000001
++ Y = RAN( ISEED(1) )
+ COEF = SQRT( -LOG( X ) ) * EXP( CI * 2.0 * PI * Y )
+
+ C --- loop over receivers
diff --git a/science/at/files/patch-Kraken+krakenc.f b/science/at/files/patch-Kraken+krakenc.f
new file mode 100644
index 000000000000..a8bb198484b5
--- /dev/null
+++ b/science/at/files/patch-Kraken+krakenc.f
@@ -0,0 +1,13 @@
+--- Kraken/krakenc.f~ Thu May 14 08:46:37 1998
++++ Kraken/krakenc.f Fri Jan 12 17:39:37 2007
+@@ -404,8 +404,8 @@
+
+ IF ( SQRT( OMEGA2 ) / REAL( SQRT( X ) ) .GT. CHIGH ) THEN
+ C --- Mode outside, restart at a random point
+- CTRY = CLOW + RAN( ISEED ) * ( CHIGH - CLOW )
+- & + ( 0.0, 0.01 ) * RAN( ISEED ) * CLOW
++ CTRY = CLOW + RAN( ISEED(1) ) * ( CHIGH - CLOW )
++ & + ( 0.0, 0.01 ) * RAN( ISEED(1) ) * CLOW
+
+ X = ( 1.0, 0.0 ) * OMEGA2 / CTRY ** 2
+
diff --git a/science/at/files/patch-aa b/science/at/files/patch-aa
index b0358047034c..18da63459efb 100644
--- a/science/at/files/patch-aa
+++ b/science/at/files/patch-aa
@@ -1,85 +1,113 @@
-*** Kraken/Makefile
-***************
-*** 1,4 ****
-! FFLAGS = -O -bytereclen
-
- #FC = f90
- #F77 = f90
---- 1,4 ----
-! FFLAGS = -O -ff90
-
- #FC = f90
- #F77 = f90
-*** misc/Makefile
-***************
-*** 1,4 ****
-! FFLAGS = -O -bytereclen
-
- #FC = f90
- #F77 = f90
---- 1,4 ----
-! FFLAGS = -O -ff90
-
- #FC = f90
- #F77 = f90
-*** Bellhop/Makefile
-***************
-*** 1,4 ****
-! FFLAGS = -O -bytereclen
- # note: SGI, use -trapuv, -lfpe in link to trap overflows
-
- #FC = f90
---- 1,4 ----
-! FFLAGS = -O -ff90
- # note: SGI, use -trapuv, -lfpe in link to trap overflows
-
- #FC = f90
-*** Scooter/Makefile
-***************
-*** 1,4 ****
-! FFLAGS= -O -bytereclen
-
- #FC = f90
- #F77 = f90
---- 1,4 ----
-! FFLAGS = -O -ff90
-
- #FC = f90
- #F77 = f90
-*** global/Makefile
-***************
-*** 1,4 ****
-! FFLAGS = -O -bytereclen
-
- #FC = f90
- #F77 = f90
---- 1,4 ----
-! FFLAGS = -O -ff90
-
- #FC = f90
- #F77 = f90
-*** tslib/Makefile
-***************
-*** 1,4 ****
-! FFLAGS = -O
-
- #FC = f90
- #F77 = f90
---- 1,4 ----
-! FFLAGS = -O -ff90
-
- #FC = f90
- #F77 = f90
-*** KrakenZ/Makefile
-***************
-*** 1,4 ****
-! #FFLAGS= -C -trapuv -check_bounds -g -old_rl
- #FFLAGS = +E1 # for HP machines
- #FFLAGS = -O -trapuv -old_rl -mips2 # old_rl forces SGI to use RECL in bytes
+--- Bellhop/Makefile.orig Thu Feb 26 14:42:16 1998
++++ Bellhop/Makefile Fri Jan 12 17:30:03 2007
+@@ -1,8 +1,8 @@
+-FFLAGS = -O -bytereclen
++FFLAGS = %%FFLAGS%%
+ # note: SGI, use -trapuv, -lfpe in link to trap overflows
---- 1,4 ----
-! FFLAGS = -O -ff90
- #FFLAGS = +E1 # for HP machines
- #FFLAGS = -O -trapuv -old_rl -mips2 # old_rl forces SGI to use RECL in bytes
+-#FC = f90
+-#F77 = f90
++FC = %%FC%%
++F77 = %%F90%%
+ misc = ../misc
+--- Kraken/Makefile.orig Thu Feb 26 14:42:17 1998
++++ Kraken/Makefile Fri Jan 12 17:30:26 2007
+@@ -1,7 +1,7 @@
+-FFLAGS = -O -bytereclen
++FFLAGS = %%FFLAGS%%
+
+-#FC = f90
+-#F77 = f90
++FC = %%FC%%
++F77 = %%F77%%
+
+ krak = ../Kraken
+ misc = ../misc
+--- KrakenZ/Makefile.orig Mon Apr 27 17:36:59 1998
++++ KrakenZ/Makefile Fri Jan 12 17:30:41 2007
+@@ -1,8 +1,8 @@
+-#FFLAGS= -C -trapuv -check_bounds -g -old_rl
++FFLAGS = %%FFLAGS%%
+ #FFLAGS = +E1 # for HP machines
+ #FFLAGS = -O -trapuv -old_rl -mips2 # old_rl forces SGI to use RECL in bytes
+
+-#FC = f90
++FC = %%FC%%
+ krak = ../Kraken
+ misc = ../misc
+
+--- Scooter/Makefile.orig Thu Feb 26 14:42:22 1998
++++ Scooter/Makefile Fri Jan 12 17:31:01 2007
+@@ -1,7 +1,7 @@
+-FFLAGS= -O -bytereclen
++FFLAGS = %%FFLAGS%%
+
+-#FC = f90
+-#F77 = f90
++FC = %%FC%%
++F77 = %%F90%%
+
+ misc = ../misc
+ tslib = ../tslib
+
+--- tslib/Makefile.orig Thu Feb 26 14:42:25 1998
++++ tslib/Makefile Fri Jan 12 17:31:39 2007
+@@ -1,7 +1,7 @@
+-FFLAGS = -O
++FFLAGS = %%FFLAGS%%
+
+-#FC = f90
+-#F77 = f90
++FC = %%FC%%
++F77 = %%F77%%
+
+ misc = ../misc
+
+--- misc/Makefile.orig Thu Feb 26 14:42:31 1998
++++ misc/Makefile Fri Jan 12 17:37:31 2007
+@@ -1,7 +1,7 @@
+-FFLAGS = -O -bytereclen
++FFLAGS = %%FFLAGS%%
+
+-#FC = f90
+-#F77 = f90
++FC = %%FC%%
++F77 = %%F77%%
+
+ install: misc
+
+--- global/Makefile.orig Thu Feb 26 14:42:23 1998
++++ global/Makefile Fri Jan 12 17:42:48 2007
+@@ -1,7 +1,7 @@
+-FFLAGS = -O -bytereclen
++FFLAGS = %%FFLAGS%%
+
+-#FC = f90
+-#F77 = f90
++FC = %%FC%%
++F77 = %%F77%%
+
+ misc = ../misc
+
+--- bb/Makefile.old Fri Jan 12 17:44:43 2007
++++ bb/Makefile Fri Jan 12 17:45:01 2007
+@@ -1,13 +1,13 @@
+-FFLAGS = -O
++FFLAGS = %%FFLAGS%%
+
+-#FC = f90
+-#F77 = f90
++FC = %%FC%%
++F77 = %%F77%%
+
+ krak = ../Kraken
+ misc = ../misc
+ tslib = ../tslib
+
+-CFLAGS = -O -cckr
++CFLAGS = %%CFLAGS%%
+
+ install: others stack.out makets.out fft.out raw.out
+ @echo "Broadband tools built"