aboutsummaryrefslogtreecommitdiff
path: root/science/bft/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2008-04-30 22:14:12 +0000
committerThierry Thomas <thierry@FreeBSD.org>2008-04-30 22:14:12 +0000
commitd3f07698a5cd7ccaa2c6616ec5aab392e4f423d7 (patch)
tree848f5eb4a9aa703aefccf5f0905ead2e644a5e4d /science/bft/Makefile
parent1419d70e42850be4fbdfd8fa58a92a8c1dbc002f (diff)
downloadports-d3f07698a5cd7ccaa2c6616ec5aab392e4f423d7.tar.gz
ports-d3f07698a5cd7ccaa2c6616ec5aab392e4f423d7.zip
Notes
Diffstat (limited to 'science/bft/Makefile')
-rw-r--r--science/bft/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/science/bft/Makefile b/science/bft/Makefile
index 5f1a46445737..4658977ae415 100644
--- a/science/bft/Makefile
+++ b/science/bft/Makefile
@@ -6,20 +6,22 @@
#
PORTNAME= bft
-PORTVERSION= 1.0.5
+PORTVERSION= 1.0.6
CATEGORIES= science parallel
-MASTER_SITES= http://www.edf.fr/html/RetD/livraison_saturne_${REL_DATE}/
+MASTER_SITES= http://rd.edf.com/fichiers/fckeditor/File/EDF%20RD/Code_Saturne/Fichiers/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .tgz
MAINTAINER= thierry@FreeBSD.org
COMMENT= Code_Saturne Base Functions and Types library
-REL_DATE= 20071218
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-TESTSBIN= bft_test
+TESTSBIN= bft_test bft_mem_usage_test bft_printf_test
pre-configure:
# No useful doc there
@@ -27,7 +29,7 @@ pre-configure:
regression-test:
.for pg in ${TESTSBIN}
- @(cd ${WRKSRC}/tests; ./${pg} arg1 arg2)
+ (cd ${WRKSRC}/tests; ./${pg} arg1 arg2)
.endfor
.include <bsd.port.mk>