aboutsummaryrefslogtreecommitdiff
path: root/science/bft
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-06-17 21:04:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-06-17 21:04:54 +0000
commit8fecd8a363977c7d53fa001250a32ead0aaf736b (patch)
tree2fc76790cd3db56aa3f887f1c8ff10a761890516 /science/bft
parent0a7df5e916cf09acca2033a1ddbed3e6f77e1dde (diff)
Notes
Diffstat (limited to 'science/bft')
-rw-r--r--science/bft/Makefile33
-rw-r--r--science/bft/distinfo3
-rw-r--r--science/bft/pkg-descr5
-rw-r--r--science/bft/pkg-plist18
4 files changed, 59 insertions, 0 deletions
diff --git a/science/bft/Makefile b/science/bft/Makefile
new file mode 100644
index 000000000000..f43e2a52055e
--- /dev/null
+++ b/science/bft/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: bft
+# Date created: Sun 1 apr 2007
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= bft
+PORTVERSION= 1.0.3
+CATEGORIES= science parallel
+MASTER_SITES= http://www.edf.fr/html/RetD/livraison_saturne_${REL_DATE}/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Code_Saturne Base Functions and Types library
+
+REL_DATE= 070305
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+TESTSBIN= bft_test
+
+pre-configure:
+ # No useful doc there
+ ${REINPLACE_CMD} -e 's|tests doc|tests|' ${WRKSRC}/Makefile.in
+
+regression-test:
+.for pg in ${TESTSBIN}
+ @(cd ${WRKSRC}/tests; ./${pg} arg1 arg2)
+.endfor
+
+.include <bsd.port.mk>
diff --git a/science/bft/distinfo b/science/bft/distinfo
new file mode 100644
index 000000000000..f75be4816a18
--- /dev/null
+++ b/science/bft/distinfo
@@ -0,0 +1,3 @@
+MD5 (bft-1.0.3.tar.gz) = 9003c7480df32b8f88fa95ee476244d7
+SHA256 (bft-1.0.3.tar.gz) = 92d96837e920fc4742d1a9058df0fd54c632ae2248304ff2e3976c2e74a754cf
+SIZE (bft-1.0.3.tar.gz) = 430826
diff --git a/science/bft/pkg-descr b/science/bft/pkg-descr
new file mode 100644
index 000000000000..d9dacf510b08
--- /dev/null
+++ b/science/bft/pkg-descr
@@ -0,0 +1,5 @@
+BFT stands for Base Functions and Types.
+It is destined to be used by scientific codes (CFD) often using
+some form of parallelism, especially MPI.
+
+WWW: http://rd.edf.com/code_saturne/
diff --git a/science/bft/pkg-plist b/science/bft/pkg-plist
new file mode 100644
index 000000000000..08eee58989c4
--- /dev/null
+++ b/science/bft/pkg-plist
@@ -0,0 +1,18 @@
+bin/bft-config
+include/bft_backtrace.h
+include/bft_config.h
+include/bft_config_priv.h
+include/bft_error.h
+include/bft_file.h
+include/bft_fp_trap.h
+include/bft_intl.h
+include/bft_mem.h
+include/bft_mem_usage.h
+include/bft_printf.h
+include/bft_sys_info.h
+include/bft_timer.h
+include/bft_version.h
+lib/libbft.a
+lib/libbft.la
+lib/libbft.so
+lib/libbft.so.1