aboutsummaryrefslogtreecommitdiff
path: root/science/cdcl
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-03-11 11:20:54 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-03-11 11:20:54 +0000
commitb7699ac1588287b69398385d737a56fabedcb24e (patch)
treedee8a66007ddffc3ebb02f273d053435d676ccc4 /science/cdcl
parent9d7a34671d0ed9acf72513594c7aa49984c3cd27 (diff)
downloadports-b7699ac1588287b69398385d737a56fabedcb24e.tar.gz
ports-b7699ac1588287b69398385d737a56fabedcb24e.zip
- Update science/cdcl to 5.3.3.
- Remove hardcoded version in packing list. - Add -fPIC to CFLAGS on amd64. PR: ports/121284 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=208798
Diffstat (limited to 'science/cdcl')
-rw-r--r--science/cdcl/Makefile33
-rw-r--r--science/cdcl/distinfo6
-rw-r--r--science/cdcl/pkg-plist61
3 files changed, 49 insertions, 51 deletions
diff --git a/science/cdcl/Makefile b/science/cdcl/Makefile
index f6c0d21944bf..44624cd4d249 100644
--- a/science/cdcl/Makefile
+++ b/science/cdcl/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= cdcl
-PORTVERSION= 5.3
-PORTREVISION= 3
+PORTVERSION= 5.3.3
CATEGORIES= science graphics
MASTER_SITES= http://www.gfd-dennou.org/arch/dcl/
-DISTNAME= dcl-5.3-C
+DISTNAME= dcl-${PORTVERSION}-C
MAINTAINER= murakami@ahs.scitec.kobe-u.ac.jp
COMMENT= Scientific graphic library for geoscience
@@ -22,20 +21,22 @@ USE_GNOME= gtk20
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --exec-prefix=${PREFIX} --libdir=${PREFIX}/lb/${PORTNAME}-${PORTVERSION} --with-x
+CONFIGURE_ARGS= --prefix=${PREFIX} --exec-prefix=${PREFIX} --with-x
.if defined(WITHOUT_GTK)
CUNFIGURE_ARGS+= --disable-gtk --disable-gtk2
.endif
-DCL_VERSION= ${PORTVERSION}-C
-PLIST_SUB= DCL_VERSION=${DCL_VERSION}
+PLIST_SUB= DCL_VERSION=${PORTVERSION:S/.//g}
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CFLAGS+= -fPIC
+.endif
BINARIES= cdclcmap cdclclr cdcldate cdcldbs cdclexec cdclfont \
cdclpara cdcltone cdcltrf cdclver
-PSLIBS= dclps2kdraw dclpscat dclpsfix dclpsfont dclpsline \
- dclpsmargin dclpsmerge dclpsnup dclpsrmcm dclpsrot \
- dclpsselect dclpsseparate dclpsunrot
DOCFILES= CHECK CREDITS HISTORY README README_clrmap README_gt2dlib \
README_itr51 README_pslib README_umfmap
DEMODIRS= gokuraku grph1 grph2 math1 math2 misc1 misc2 rakuraku
@@ -49,16 +50,10 @@ DEMOMISC1DIR= bitlib chglib chklib chnlib clcklib datelib fmtlib hexlib \
misclib randlib timelib
DEMORAKUDIR= color kihon layout map3d miss quick u2d uspack uxyz
-RESTRICTED= "No commercial use"
+RESTRICTED= No commercial use
-pre-build:
- @cd ${WRKSRC}
- @${REINPLACE_CMD} -e 's+dcldbase+dcldbase-${PORTVERSION}-C+' ${WRKSRC}/Mkinclude
- @${REINPLACE_CMD} -e 's+dclps+cdclps+g' ${WRKSRC}/bin/Makefile
- @${REINPLACE_CMD} -e 's+dclps+cdclps+g' ${WRKSRC}/src/env2/pslib/Makefile
-.for i in ${PSLIBS}
- ${MV} ${WRKSRC}/src/env2/pslib/${i} ${WRKSRC}/src/env2/pslib/c${i}
-.endfor
+post-configure:
+ @${REINPLACE_CMD} -e 's|$$(DCLLANG)dcl$$(DCLVERNUM)|$$(DCLLANG)dcl|' ${WRKSRC}/Mkinclude
post-install:
.if !defined(NOPORTDOCS)
@@ -104,4 +99,4 @@ post-install:
.for i in ${DOCFILES}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/science/cdcl/distinfo b/science/cdcl/distinfo
index f45d6bad42ba..3072ba528f57 100644
--- a/science/cdcl/distinfo
+++ b/science/cdcl/distinfo
@@ -1,3 +1,3 @@
-MD5 (dcl-5.3-C.tar.gz) = abbf7e26f49ff95af6141ede9293181e
-SHA256 (dcl-5.3-C.tar.gz) = f1f334bbccc10c93db0a2e1b5cee5e97e728df3fd931d07966ff4c178939c261
-SIZE (dcl-5.3-C.tar.gz) = 1052506
+MD5 (dcl-5.3.3-C.tar.gz) = 0418bc26737fe30fd5ce4617b558710f
+SHA256 (dcl-5.3.3-C.tar.gz) = 0b359170658255879ff75baa3b199fb8a7831526baa1d7e68cf32467fc6af73a
+SIZE (dcl-5.3.3-C.tar.gz) = 1093398
diff --git a/science/cdcl/pkg-plist b/science/cdcl/pkg-plist
index 4831e5ba064d..f3efa99b8a2d 100644
--- a/science/cdcl/pkg-plist
+++ b/science/cdcl/pkg-plist
@@ -2,7 +2,7 @@ bin/cdclcc
bin/cdclcmap
bin/cdclclr
bin/cdclconfig
-bin/cdclconfig53
+bin/cdclconfig%%DCL_VERSION%%
bin/cdcldate
bin/cdcldbs
bin/cdclexec
@@ -16,6 +16,7 @@ bin/cdclpsline
bin/cdclpsmargin
bin/cdclpsmerge
bin/cdclpsnup
+bin/cdclpsrgb2cmyk
bin/cdclpsrmcm
bin/cdclpsrot
bin/cdclpsselect
@@ -27,33 +28,34 @@ bin/cdclver
bin/crepsl
include/libtinyf2c.h
include/cdcl.h
-lib/dcldbase-%%DCL_VERSION%%/bitmap.x11
-lib/dcldbase-%%DCL_VERSION%%/border_world
-lib/dcldbase-%%DCL_VERSION%%/cl2tnmap
-lib/dcldbase-%%DCL_VERSION%%/cmaplist
-lib/dcldbase-%%DCL_VERSION%%/coast_japan
-lib/dcldbase-%%DCL_VERSION%%/coast_world
-lib/dcldbase-%%DCL_VERSION%%/coast_world_1
-lib/dcldbase-%%DCL_VERSION%%/colormap.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_01.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_02.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_03.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_04.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_05.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_06.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_07.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_08.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_09.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_10.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_11.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_12.x11
-lib/dcldbase-%%DCL_VERSION%%/colormap_13.x11
-lib/dcldbase-%%DCL_VERSION%%/font1u
-lib/dcldbase-%%DCL_VERSION%%/font2u
-lib/dcldbase-%%DCL_VERSION%%/plate_world
-lib/dcldbase-%%DCL_VERSION%%/pref_japan
-lib/dcldbase-%%DCL_VERSION%%/state_usa
-lib/libcdcl53.a
+lib/cdcldbase/bitmap.x11
+lib/cdcldbase/border_world
+lib/cdcldbase/cl2tnmap
+lib/cdcldbase/cmaplist
+lib/cdcldbase/coast_japan
+lib/cdcldbase/coast_world
+lib/cdcldbase/coast_world_1
+lib/cdcldbase/colormap.x11
+lib/cdcldbase/colormap_01.x11
+lib/cdcldbase/colormap_02.x11
+lib/cdcldbase/colormap_03.x11
+lib/cdcldbase/colormap_04.x11
+lib/cdcldbase/colormap_05.x11
+lib/cdcldbase/colormap_06.x11
+lib/cdcldbase/colormap_07.x11
+lib/cdcldbase/colormap_08.x11
+lib/cdcldbase/colormap_09.x11
+lib/cdcldbase/colormap_10.x11
+lib/cdcldbase/colormap_11.x11
+lib/cdcldbase/colormap_12.x11
+lib/cdcldbase/colormap_13.x11
+lib/cdcldbase/colormap_14.x11
+lib/cdcldbase/font1u
+lib/cdcldbase/font2u
+lib/cdcldbase/plate_world
+lib/cdcldbase/pref_japan
+lib/cdcldbase/state_usa
+lib/libcdcl.a
lib/libf2c4dcl.a
%%PORTDOCS%%share/doc/cdcl/CHECK
%%PORTDOCS%%share/doc/cdcl/CREDITS
@@ -117,6 +119,7 @@ lib/libf2c4dcl.a
%%PORTDOCS%%share/examples/cdcl/grph1/sgpack/sgpk09.c
%%PORTDOCS%%share/examples/cdcl/grph1/sgpack/sgpk10.c
%%PORTDOCS%%share/examples/cdcl/grph1/sgpack/sgtclr.c
+%%PORTDOCS%%share/examples/cdcl/grph1/sgpack/sgtcls.c
%%PORTDOCS%%share/examples/cdcl/grph1/sgpack/sgtone.c
%%PORTDOCS%%share/examples/cdcl/grph1/sgpack/sgtonz.c
%%PORTDOCS%%share/examples/cdcl/grph1/slpack/Makefile
@@ -411,4 +414,4 @@ lib/libf2c4dcl.a
%%PORTDOCS%%@dirrm share/examples/cdcl/rakuraku/uxyz
%%PORTDOCS%%@dirrm share/examples/cdcl/rakuraku
%%PORTDOCS%%@dirrm share/examples/cdcl
-@dirrm lib/dcldbase-%%DCL_VERSION%%
+@dirrm lib/cdcldbase