aboutsummaryrefslogtreecommitdiff
path: root/science/cdo/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-10 03:09:55 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-10 03:09:55 +0000
commitd5c3e741ffe1bd3d6ee41c01ac1c59dbb0162cef (patch)
tree4b752122e203e9dc24847900c869331d80dcc6db /science/cdo/Makefile
parentdb0bf94b4c6b56150111c95cf6af0fcb2f1b8d06 (diff)
Notes
Diffstat (limited to 'science/cdo/Makefile')
-rw-r--r--science/cdo/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index b1460d8cffb8..4ad4f7db0c2d 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= cdo
-PORTVERSION= 1.0.6
+PORTVERSION= 1.0.7
CATEGORIES= science
MASTER_SITES= http://www.mpimet.mpg.de/fileadmin/software/cdo/ \
http://sunpoet.net/distfiles/
@@ -28,6 +28,12 @@ PLIST_FILES= bin/cdo bin/cdotest
OPTIONS= HDF5 "HDF5 support" off \
NETCDF "NETCDF support" off
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} > 700000) || (${ARCH} != "sparc64" && ${OSVERSION} > 600000)
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -DPTHREAD_MUTEXATTR_CONDATTR"
+.endif
+
.if defined(WITH_HDF5)
CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE}
LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
@@ -35,10 +41,10 @@ LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
.if defined(WITH_NETCDF)
CONFIGURE_ARGS+= --with-netcdf=${LOCALBASE}
-LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
+LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
.endif
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>