aboutsummaryrefslogtreecommitdiff
path: root/science/cdo/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2008-02-17 20:35:17 +0000
committerThierry Thomas <thierry@FreeBSD.org>2008-02-17 20:35:17 +0000
commite3301dcda29c98536690fdf6cdd74af25afc4e57 (patch)
treebf93a74e7ecd7f9ded07aacabca765b88c3166e9 /science/cdo/Makefile
parent4c752974adeb4e6895da57abea2568fb5d8894b2 (diff)
Notes
Diffstat (limited to 'science/cdo/Makefile')
-rw-r--r--science/cdo/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index 4e9281e010c6..158f74e67e03 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= cdo
-PORTVERSION= 1.0.9
+PORTVERSION= 1.1.0
CATEGORIES= science
MASTER_SITES= http://www.mpimet.mpg.de/fileadmin/software/cdo/ \
http://sunpoet.net/distfiles/
@@ -23,10 +23,9 @@ CONFIGURE_ENV= CC="${CC}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-PLIST_FILES= bin/cdo bin/cdotest
+PLIST_FILES= bin/cdo
-OPTIONS= HDF5 "HDF5 support" off \
- NETCDF "NETCDF support" off
+OPTIONS= NETCDF "NETCDF support" off
.include <bsd.port.pre.mk>
@@ -34,14 +33,16 @@ OPTIONS= HDF5 "HDF5 support" off \
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -DPTHREAD_MUTEXATTR_CONDATTR"
.endif
-.if defined(WITH_HDF5)
-CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE}
-LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
-.endif
-
.if defined(WITH_NETCDF)
CONFIGURE_ARGS+= --with-netcdf=${LOCALBASE}
LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-Makefile.in
+PLIST_FILES+= bin/cdotest
+.endif
+
+post-build:
+.if defined(WITH_NETCDF)
+ cd "${WRKSRC}/src" && ${SETENV} CDO_PATH="${WRKSRC}/src/cdo" "${WRKSRC}/src/cdotest"
.endif
post-install: