aboutsummaryrefslogtreecommitdiff
path: root/science/cdo
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2006-12-04 16:00:06 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2006-12-04 16:00:06 +0000
commit7e15092dd076cf9a52128cafa45d06ebf9e9985c (patch)
tree047424c5ed7c3ab1c6a604994e0afa999bfbba21 /science/cdo
parent491c2ca8320e2546d02beae661f775244014912c (diff)
downloadports-7e15092dd076cf9a52128cafa45d06ebf9e9985c.tar.gz
ports-7e15092dd076cf9a52128cafa45d06ebf9e9985c.zip
Notes
Diffstat (limited to 'science/cdo')
-rw-r--r--science/cdo/Makefile8
-rw-r--r--science/cdo/files/extra-patch-freebsd5-pthread29
2 files changed, 36 insertions, 1 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index 04edafb41f23..9713928ebd6f 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -27,6 +27,8 @@ PLIST_FILES= bin/cdo
OPTIONS= HDF5 "HDF5 support" off \
NETCDF "NETCDF support" off
+.include <bsd.port.pre.mk>
+
.if defined(WITH_HDF5)
CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE}
LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
@@ -37,4 +39,8 @@ CONFIGURE_ARGS+= --with-netcdf=${LOCALBASE}
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
.endif
-.include <bsd.port.mk>
+.if ${OSVERSION} >= 502102
+EXTRA_PATCHES+= "${PATCHDIR}/extra-patch-freebsd5-pthread"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/cdo/files/extra-patch-freebsd5-pthread b/science/cdo/files/extra-patch-freebsd5-pthread
new file mode 100644
index 000000000000..0cf7364580af
--- /dev/null
+++ b/science/cdo/files/extra-patch-freebsd5-pthread
@@ -0,0 +1,29 @@
+--- src/cdo_pthread.c.orig Wed Mar 22 22:04:18 2006
++++ src/cdo_pthread.c Mon Dec 4 11:46:11 2006
+@@ -32,8 +32,10 @@
+ {
+ #if defined (HAVE_LIBPTHREAD)
+ pthread_attr_t attr;
++/*
+ pthread_mutexattr_t m_attr;
+ pthread_condattr_t c_attr;
++*/
+
+ #if defined (PTHREAD_KEYS_MAX)
+ fprintf(stderr, "PTHREAD_KEYS_MAX = %d\n", PTHREAD_KEYS_MAX);
+@@ -54,6 +56,7 @@
+ print_pthread_attr("Default pthread attr", &attr);
+ pthread_attr_destroy(&attr);
+
++/*
+ pthread_mutexattr_init(&m_attr);
+ print_pthread_mutexattr("Default pthread mutexattr", &m_attr);
+ pthread_mutexattr_destroy(&m_attr);
+@@ -61,6 +64,7 @@
+ pthread_condattr_init(&c_attr);
+ print_pthread_condattr("Default pthread condattr ", &c_attr);
+ pthread_condattr_destroy(&c_attr);
++*/
+
+ fprintf(stderr, "\n");
+ #endif