aboutsummaryrefslogtreecommitdiff
path: root/science/cgnslib
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2019-03-06 19:49:56 +0000
committerThierry Thomas <thierry@FreeBSD.org>2019-03-06 19:49:56 +0000
commit1b7c99c8f125c677565e4e487e286764f7ffcb6e (patch)
treeb76a8cf257d18a46bd5589d720c09bab4d0a8bae /science/cgnslib
parente91dee7c5b6795d0aaca9fdd23f13baa127378f4 (diff)
downloadports-1b7c99c8f125c677565e4e487e286764f7ffcb6e.tar.gz
ports-1b7c99c8f125c677565e4e487e286764f7ffcb6e.zip
Notes
Diffstat (limited to 'science/cgnslib')
-rw-r--r--science/cgnslib/Makefile23
-rw-r--r--science/cgnslib/distinfo6
-rw-r--r--science/cgnslib/files/patch-src_cgnstools_cgnscalc_calcwish.c13
-rw-r--r--science/cgnslib/files/patch-src_cgnstools_cgnsplot_plotwish.c13
-rw-r--r--science/cgnslib/files/patch-src_cgnstools_cgnsview_cgiowish.c13
-rw-r--r--science/cgnslib/pkg-plist5
6 files changed, 16 insertions, 57 deletions
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index 1cd39ffeb63a..e93d2b1b79e5 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -3,8 +3,7 @@
PORTNAME= cgnslib
DISTVERSIONPREFIX= v
-DISTVERSION= 3.3.1
-PORTREVISION= 2
+DISTVERSION= 3.4.0
PORTEPOCH= 1
CATEGORIES= science
@@ -22,33 +21,31 @@ GH_ACCOUNT= CGNS
GH_PROJECT= CGNS
USE_LDCONFIG= yes
-OPTIONS_DEFINE= HDF5 TESTS TOOLS
-OPTIONS_DEFAULT= HDF5 TESTS TOOLS
+TEST_TARGET= test
+
+OPTIONS_DEFINE= FORTRAN HDF5 TESTS TOOLS
+OPTIONS_DEFAULT= FORTRAN HDF5 TESTS TOOLS
OPTIONS_SUB= yes
HDF5_DESC= Enable HDF5 interface
TESTS_DESC= Enable test programs
TOOLS_DESC= Build the CGNSTools package
-SZIP_DESC= SZIP support in HDF5
+
+FORTRAN_USES= fortran
+FORTRAN_CMAKE_BOOL= CGNS_ENABLE_FORTRAN
HDF5_LIB_DEPENDS= libhdf5.so:science/hdf5 libsz.so:science/szip
HDF5_CMAKE_BOOL= CGNS_ENABLE_HDF5
HDF5_CMAKE_ON= -DHDF5_INCLUDE_PATH:PATH="${LOCALBASE}/include"
-TESTS_USES= fortran
-TESTS_CMAKE_BOOL= ENABLE_TESTS CGNS_ENABLE_FORTRAN
+TESTS_CMAKE_BOOL= CGNS_ENABLE_TESTS
TOOLS_USES= gl localbase tk
-TOOLS_USE= GL=gl,glu XORG=x11,xmu
+TOOLS_USE= GL=gl,glu XORG=ice,xext,x11,xmu
TOOLS_CMAKE_BOOL= CGNS_BUILD_CGNSTOOLS
TOOLS_CMAKE_ON= -DTCL_INCLUDE_PATH:STRING="${TCL_INCLUDEDIR}" \
-DTK_INCLUDE_PATH:STRING="${TK_INCLUDEDIR}"
-do-test-TESTS-on:
-.for pg in cgwrite cgread test_partial
- @(cd ${BUILD_WRKSRC}/src/tests; ./${pg})
-.endfor
-
post-install:
${RLN} ${STAGEDIR}${PREFIX}/lib/libcgns.so.${DISTVERSION:R} \
${STAGEDIR}${PREFIX}/lib/libcgns.so.${DISTVERSION:R:R}
diff --git a/science/cgnslib/distinfo b/science/cgnslib/distinfo
index dd0d6199917c..9f4c59480c96 100644
--- a/science/cgnslib/distinfo
+++ b/science/cgnslib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1538602109
-SHA256 (CGNS-CGNS-v3.3.1_GH0.tar.gz) = 81093693b2e21a99c5640b82b267a495625b663d7b8125d5f1e9e7aaa1f8d469
-SIZE (CGNS-CGNS-v3.3.1_GH0.tar.gz) = 3340675
+TIMESTAMP = 1551816418
+SHA256 (CGNS-CGNS-v3.4.0_GH0.tar.gz) = 6372196caf25b27d38cf6f056258cb0bdd45757f49d9c59372b6dbbddb1e05da
+SIZE (CGNS-CGNS-v3.4.0_GH0.tar.gz) = 3393312
diff --git a/science/cgnslib/files/patch-src_cgnstools_cgnscalc_calcwish.c b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_calcwish.c
deleted file mode 100644
index 5c6f4c7d691f..000000000000
--- a/science/cgnslib/files/patch-src_cgnstools_cgnscalc_calcwish.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/cgnstools/cgnscalc/calcwish.c.orig 2017-07-17 21:51:06 UTC
-+++ src/cgnstools/cgnscalc/calcwish.c
-@@ -20,8 +20,10 @@
- * Sun shared libraries to be used for Tcl.
- */
-
-+#ifndef __FreeBSD__
- extern int matherr();
- int *tclDummyMathPtr = (int *) matherr;
-+#endif /* FreeBSD test */
-
- #ifdef TK_TEST
- extern int Tcltest_Init _ANSI_ARGS_((Tcl_Interp *interp));
diff --git a/science/cgnslib/files/patch-src_cgnstools_cgnsplot_plotwish.c b/science/cgnslib/files/patch-src_cgnstools_cgnsplot_plotwish.c
deleted file mode 100644
index 2b52371f169e..000000000000
--- a/science/cgnslib/files/patch-src_cgnstools_cgnsplot_plotwish.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/cgnstools/cgnsplot/plotwish.c.orig 2017-07-17 21:51:06 UTC
-+++ src/cgnstools/cgnsplot/plotwish.c
-@@ -20,8 +20,10 @@
- * Sun shared libraries to be used for Tcl.
- */
-
-+#ifndef __FreeBSD__
- extern int matherr();
- int *tclDummyMathPtr = (int *) matherr;
-+#endif /* FreeBSD test */
-
- extern int Cgnstcl_Init _ANSI_ARGS_((Tcl_Interp *interp));
- extern int Tkogl_Init _ANSI_ARGS_((Tcl_Interp *interp));
diff --git a/science/cgnslib/files/patch-src_cgnstools_cgnsview_cgiowish.c b/science/cgnslib/files/patch-src_cgnstools_cgnsview_cgiowish.c
deleted file mode 100644
index 0e8ddbec0512..000000000000
--- a/science/cgnslib/files/patch-src_cgnstools_cgnsview_cgiowish.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/cgnstools/cgnsview/cgiowish.c.orig 2017-07-17 21:51:06 UTC
-+++ src/cgnstools/cgnsview/cgiowish.c
-@@ -20,8 +20,10 @@
- * Sun shared libraries to be used for Tcl.
- */
-
-+#ifndef __FreeBSD__
- extern int matherr();
- int *tclDummyMathPtr = (int *) matherr;
-+#endif /* FreeBSD test */
-
- #ifdef TK_TEST
- extern int Tcltest_Init _ANSI_ARGS_((Tcl_Interp *interp));
diff --git a/science/cgnslib/pkg-plist b/science/cgnslib/pkg-plist
index 1393de6622e9..d07697de0d69 100644
--- a/science/cgnslib/pkg-plist
+++ b/science/cgnslib/pkg-plist
@@ -23,6 +23,7 @@
%%TOOLS%%bin/cgnstools/plotwish
%%TOOLS%%bin/cgnstools/tecplot_to_cgns
%%TOOLS%%bin/cgnstools/tetgen_to_cgns
+%%TOOLS%%bin/cgnstools/update_ngon
%%TOOLS%%bin/cgnstools/vgrid_to_cgns
%%TOOLS%%bin/cgnsview
%%TOOLS%%bin/unitconv
@@ -33,7 +34,7 @@ bin/cgnsdiff
bin/cgnslist
bin/cgnsnames
bin/cgnsupdate
-%%TESTS%%include/cgns.mod
+%%FORTRAN%%include/cgns.mod
include/cgnsBuild.defs
include/cgns_io.h
include/cgnsconfig.h
@@ -45,7 +46,7 @@ include/cgnswin_f.h
lib/libcgns.a
lib/libcgns.so
lib/libcgns.so.3
-lib/libcgns.so.3.3
+lib/libcgns.so.3.4
%%TOOLS%%share/cgnstools/aflr3.tcl
%%TOOLS%%share/cgnstools/balloon.tcl
%%TOOLS%%share/cgnstools/cgns-icon.xbm