aboutsummaryrefslogtreecommitdiff
path: root/science/cgnslib
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-04-01 09:00:23 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-04-01 09:00:23 +0000
commit18f7045bf239b57f2ff59fef6643158f958e4cdb (patch)
tree2ab80f6a6c1ca3bc8686960549a5dc5ef5662876 /science/cgnslib
parent4eee6dce59e8195898c3a9d99cf63bdeb8ff4f4c (diff)
downloadports-18f7045bf239b57f2ff59fef6643158f958e4cdb.tar.gz
ports-18f7045bf239b57f2ff59fef6643158f958e4cdb.zip
Notes
Diffstat (limited to 'science/cgnslib')
-rw-r--r--science/cgnslib/Makefile62
-rw-r--r--science/cgnslib/distinfo3
-rw-r--r--science/cgnslib/files/patch-make.defs.in18
-rw-r--r--science/cgnslib/files/patch-tests_rundbtest11
-rw-r--r--science/cgnslib/pkg-descr5
-rw-r--r--science/cgnslib/pkg-plist7
6 files changed, 106 insertions, 0 deletions
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
new file mode 100644
index 000000000000..78b95a7ca61d
--- /dev/null
+++ b/science/cgnslib/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: cgnslib
+# Date created: Sat 24 oct 2007
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= cgnslib
+DISTVERSION= 2.4-5
+CATEGORIES= science
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cgns
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= CFD General Notation System library code
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= F77=${F77}
+CONFIGURE_ARGS= --enable-shared=all
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
+USE_LDCONFIG= yes
+
+.if !defined(WITHOUT_HDF5)
+LIB_DEPENDS+= hdf5.0:${PORTSDIR}/science/hdf5
+CONFIGURE_ARGS+=--with-hdf5=${LOCALBASE}
+PLIST_SUB= HDF5=""
+.else
+CONFIGURE_ARGS+=--with-hdf5=no
+PLIST_SUB= HDF5="@comment "
+.endif
+
+.if !defined(WITHOUT_TESTS)
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+TESTSBIN= rundbtest cgwrite cgread
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:R}
+CNVBIN= adf2hdf hdf2adf
+
+post-build:
+.if !defined(WITHOUT_TESTS)
+ @(cd ${BUILD_WRKSRC}/tests; \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+ @(cd ${BUILD_WRKSRC}/tests; \
+ ${SETENV} ${MAKE_ENV} FOPTS="${FFLAGS} -I.." ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} fortran)
+.endif
+
+regression-test:
+.for pg in ${TESTSBIN}
+ @(cd ${BUILD_WRKSRC}/tests; ./${pg})
+.endfor
+
+post-install:
+ ${MV} ${PREFIX}/lib/libcgns.so ${PREFIX}/lib/libcgns.so.0
+ ${LN} -sf ${PREFIX}/lib/libcgns.so.0 ${PREFIX}/lib/libcgns.so
+ ${INSTALL_PROGRAM} ${CNVBIN:C|^|${BUILD_WRKSRC}/${OPSYS:U}/|} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/science/cgnslib/distinfo b/science/cgnslib/distinfo
new file mode 100644
index 000000000000..861c9590efa7
--- /dev/null
+++ b/science/cgnslib/distinfo
@@ -0,0 +1,3 @@
+MD5 (cgnslib_2.4-5.tar.gz) = f5e88b52ec30f2bc0b1fdacdd22821dc
+SHA256 (cgnslib_2.4-5.tar.gz) = dc865f609b44f8a67a72c71c2d8668c7eb344e70cb78e9f609f5b26da2059ed7
+SIZE (cgnslib_2.4-5.tar.gz) = 340469
diff --git a/science/cgnslib/files/patch-make.defs.in b/science/cgnslib/files/patch-make.defs.in
new file mode 100644
index 000000000000..29183fd239da
--- /dev/null
+++ b/science/cgnslib/files/patch-make.defs.in
@@ -0,0 +1,18 @@
+--- ./make.defs.in.orig Thu May 12 06:55:51 2005
++++ ./make.defs.in Sat Mar 24 21:33:14 2007
+@@ -48,7 +48,7 @@
+ CFLAGS = @CFLAGS@ @SYSCFLAGS@
+ COOUT = @COOUT@
+ CEOUT = @CEOUT@
+-CLIBS = @LIBS@
++CLIBS = @LIBS@ $(PTHREAD_LIBS)
+
+ #------------------------------------------------------------------------
+ # F2CFLAGS defines the type of Fortran to C interface.
+@@ -122,5 +122,5 @@
+ F77 = @F77@
+ FFLAGS = @FFLAGS@ @SYSFFLAGS@
+ FEOUT = @FEOUT@
+-FLIBS = @FLIBS@
++FLIBS = @FLIBS@ $(PTHREAD_LIBS)
+
diff --git a/science/cgnslib/files/patch-tests_rundbtest b/science/cgnslib/files/patch-tests_rundbtest
new file mode 100644
index 000000000000..36f5a84e3335
--- /dev/null
+++ b/science/cgnslib/files/patch-tests_rundbtest
@@ -0,0 +1,11 @@
+--- tests/rundbtest.orig Sat May 7 03:11:17 2005
++++ tests/rundbtest Sat Mar 24 21:41:06 2007
+@@ -5,7 +5,7 @@
+ values="1 10 100 1000 10000 100000"
+ for z in $zones ; do
+ for v in $values ; do
+- dbtest $z $v
++ ./dbtest $z $v
+ done
+ done
+ exit
diff --git a/science/cgnslib/pkg-descr b/science/cgnslib/pkg-descr
new file mode 100644
index 000000000000..8bda0cb52bf7
--- /dev/null
+++ b/science/cgnslib/pkg-descr
@@ -0,0 +1,5 @@
+The CFD General Notation System (CGNS) provides a standard for recording and
+recovering computer data associated with the numerical solution of the equations
+of fluid dynamics.
+
+WWW: http://www.cgns.org/
diff --git a/science/cgnslib/pkg-plist b/science/cgnslib/pkg-plist
new file mode 100644
index 000000000000..9a58dc7a5177
--- /dev/null
+++ b/science/cgnslib/pkg-plist
@@ -0,0 +1,7 @@
+%%HDF5%%bin/adf2hdf
+%%HDF5%%bin/hdf2adf
+include/cgnslib.h
+include/cgnswin_f.h
+include/cgnslib_f.h
+lib/libcgns.so
+lib/libcgns.so.0