aboutsummaryrefslogtreecommitdiff
path: root/science/chemtool-devel/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-05-10 01:29:11 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-05-10 01:29:11 +0000
commiteedd973e2574a47b406b04c8b189de82ecb00abe (patch)
tree1a592f2004e0a22a2195591a64d237ee088fcf0e /science/chemtool-devel/Makefile
parenteeb971c1304edc1b92cdb37d185df507672525b4 (diff)
downloadports-eedd973e2574a47b406b04c8b189de82ecb00abe.tar.gz
ports-eedd973e2574a47b406b04c8b189de82ecb00abe.zip
Notes
Diffstat (limited to 'science/chemtool-devel/Makefile')
-rw-r--r--science/chemtool-devel/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/science/chemtool-devel/Makefile b/science/chemtool-devel/Makefile
new file mode 100644
index 000000000000..6ca47cfcdb10
--- /dev/null
+++ b/science/chemtool-devel/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: chemtool
+# Date created: Mar 5, 2003
+# Whom: NAKATA, Maho <maho@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= chemtool
+PORTVERSION= 1.6
+CATEGORIES= science
+MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
+DISTNAME= ct16a29
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= Drawing organic molecules easily and store them (develop version)
+
+RUN_DEPENDS= transfig:${PORTSDIR}/print/transfig
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}alpha29
+USE_REINPLACE= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAN1= chemtool.1 cht.1
+
+do-build:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE})
+
+do-install:
+ @(cd ${WRKSRC}; ${GMAKE} install)
+ @(cd ${WRKSRC}; \
+ ${MKDIR} ${PREFIX}/share/examples/chemtool/; \
+ cd ${WRKSRC}/examples/; \
+ ${INSTALL_DATA} * ${PREFIX}/share/examples/chemtool; \
+ )
+
+.include <bsd.port.mk>