aboutsummaryrefslogtreecommitdiff
path: root/science/crf++
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-28 03:38:04 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-28 03:38:04 +0000
commit257561329d0635256d48db6a044b51ce68691cd4 (patch)
tree85c7bd3a37156d2e50a1eca6709d51adda46399b /science/crf++
parent0b8041f70083dfb0a7dc2d31b51df0461370fe43 (diff)
downloadports-257561329d0635256d48db6a044b51ce68691cd4.tar.gz
ports-257561329d0635256d48db6a044b51ce68691cd4.zip
Add crf++ 0.42, yet Another CRF toolkit.
PR: ports/100909 Submitted by: Cheng-Lung Sung <clsung at FreeBSD.org>
Notes
Notes: svn path=/head/; revision=168927
Diffstat (limited to 'science/crf++')
-rw-r--r--science/crf++/Makefile20
-rw-r--r--science/crf++/distinfo3
-rw-r--r--science/crf++/files/patch-ltmain.sh15
-rw-r--r--science/crf++/pkg-descr8
-rw-r--r--science/crf++/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/science/crf++/Makefile b/science/crf++/Makefile
new file mode 100644
index 000000000000..02dbaa7126a4
--- /dev/null
+++ b/science/crf++/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: crf++
+# Date created: 2006-07-27
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crf++
+PORTVERSION= 0.42
+CATEGORIES= science math
+MASTER_SITES= http://chasen.org/~taku/software/CRF++/src/
+DISTNAME= CRF++-${PORTVERSION}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Yet Another CRF toolkit
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/science/crf++/distinfo b/science/crf++/distinfo
new file mode 100644
index 000000000000..e7d33a7b79c3
--- /dev/null
+++ b/science/crf++/distinfo
@@ -0,0 +1,3 @@
+MD5 (CRF++-0.42.tar.gz) = 521fb502bc71f448fb9be3651f0b64e1
+SHA256 (CRF++-0.42.tar.gz) = 3028f1c813d7a53da031623a70a46585637f2546ee2edcde08b2c1a717550540
+SIZE (CRF++-0.42.tar.gz) = 494293
diff --git a/science/crf++/files/patch-ltmain.sh b/science/crf++/files/patch-ltmain.sh
new file mode 100644
index 000000000000..a534781a892e
--- /dev/null
+++ b/science/crf++/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Sun Oct 30 11:54:15 2005
++++ ltmain.sh Thu Jul 27 15:53:28 2006
+@@ -5550,10 +5550,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/science/crf++/pkg-descr b/science/crf++/pkg-descr
new file mode 100644
index 000000000000..bc8f9f70697f
--- /dev/null
+++ b/science/crf++/pkg-descr
@@ -0,0 +1,8 @@
+CRF++ is a simple, customizable, and open source
+implementation of Conditional Random Fields (CRFs)
+for segmenting/labeling sequential data. CRF++ is
+designed for generic purpose and will be applied to
+a variety of NLP tasks, such as Named Entity Recognition,
+Information Extraction and Text Chunking.
+
+WWW: http://chasen.org/~taku/software/CRF++/
diff --git a/science/crf++/pkg-plist b/science/crf++/pkg-plist
new file mode 100644
index 000000000000..87711f6c57e5
--- /dev/null
+++ b/science/crf++/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+bin/crf_learn
+bin/crf_test
+include/crfpp.h
+lib/libcrfpp.so.0
+lib/libcrfpp.so
+lib/libcrfpp.a