aboutsummaryrefslogtreecommitdiff
path: root/science/dcl/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-05-22 14:48:51 +0000
committerSteve Wills <swills@FreeBSD.org>2014-05-22 14:48:51 +0000
commit316144d889350323361b8eeed4947f1e82ec05c6 (patch)
tree0516eb3600fb27109a6de6951445f7f3c25c57fc /science/dcl/Makefile
parentc2f189426ec034797c34de14eac303a26abe5a14 (diff)
downloadports-316144d889350323361b8eeed4947f1e82ec05c6.tar.gz
ports-316144d889350323361b8eeed4947f1e82ec05c6.zip
Notes
Diffstat (limited to 'science/dcl/Makefile')
-rw-r--r--science/dcl/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/science/dcl/Makefile b/science/dcl/Makefile
index b6c7f72ad8cd..161826cf918c 100644
--- a/science/dcl/Makefile
+++ b/science/dcl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dcl
-PORTVERSION= 5.4.7
-PORTREVISION= 2
+PORTVERSION= 5.4.8
CATEGORIES= science graphics
MASTER_SITES= http://www.gfd-dennou.org/library/dcl/ \
http://dennou-h.gfd-dennou.org/library/dcl/ \
@@ -13,27 +12,26 @@ MAINTAINER= murashin@gfd-dennou.org
COMMENT= Scientific graphic library for geoscience
MAKE_JOBS_UNSAFE= yes
-USES= fortran pkgconfig
+USES= desthack pkgconfig fortran
USE_XORG= x11 xext
USE_GNOME= gtk20 gdkpixbuf2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-x
+CONFIGURE_ARGS= --with-x
PORTDOCS= CHECK CREDITS HISTORY README
PORTEXAMPLES= *
RESTRICTED= No commercial use
-NO_STAGE= yes
post-install:
.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/demo/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/demo/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.endif
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}/
.endfor
.endif