aboutsummaryrefslogtreecommitdiff
path: root/science/dvc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-08-13 20:23:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-08-13 20:23:18 +0000
commitc961d8783f75602d65173a12f1a82797bee82320 (patch)
tree1adfe1daf0f4fc0681f2fdcb194d361e0cc94ce1 /science/dvc
parent71d095407ea6e74c05c12830baf81989af4e0117 (diff)
downloadports-c961d8783f75602d65173a12f1a82797bee82320.tar.gz
ports-c961d8783f75602d65173a12f1a82797bee82320.zip
science/dvc: Remove the 2.7 python limitation because the cuplrit dependency is now python3-compatible
Notes
Notes: svn path=/head/; revision=544839
Diffstat (limited to 'science/dvc')
-rw-r--r--science/dvc/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/science/dvc/Makefile b/science/dvc/Makefile
index 331561039590..5b334791aa37 100644
--- a/science/dvc/Makefile
+++ b/science/dvc/Makefile
@@ -2,7 +2,7 @@
PORTNAME= dvc
DISTVERSION= 0.30.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
@@ -11,9 +11,6 @@ COMMENT= Git for data scientists: manage code and data together
LICENSE= APACHE20
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-08-15
-
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.3:devel/py-appdirs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}asciimatics>=1.10.0:devel/py-asciimatics@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}colorama>=0.3.9:devel/py-colorama@${PY_FLAVOR} \
@@ -23,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.3:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}future>=0.16.0:devel/py-future@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}GitPython>=2.1.8:devel/py-gitpython@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}grandalf==0.6:math/py-grandalf@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jsonpath-rw==1.4.0:devel/py-jsonpath-rw@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonpath-rw>0:devel/py-jsonpath-rw@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}nanotime>=0.5.2:devel/py-nanotime@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}networkx>=2.1:math/py-networkx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ply>=3.9:devel/py-ply@${PY_FLAVOR} \
@@ -33,8 +30,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.3:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}schema>=0.6.7:devel/py-schema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zclockfile>0:devel/py-zclockfile@${PY_FLAVOR}
-USES= python:2.7 # only because asciimatics is py27-only
-USE_PYTHON= distutils autoplist
+USES= python
+USE_PYTHON= distutils autoplist noflavors
NO_ARCH= yes