aboutsummaryrefslogtreecommitdiff
path: root/science/epte
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-08-23 16:07:29 +0000
committerJohn Marino <marino@FreeBSD.org>2016-08-23 16:07:29 +0000
commit46911f17268605c999a1bc5d678c7b4b8cafcd2c (patch)
tree6c901d8bde7360132ec26005b38754159a7f7c11 /science/epte
parent8243b48a1b3598693fd9fda6b34d4313cb9f2748 (diff)
downloadports-46911f17268605c999a1bc5d678c7b4b8cafcd2c.tar.gz
ports-46911f17268605c999a1bc5d678c7b4b8cafcd2c.zip
Notes
Diffstat (limited to 'science/epte')
-rw-r--r--science/epte/Makefile6
-rw-r--r--science/epte/files/patch-makefile11
-rw-r--r--science/epte/files/patch-periodic.h2
-rw-r--r--science/epte/files/patch-setaudio.c2
4 files changed, 14 insertions, 7 deletions
diff --git a/science/epte/Makefile b/science/epte/Makefile
index ce30560479e7..04ca867c7ceb 100644
--- a/science/epte/Makefile
+++ b/science/epte/Makefile
@@ -3,12 +3,14 @@
PORTNAME= epte
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://www.toddmiller.com/epte/
MAINTAINER= culot@FreeBSD.org
COMMENT= Electronic Periodic Table of the Elements
+USES= ncurses
MAKEFILE= makefile
ALL_TARGET= ${PORTNAME}
@@ -21,7 +23,7 @@ post-patch:
@${REINPLACE_CMD} 's|/usr|${PREFIX}|' ${WRKSRC}/epte.1
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/epte ${STAGEDIR}${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/epte.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/epte ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/epte.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/science/epte/files/patch-makefile b/science/epte/files/patch-makefile
index b5fd844ccb35..79dfaad5481b 100644
--- a/science/epte/files/patch-makefile
+++ b/science/epte/files/patch-makefile
@@ -1,5 +1,5 @@
---- makefile.orig 2010-09-01 10:41:27.655060824 +0200
-+++ makefile 2010-09-01 10:46:21.341029572 +0200
+--- makefile.orig 2012-08-04 20:53:21 UTC
++++ makefile
@@ -320,13 +320,13 @@ IS_INTERACTIVE= yes
#ifdef VMS
CC = cc
@@ -17,7 +17,12 @@
#endif
-@@ -344,7 +344,7 @@ LIBS = -lcursesX -o epte
+@@ -340,11 +340,11 @@ DISTNAME = [system]
+ LIBS = -lcursesX -o epte
+ #endif
+ # Use ncurses library for linux & FreeBSD
+-#if defined(linux) || defined(__FreeBSD__)
++#if defined(linux) || defined(__FreeBSD__) || defined(__DragonFly__)
LIBS = -lncurses -o epte
#endif
diff --git a/science/epte/files/patch-periodic.h b/science/epte/files/patch-periodic.h
index dd6c5c4159cd..42be948ae5cc 100644
--- a/science/epte/files/patch-periodic.h
+++ b/science/epte/files/patch-periodic.h
@@ -5,7 +5,7 @@
#include <curses.h>
#endif
-#if defined(linux) || defined(__FreeBSD)
-+#if defined(linux) || defined(__FreeBSD__)
++#if defined(linux) || defined(__FreeBSD__) || defined(__DragonFly__)
#include <ncurses.h>
#endif
diff --git a/science/epte/files/patch-setaudio.c b/science/epte/files/patch-setaudio.c
index 8e0da6673155..b764c3f1029a 100644
--- a/science/epte/files/patch-setaudio.c
+++ b/science/epte/files/patch-setaudio.c
@@ -5,7 +5,7 @@
char *file_name;
-#ifdef VMS
-+#if defined(VMS) || defined(__FreeBSD__)
++#if defined(VMS) || defined(__FreeBSD__) || defined(__DragonFly__)
#else
/* The audio device sometimes does not work if it is left open for a long