aboutsummaryrefslogtreecommitdiff
path: root/science/fastcap/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-15 10:36:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-15 10:36:29 +0000
commit8aa1e9d39cb8e6e5599ffa463a7294da7b889a80 (patch)
treec13736a07784189c719c7f69c4952b866cb85a62 /science/fastcap/Makefile
parentfadc2e1699b6e842826b59e71cc2f7e0d6c2f5b0 (diff)
downloadports-8aa1e9d39cb8e6e5599ffa463a7294da7b889a80.tar.gz
ports-8aa1e9d39cb8e6e5599ffa463a7294da7b889a80.zip
Notes
Diffstat (limited to 'science/fastcap/Makefile')
-rw-r--r--science/fastcap/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/science/fastcap/Makefile b/science/fastcap/Makefile
new file mode 100644
index 000000000000..7c7839a6ba02
--- /dev/null
+++ b/science/fastcap/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: FastCap
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fastcap
+DISTVERSION= ${P_VERSION}wr
+CATEGORIES= science cad
+MASTER_SITES= ftp://ftp.srware.com/pub/ \
+ http://www.wrcad.com/ftp/pub/
+
+MAINTAINER= giffunip@asme.org
+COMMENT= A three-dimensional capacitance extraction program
+
+P_VERSION= 2.0
+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= config
+
+BINFILES= busgen capgen cubegen fastcap pipedgen pyragen
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,TYPE=other,TYPE=4,' \
+ ${WRKSRC}/config
+ @${REINPLACE_CMD} -e 's,CFLAGS =,CFLAGS +=,' \
+ ${WRKSRC}/src/Makefile.4
+
+do-install:
+.for b in ${BINFILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/${b} ${PREFIX}/bin/
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CAT} ${WRKSRC}/README ${WRKSRC}/README.mit > ${DOCSDIR}/readme
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.ps ${DOCSDIR}
+ ${GZIP_CMD} ${DOCSDIR}/*
+.endif
+
+.include <bsd.port.mk>