aboutsummaryrefslogtreecommitdiff
path: root/science/fasthenry
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-08-20 11:28:54 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-08-20 11:28:54 +0000
commit81711c866dcb6a62da0aa5a18af8a32b33dc659a (patch)
treeceeecce8d4be02f1e6f260498d90fbd2cc3a986d /science/fasthenry
parent509a931849bfff34f19cd5c504082e1d8cc56386 (diff)
downloadports-81711c866dcb6a62da0aa5a18af8a32b33dc659a.tar.gz
ports-81711c866dcb6a62da0aa5a18af8a32b33dc659a.zip
Notes
Diffstat (limited to 'science/fasthenry')
-rw-r--r--science/fasthenry/Makefile29
1 files changed, 28 insertions, 1 deletions
diff --git a/science/fasthenry/Makefile b/science/fasthenry/Makefile
index ff74b3139945..da9372c09977 100644
--- a/science/fasthenry/Makefile
+++ b/science/fasthenry/Makefile
@@ -18,9 +18,36 @@ CONFIGURE_SCRIPT= config
WRKSRC = ${WRKDIR}/fasthenry-3.0wr
post-patch:
- @${REINPLACE_CMD} -e 's,CFLAGS =, CFLAGS +=,' \
+ @${REINPLACE_CMD} -Ee '/CFLAGS =/{s/=/+=/;s/-O[[:digit:]]*//;}' \
${WRKSRC}/src/fasthenry/Makefile.default \
+ ${WRKSRC}/src/fasthenry/sparse/Makefile \
${WRKSRC}/src/zbuf/Makefile.default
+#minimal changes to fix the clang build (there should be a more thorough
+#clean-up, to correct types of functions, remove implicit declarations, fix
+#formatting, add missing returns, etc.)
+ @${REINPLACE_CMD} -e 's,return;,return 0;,' \
+ ${WRKSRC}/src/fasthenry/barnoldi.c \
+ ${WRKSRC}/src/fasthenry/contact.c \
+ ${WRKSRC}/src/fasthenry/findpaths.c \
+ ${WRKSRC}/src/fasthenry/fillM.c \
+ ${WRKSRC}/src/fasthenry/hole.c \
+ ${WRKSRC}/src/fasthenry/induct.c \
+ ${WRKSRC}/src/fasthenry/joelself.c \
+ ${WRKSRC}/src/fasthenry/mulSetup.c \
+ ${WRKSRC}/src/fasthenry/read_tree.c
+ @${REINPLACE_CMD} -Ee \
+ '/^(AllocateBlockOfAllocationList|InitializeElementBlocks|RecordAllocation)/,/^\}/s/return;/return 0;/' \
+ ${WRKSRC}/src/fasthenry/sparse/spAllocate.c
+ @${REINPLACE_CMD} -Ee \
+ '/^(EnlargeMatrix|ExpandTranslationArrays|spcLinkRows)/,/^\}/s/return;/return 0;/' \
+ ${WRKSRC}/src/fasthenry/sparse/spBuild.c
+ @${REINPLACE_CMD} -Ee \
+ '/^(ComplexRowColElimination|CountMarkowitz|CreateInternalVectors|ExchangeColElements|ExchangeRowElements|ExchangeRowsAndCols|MarkowitzProducts|RealRowColElimination|UpdateMarkowitzNumbers|spcColExchange|spcRowExchange)/,/^\}/s/return;/return 0;/' \
+ ${WRKSRC}/src/fasthenry/sparse/spFactor.c
+ @${REINPLACE_CMD} -Ee 's,^mul(Up|Down),void &,' \
+ ${WRKSRC}/src/fasthenry/mulDo.c
+ @${REINPLACE_CMD} -e 's,^mulMatUp,void &,' \
+ ${WRKSRC}/src/fasthenry/mulMats.c
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/bin/fasthenry ${PREFIX}/bin/