aboutsummaryrefslogtreecommitdiff
path: root/science/flounder/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2012-12-23 19:11:12 +0000
committerBeech Rintoul <beech@FreeBSD.org>2012-12-23 19:11:12 +0000
commit6bec834a464e936fcb6eafcf2b3c3ef4c2c2eff4 (patch)
treea92c0760fdc6946fb746b4a6dd05c22cc4465254 /science/flounder/Makefile
parent6e2fa0573bdbe896a47e2e1d3e49cd84e62d1555 (diff)
downloadports-6bec834a464e936fcb6eafcf2b3c3ef4c2c2eff4.tar.gz
ports-6bec834a464e936fcb6eafcf2b3c3ef4c2c2eff4.zip
Notes
Diffstat (limited to 'science/flounder/Makefile')
-rw-r--r--science/flounder/Makefile60
1 files changed, 36 insertions, 24 deletions
diff --git a/science/flounder/Makefile b/science/flounder/Makefile
index fceba98f4b34..8bf193e0c0ec 100644
--- a/science/flounder/Makefile
+++ b/science/flounder/Makefile
@@ -1,14 +1,9 @@
-# ex:ts=8
-# Ports collection Makefile for: flounder
-# Date created: Oct 14, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= flounder
PORTVERSION= 0.40
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= science
MASTER_SITES= http://www.enel.ucalgary.ca/People/vigmond/flounder/
EXTRACT_SUFX= .tgz
@@ -16,35 +11,52 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A quick way to visualize regularly spaced 4D data
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- gif:${PORTSDIR}/graphics/giflib \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
+ png15:${PORTSDIR}/graphics/png \
+ fltk:${PORTSDIR}/x11-toolkits/fltk
+
+OPTIONS_DEFINE= GNUPLOT GRACE
+OPTIONS_DEFAULT=GNUPLOT GRACE
+GRACE_DESC= Plotting via GRACE
USE_GL= glut
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lstdc++
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+PLIST_FILES= bin/flounder bin/igbhead
-.if !defined(WITHOUT_PLOT)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNUPLOT}
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
CONFIGURE_ARGS+= --enable-gnuplot
.endif
-.if !defined(WITHOUT_GRACE)
+.if ${PORT_OPTIONS:MGRACE}
BUILD_DEPENDS+= xmgrace:${PORTSDIR}/math/grace
RUN_DEPENDS+= xmgrace:${PORTSDIR}/math/grace
CONFIGURE_ARGS+= --enable-grace
.endif
post-patch:
- ${REINPLACE_CMD} -e "s|-lungif|-lgif|" ${WRKSRC}/configure
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha"
-BROKEN= Does not compile on alpha
-.endif
-
-.include <bsd.port.post.mk>
+ @${REINPLACE_CMD} -e \
+ 's|-lungif|-lgif|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|cmdline.o.*|cmdline.o| ; \
+ /getopt.o/d ; \
+ /getopt1.o/d ; \
+ s|g++ |$$(CXX) | ; \
+ s|-g | |' ${WRKSRC}/utils/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|^main(|int main(|' ${WRKSRC}/utils/igbhead.cc
+
+do-install:
+ cd ${WRKSRC}/src && ${INSTALL_PROGRAM} flounder ${PREFIX}/bin
+ cd ${WRKSRC}/utils && ${INSTALL_PROGRAM} igbhead ${PREFIX}/bin
+
+.include <bsd.port.mk>