aboutsummaryrefslogtreecommitdiff
path: root/science/gchempaint
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-05-24 22:22:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-05-24 22:22:53 +0000
commitb89a4d4dead7bf908e908df661a60525dc1ea61a (patch)
tree482b09e28c8a1bbaddf2c36e81556a0096694cb8 /science/gchempaint
parent923ec58864ec5f21cc5d30d2ef20a05518fca780 (diff)
downloadports-b89a4d4dead7bf908e908df661a60525dc1ea61a.tar.gz
ports-b89a4d4dead7bf908e908df661a60525dc1ea61a.zip
Notes
Diffstat (limited to 'science/gchempaint')
-rw-r--r--science/gchempaint/Makefile17
-rw-r--r--science/gchempaint/distinfo6
-rw-r--r--science/gchempaint/files/patch-goffice-gchempaint.cc10
-rw-r--r--science/gchempaint/pkg-plist156
4 files changed, 82 insertions, 107 deletions
diff --git a/science/gchempaint/Makefile b/science/gchempaint/Makefile
index 013534d11c16..4afede99454e 100644
--- a/science/gchempaint/Makefile
+++ b/science/gchempaint/Makefile
@@ -5,28 +5,31 @@
# $FreeBSD$
PORTNAME= gchempaint
-PORTVERSION= 0.6.9
-PORTREVISION= 1
+PORTVERSION= 0.8.0
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}/0.6
+MASTER_SITE_SUBDIR= ${PORTNAME}/0.8
MAINTAINER= pav@FreeBSD.org
COMMENT= 2D chemical structures editor for GNOME 2
BUILD_DEPENDS= gnome-doc-prepare:${PORTSDIR}/textproc/gnome-doc-utils
-LIB_DEPENDS= gcu.6:${PORTSDIR}/science/gchemutils
+LIB_DEPENDS= gcu.8:${PORTSDIR}/science/gchemutils
USE_BZIP2= yes
USE_XLIB= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
-GCONF_SCHEMAS= gchempaint-arrows.schemas
-USE_GNOME= gnomehack gnomeprefix intlhack libgnomeprintui libgnomeui
+GCONF_SCHEMAS= gchempaint.schemas gchempaint-arrows.schemas
+USE_GNOME= gnomehack intlhack libgnomeprintui libgnomeui
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-help-dir=${PREFIX}/share/gnome/help
+CONFIGURE_ARGS= --with-help-dir=${PREFIX}/share/gnome/help --with-omf-dir=${PREFIX}/share/gnome/omf
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-release $$(VERSION)|-version @GCP_VERSION_INFO@|' \
+ ${WRKSRC}/lib/Makefile.in ${WRKSRC}/libgcpcanvas/Makefile.in
.include <bsd.port.mk>
diff --git a/science/gchempaint/distinfo b/science/gchempaint/distinfo
index 15cf02b89090..946775f8d48f 100644
--- a/science/gchempaint/distinfo
+++ b/science/gchempaint/distinfo
@@ -1,3 +1,3 @@
-MD5 (gchempaint-0.6.9.tar.bz2) = 3b81f99972bedccd5f19a6bda785d451
-SHA256 (gchempaint-0.6.9.tar.bz2) = df47e85bf3fab81227a09a4d9bfc57abf3319d9cc43999b2abba75d6bff4c74a
-SIZE (gchempaint-0.6.9.tar.bz2) = 914354
+MD5 (gchempaint-0.8.0.tar.bz2) = 8ddac8bf752e927197b42f91b3d2e24a
+SHA256 (gchempaint-0.8.0.tar.bz2) = 2422e0781dc3fc63787c7b3fe281c75381887e0087279f2ec8ce0ab0b3ac34d4
+SIZE (gchempaint-0.8.0.tar.bz2) = 1355062
diff --git a/science/gchempaint/files/patch-goffice-gchempaint.cc b/science/gchempaint/files/patch-goffice-gchempaint.cc
new file mode 100644
index 000000000000..9c8db643f024
--- /dev/null
+++ b/science/gchempaint/files/patch-goffice-gchempaint.cc
@@ -0,0 +1,10 @@
+--- goffice/gchempaint.cc.orig Mon May 7 18:27:11 2007
++++ goffice/gchempaint.cc Mon May 21 19:17:04 2007
+@@ -31,6 +31,7 @@
+ #include <libgnomecanvas/gnome-canvas.h>
+ #include <math.h>
+ #include <openbabel/mol.h>
++#include <libintl.h>
+
+ gcpGOfficeApplication *app;
+
diff --git a/science/gchempaint/pkg-plist b/science/gchempaint/pkg-plist
index d1dbc91b0260..f700426090d7 100644
--- a/science/gchempaint/pkg-plist
+++ b/science/gchempaint/pkg-plist
@@ -1,37 +1,4 @@
bin/gchempaint
-bin/gchempaint-viewer
-include/gchempaint/about.h
-include/gchempaint/application.h
-include/gchempaint/arrow.h
-include/gchempaint/atom.h
-include/gchempaint/bond.h
-include/gchempaint/cycle.h
-include/gchempaint/dialog.h
-include/gchempaint/docprop.h
-include/gchempaint/document.h
-include/gchempaint/electron.h
-include/gchempaint/filechooser.h
-include/gchempaint/fragment.h
-include/gchempaint/fragment-atom.h
-include/gchempaint/chain.h
-include/gchempaint/mendeleiev.h
-include/gchempaint/mesomery.h
-include/gchempaint/mesomery-arrow.h
-include/gchempaint/mesomer.h
-include/gchempaint/molecule.h
-include/gchempaint/operation.h
-include/gchempaint/plugin.h
-include/gchempaint/reactant.h
-include/gchempaint/reaction.h
-include/gchempaint/reaction-arrow.h
-include/gchempaint/reaction-operator.h
-include/gchempaint/reaction-step.h
-include/gchempaint/settings.h
-include/gchempaint/text.h
-include/gchempaint/text-object.h
-include/gchempaint/tool.h
-include/gchempaint/view.h
-include/gchempaint/widgetdata.h
lib/gchempaint/plugins/arrows.la
lib/gchempaint/plugins/arrows.so
lib/gchempaint/plugins/atoms.la
@@ -46,63 +13,51 @@ lib/gchempaint/plugins/templates.la
lib/gchempaint/plugins/templates.so
lib/gchempaint/plugins/text.la
lib/gchempaint/plugins/text.so
+lib/goffice/0.4.0/plugins/gchempaint/gchempaint.la
+lib/goffice/0.4.0/plugins/gchempaint/gchempaint.so
+lib/goffice/0.4.0/plugins/gchempaint/plugin.xml
+lib/libgcpcanvas.la
+lib/libgcpcanvas.so
+lib/libgcpcanvas.so.0
lib/libgchempaint.la
lib/libgchempaint.so
-lib/libgchempaint.so.6
-libdata/bonobo/servers/gchempaint.server
-share/gnome/applications/gchempaint.desktop
-share/gnome/gchempaint/pixmaps/gchempaint_logo.png
-share/gnome/gchempaint/templates/templates.xml
-share/gnome/gchempaint/ui/arrows.xml
-share/gnome/gchempaint/ui/arrowtool.glade
-share/gnome/gchempaint/ui/arrow1-24.png
-share/gnome/gchempaint/ui/arrow2-24.png
-share/gnome/gchempaint/ui/atoms.xml
-share/gnome/gchempaint/ui/bonds.xml
-share/gnome/gchempaint/ui/bond24.png
-share/gnome/gchempaint/ui/cn-24.png
-share/gnome/gchempaint/ui/cyclentool.glade
-share/gnome/gchempaint/ui/cycles.xml
-share/gnome/gchempaint/ui/c3-24.png
-share/gnome/gchempaint/ui/c4-24.png
-share/gnome/gchempaint/ui/c5-24.png
-share/gnome/gchempaint/ui/c6-24.png
-share/gnome/gchempaint/ui/c7-24.png
-share/gnome/gchempaint/ui/c8-24.png
-share/gnome/gchempaint/ui/docprop.glade
-share/gnome/gchempaint/ui/downbond24.png
-share/gnome/gchempaint/ui/electronpair24.png
-share/gnome/gchempaint/ui/element24.png
-share/gnome/gchempaint/ui/eraser24.png
-share/gnome/gchempaint/ui/fragment24.png
-share/gnome/gchempaint/ui/gchempaint.xml
-share/gnome/gchempaint/ui/group.glade
-share/gnome/gchempaint/ui/horiz24.png
-share/gnome/gchempaint/ui/charge-24.png
-share/gnome/gchempaint/ui/charge+24.png
-share/gnome/gchempaint/ui/mendeleiev.glade
-share/gnome/gchempaint/ui/merge24.png
-share/gnome/gchempaint/ui/mesomery24.png
-share/gnome/gchempaint/ui/new-template.glade
-share/gnome/gchempaint/ui/retrosynth24.png
-share/gnome/gchempaint/ui/rotate24.png
-share/gnome/gchempaint/ui/selection24.png
-share/gnome/gchempaint/ui/selection.xml
-share/gnome/gchempaint/ui/subscript24.png
-share/gnome/gchempaint/ui/superscript24.png
-share/gnome/gchempaint/ui/templates.glade
-share/gnome/gchempaint/ui/templates.xml
-share/gnome/gchempaint/ui/text24.png
-share/gnome/gchempaint/ui/text.xml
-share/gnome/gchempaint/ui/unpairedelectron24.png
-share/gnome/gchempaint/ui/upbond24.png
-share/gnome/gchempaint/ui/vert24.png
-share/gnome/gchempaint/ui/xbond24.png
+lib/libgchempaint.so.0
+share/applications/gchempaint.desktop
+share/gchempaint/pixmaps/gchempaint_logo.png
+share/gchempaint/templates/haworth.xml
+share/gchempaint/templates/templates.xml
+share/gchempaint/ui/H-pos.glade
+share/gchempaint/ui/arrow.png
+share/gchempaint/ui/arrowtool.glade
+share/gchempaint/ui/bond.glade
+share/gchempaint/ui/chain.glade
+share/gchempaint/ui/cycle.glade
+share/gchempaint/ui/cyclen.glade
+share/gchempaint/ui/docprop.glade
+share/gchempaint/ui/fontsel.glade
+share/gchempaint/ui/gchempaint.xml
+share/gchempaint/ui/group.glade
+share/gchempaint/ui/new-template.glade
+share/gchempaint/ui/newfiledlg.glade
+share/gchempaint/ui/preferences.glade
+share/gchempaint/ui/stringdlg.glade
+share/gchempaint/ui/templates.glade
+share/gchempaint/ui/tools.glade
+share/gchempaint/ui/zoom.glade
share/gnome/help/gchempaint/C/legal.xml
share/gnome/help/gchempaint/C/gchempaint.xml
+share/gnome/help/gchempaint/C/figures/Hposdlg.png
share/gnome/help/gchempaint/C/figures/arrow-heads.png
+share/gnome/help/gchempaint/C/figures/arrow-opts.png
+share/gnome/help/gchempaint/C/figures/arrows.png
+share/gnome/help/gchempaint/C/figures/bond-opts.png
share/gnome/help/gchempaint/C/figures/bond.png
+share/gnome/help/gchempaint/C/figures/chain-opt.png
+share/gnome/help/gchempaint/C/figures/chain.png
share/gnome/help/gchempaint/C/figures/charges.png
+share/gnome/help/gchempaint/C/figures/choose-elt.png
+share/gnome/help/gchempaint/C/figures/cycle-opt.png
+share/gnome/help/gchempaint/C/figures/cyclentool-opt.png
share/gnome/help/gchempaint/C/figures/cyclentool.png
share/gnome/help/gchempaint/C/figures/cycletools.png
share/gnome/help/gchempaint/C/figures/delocalized-bond.png
@@ -114,36 +69,43 @@ share/gnome/help/gchempaint/C/figures/group.png
share/gnome/help/gchempaint/C/figures/main-window.png
share/gnome/help/gchempaint/C/figures/mechanism-arrows.png
share/gnome/help/gchempaint/C/figures/mendeleiev.png
+share/gnome/help/gchempaint/C/figures/merge.png
share/gnome/help/gchempaint/C/figures/merge1.png
share/gnome/help/gchempaint/C/figures/merge2.png
share/gnome/help/gchempaint/C/figures/merge3.png
-share/gnome/help/gchempaint/C/figures/merge.png
+share/gnome/help/gchempaint/C/figures/mesomery-arrow.png
share/gnome/help/gchempaint/C/figures/mesomery1.png
share/gnome/help/gchempaint/C/figures/mesomery2.png
share/gnome/help/gchempaint/C/figures/mesomery3.png
-share/gnome/help/gchempaint/C/figures/mesomery-arrow.png
share/gnome/help/gchempaint/C/figures/new-template.png
+share/gnome/help/gchempaint/C/figures/newfile.png
share/gnome/help/gchempaint/C/figures/plus.png
+share/gnome/help/gchempaint/C/figures/preferences.png
+share/gnome/help/gchempaint/C/figures/prefs-arrows.png
+share/gnome/help/gchempaint/C/figures/prefs-atoms-font.png
+share/gnome/help/gchempaint/C/figures/prefs-atoms-other.png
+share/gnome/help/gchempaint/C/figures/prefs-bonds.png
+share/gnome/help/gchempaint/C/figures/prefs-text.png
share/gnome/help/gchempaint/C/figures/properties.png
+share/gnome/help/gchempaint/C/figures/reaction-arrows.png
share/gnome/help/gchempaint/C/figures/reaction1.png
share/gnome/help/gchempaint/C/figures/reaction2.png
share/gnome/help/gchempaint/C/figures/reaction3.png
share/gnome/help/gchempaint/C/figures/reaction4.png
share/gnome/help/gchempaint/C/figures/reaction5.png
-share/gnome/help/gchempaint/C/figures/reaction-arrows.png
+share/gnome/help/gchempaint/C/figures/retrosynthesis.png
share/gnome/help/gchempaint/C/figures/retrosynthesis1.png
share/gnome/help/gchempaint/C/figures/retrosynthesis2.png
share/gnome/help/gchempaint/C/figures/retrosynthesis3.png
share/gnome/help/gchempaint/C/figures/retrosynthesis4.png
-share/gnome/help/gchempaint/C/figures/retrosynthesis.png
share/gnome/help/gchempaint/C/figures/rotate.png
share/gnome/help/gchempaint/C/figures/selection.png
share/gnome/help/gchempaint/C/figures/stereobonds.png
-share/gnome/help/gchempaint/C/figures/templates.png
share/gnome/help/gchempaint/C/figures/templates-tools.png
+share/gnome/help/gchempaint/C/figures/templates.png
share/gnome/help/gchempaint/C/figures/text.png
share/gnome/help/gchempaint/C/figures/texttools-bar.png
-share/gnome/mimelnk/application/x-gchempaint.desktop
+share/gnome/help/gchempaint/C/figures/toolbox.png
share/gnome/omf/gchempaint/gchempaint-C.omf
share/icons/hicolor/32x32/apps/gchempaint.png
share/icons/hicolor/32x32/mimetypes/gnome-mime-application-x-gchempaint.png
@@ -161,20 +123,20 @@ share/locale/ru/LC_MESSAGES/gchempaint.mo
share/locale/zh_CN/LC_MESSAGES/gchempaint.mo
share/mime/application/x-gchempaint.xml
share/mime/packages/gchempaint.xml
-share/mime/chemical/x-chemdraw.xml
share/mime/chemical/x-cml.xml
-@dirrm share/gnome/gchempaint/ui
-@dirrm share/gnome/gchempaint/templates
-@dirrm share/gnome/gchempaint/pixmaps
-@dirrm share/gnome/gchempaint
+share/mimelnk/application/x-gchempaint.desktop
+@dirrmtry share/mimelnk/application
+@dirrmtry share/mimelnk
+@dirrm share/gchempaint/ui
+@dirrm share/gchempaint/templates
+@dirrm share/gchempaint/pixmaps
+@dirrm share/gchempaint
@dirrm share/gnome/help/gchempaint/C/figures
@dirrm share/gnome/help/gchempaint/C
@dirrm share/gnome/help/gchempaint
-@dirrmtry share/gnome/mimelnk/application
-@dirrmtry share/gnome/mimelnk
@dirrm share/gnome/omf/gchempaint
+@dirrm lib/goffice/0.4.0/plugins/gchempaint
@dirrm lib/gchempaint/plugins
@dirrm lib/gchempaint
-@dirrm include/gchempaint
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime