aboutsummaryrefslogtreecommitdiff
path: root/science/gchempaint
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-17 12:33:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-17 12:33:36 +0000
commitec5bba0564421f74698a750dc2409ba9595e455c (patch)
tree680fc43f11a11007ae412f80749779c16c993002 /science/gchempaint
parent99f0ad08691194e519446d911f9b66719b661bce (diff)
downloadports-ec5bba0564421f74698a750dc2409ba9595e455c.tar.gz
ports-ec5bba0564421f74698a750dc2409ba9595e455c.zip
Notes
Diffstat (limited to 'science/gchempaint')
-rw-r--r--science/gchempaint/Makefile2
-rw-r--r--science/gchempaint/distinfo4
-rw-r--r--science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-rich-text.c31
-rw-r--r--science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-text.c19
4 files changed, 3 insertions, 53 deletions
diff --git a/science/gchempaint/Makefile b/science/gchempaint/Makefile
index 9e1cdf3f420e..58873004daab 100644
--- a/science/gchempaint/Makefile
+++ b/science/gchempaint/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= gchempaint
-PORTVERSION= 0.4.13
+PORTVERSION= 0.4.14
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/science/gchempaint/distinfo b/science/gchempaint/distinfo
index 454581419d4f..821901d5ded7 100644
--- a/science/gchempaint/distinfo
+++ b/science/gchempaint/distinfo
@@ -1,2 +1,2 @@
-MD5 (gchempaint-0.4.13.tar.bz2) = b66e03cbac634d6e1565707f88bec8f5
-SIZE (gchempaint-0.4.13.tar.bz2) = 681493
+MD5 (gchempaint-0.4.14.tar.bz2) = f72aea94e73e0f8e741ab692d15caa9d
+SIZE (gchempaint-0.4.14.tar.bz2) = 681690
diff --git a/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-rich-text.c b/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-rich-text.c
deleted file mode 100644
index 726c749fa42f..000000000000
--- a/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-rich-text.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- libgcpcanvas/gcp-canvas-rich-text.c.orig Mon Nov 29 08:46:09 2004
-+++ libgcpcanvas/gcp-canvas-rich-text.c Tue Nov 30 00:19:42 2004
-@@ -1699,9 +1699,10 @@
- static gboolean
- request_update(gpointer data)
- {
-+ GnomeCanvasRichTextExt *text;
- if (!GNOME_IS_CANVAS_RICH_TEXT_EXT (data))
- return;
-- GnomeCanvasRichTextExt *text = GNOME_CANVAS_RICH_TEXT_EXT(data);
-+ text = GNOME_CANVAS_RICH_TEXT_EXT(data);
-
- gnome_canvas_item_request_update(GNOME_CANVAS_ITEM(text));
-
-@@ -2420,10 +2421,13 @@
- gnome_canvas_rich_text_ext_ensure_rendered (GnomeCanvasRichTextExt *text)
- {
- double x1, y1, x2, y2;
-- get_bounds (text, &x1, &y1, &x2, &y2);
-- int w = (int) (ceil (x2) - floor (x1)) + 1, h = (int) (ceil (y2) - floor (y1)) + 1;
-- GdkPixbuf *pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB, FALSE, 8, w, h);
-+ int w, h;
-+ GdkPixbuf *pixbuf;
- GnomeCanvasBuf buf;
-+
-+ get_bounds (text, &x1, &y1, &x2, &y2);
-+ w = (int) (ceil (x2) - floor (x1)) + 1, h = (int) (ceil (y2) - floor (y1)) + 1;
-+ pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB, FALSE, 8, w, h);
- buf.buf = gdk_pixbuf_get_pixels (pixbuf);
- buf.rect.x0 = (int) floor (x1);
- buf.rect.x1 = (int) ceil (x2);
diff --git a/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-text.c b/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-text.c
deleted file mode 100644
index 8c8af6a3d4ef..000000000000
--- a/science/gchempaint/files/patch-libgcpcanvas-gcp-canvas-text.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- libgcpcanvas/gcp-canvas-text.c.orig Mon Nov 29 08:46:09 2004
-+++ libgcpcanvas/gcp-canvas-text.c Tue Nov 30 00:37:59 2004
-@@ -228,10 +228,13 @@
- gnome_canvas_text_ext_ensure_rendered (GnomeCanvasTextExt *text)
- {
- double x1, y1, x2, y2;
-- gnome_canvas_item_get_bounds (GNOME_CANVAS_ITEM (text), &x1, &y1, &x2, &y2);
-- int w = (int) (ceil (x2) - floor (x1)) + 1, h = (int) (ceil (y2) - floor (y1)) + 1;
-- GdkPixbuf *pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB, FALSE, 8, w, h);
-+ int w, h;
- GnomeCanvasBuf buf;
-+ GdkPixbuf *pixbuf;
-+
-+ gnome_canvas_item_get_bounds (GNOME_CANVAS_ITEM (text), &x1, &y1, &x2, &y2);
-+ w = (int) (ceil (x2) - floor (x1)) + 1, h = (int) (ceil (y2) - floor (y1)) + 1;
-+ pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB, FALSE, 8, w, h);
- buf.buf = gdk_pixbuf_get_pixels (pixbuf);
- buf.rect.x0 = (int) floor (x1);
- buf.rect.x1 = (int) ceil (x2);