aboutsummaryrefslogtreecommitdiff
path: root/science/gchemutils
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-06-27 11:42:57 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-06-27 11:42:57 +0000
commite70cf0a91ebcecc9153e617933c6d734e5544dc7 (patch)
tree7ba2f49be1dbfd11d36e94786e57ffa622c0ee02 /science/gchemutils
parent3e0fd1eb7478ce941094894735d3888a9174f5e2 (diff)
downloadports-e70cf0a91ebcecc9153e617933c6d734e5544dc7.tar.gz
ports-e70cf0a91ebcecc9153e617933c6d734e5544dc7.zip
Notes
Diffstat (limited to 'science/gchemutils')
-rw-r--r--science/gchemutils/Makefile47
-rw-r--r--science/gchemutils/distinfo4
-rw-r--r--science/gchemutils/files/patch-libs-gcu-spectrumdoc.cc11
-rw-r--r--science/gchemutils/files/patch-libs_gcu_application.cc10
-rw-r--r--science/gchemutils/pkg-plist178
5 files changed, 117 insertions, 133 deletions
diff --git a/science/gchemutils/Makefile b/science/gchemutils/Makefile
index 3ce411e5172b..e39a5ab33890 100644
--- a/science/gchemutils/Makefile
+++ b/science/gchemutils/Makefile
@@ -1,44 +1,38 @@
-# New ports collection makefile for: gchemutils
-# Date created: Mar 18, 2003
-# Whom: Pav Lucistnik <pav@oook.cz>
-#
+# Created by: Pav Lucistnik <pav@oook.cz>
# $FreeBSD$
-#
PORTNAME= gchemutils
-PORTVERSION= 0.12.10
-PORTREVISION= 2
+PORTVERSION= 0.14.2
CATEGORIES= science
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= ${PORTNAME}/0.12
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION:R}
DISTNAME= gnome-chemistry-utils-${PORTVERSION}
MAINTAINER= kwm@FreeBSD.org
-COMMENT= C++ classes and Gtk2 widgets related to chemistry
+COMMENT= C++ classes and Gtk3 widgets related to chemistry
-LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext \
- openbabel:${PORTSDIR}/science/openbabel \
- goffice-0.8.8:${PORTSDIR}/devel/goffice
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/bodr.pc:${PORTSDIR}/science/bodr \
${LOCALBASE}/libdata/pkgconfig/chemical-mime-data.pc:${PORTSDIR}/science/chemical-mime-data
+LIB_DEPENDS= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext \
+ openbabel:${PORTSDIR}/science/openbabel \
+ goffice-0.10:${PORTSDIR}/devel/goffice010
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/bodr.pc:${PORTSDIR}/science/bodr \
${LOCALBASE}/libdata/pkgconfig/chemical-mime-data.pc:${PORTSDIR}/science/chemical-mime-data
PORTSCOUT= limitw:1,even
-USE_BZIP2= yes
+USE_XZ= yes
USE_XORG= x11
-USE_GNOME= gnomehack intlhack gnomedocutils gtk20 libgsf
+USE_GNOME= gnomedocutils gtk30 intlhack libgsf libxml2
USE_GMAKE= yes
+USES= desktop-file-utils gettext pathfix shared-mime-info
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-omf-dir=${PREFIX}/share/omf
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
-GCONF_SCHEMAS= gcrystal.schemas gchempaint.schemas gchempaint-arrows.schemas \
- gchemutils.schemas
GLIB_SCHEMAS= org.gnome.gchemutils.crystal.gschema.xml \
org.gnome.gchemutils.gschema.xml \
org.gnome.gchemutils.paint.gschema.xml \
@@ -47,31 +41,24 @@ GLIB_SCHEMAS= org.gnome.gchemutils.crystal.gschema.xml \
MAN1= gchem3d.1 gchemcalc.1 gchempaint.1 gchemtable.1 gcrystal.1 \
gspectrum.1
-PLIST_SUB= VER=0.12 GOFFICE=0.8.17 GNUMERIC_VER=1.10.17
+PLIST_SUB= VER=0.14 GOFFICE=0.10
OPTIONS_DEFINE= XUL
-XUL_DESC= Build browser plugin (requires Xulrunner)
+XUL_DESC= Build browser plugin (requires libxul)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MXUL}
-BROKEN= Does not work with newer libxul
USE_GECKO= libxul
-CONFIGURE_ARGS+=--enable-mozilla-plugin
+CONFIGURE_ARGS+=--enable-mozilla-plugin \
+ --with-mozilla-libdir=${PREFIX}/lib/xulrunner
PLIST_SUB+= XUL=""
.else
CONFIGURE_ARGS+=--disable-mozilla-plugin
PLIST_SUB+= XUL="@comment "
.endif
-.if exists(${LOCALBASE}/bin/gnumeric)
-RUN_DEPENDS+= gnumeric:${PORTSDIR}/math/gnumeric
-PLIST_SUB+= GNUMERIC=""
-.else
-PLIST_SUB+= GNUMERIC="@comment "
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||g' ${WRKSRC}/libs/gcp/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/science/gchemutils/distinfo b/science/gchemutils/distinfo
index 55193a3f5222..6abbcb7eff61 100644
--- a/science/gchemutils/distinfo
+++ b/science/gchemutils/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome-chemistry-utils-0.12.10.tar.bz2) = 0b83108f0503ea8635d553d4a94cb3028ea10edb41570ad3bc7b6f9756f1284f
-SIZE (gnome-chemistry-utils-0.12.10.tar.bz2) = 5018000
+SHA256 (gnome-chemistry-utils-0.14.2.tar.xz) = 85462b95b9d72e95b34ebaa0d07dc101595adf2159e480e3483ab8f440028dfe
+SIZE (gnome-chemistry-utils-0.14.2.tar.xz) = 5572856
diff --git a/science/gchemutils/files/patch-libs-gcu-spectrumdoc.cc b/science/gchemutils/files/patch-libs-gcu-spectrumdoc.cc
deleted file mode 100644
index 8e203f3c6fc5..000000000000
--- a/science/gchemutils/files/patch-libs-gcu-spectrumdoc.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/gcu/spectrumdoc.cc.orig 2009-01-05 14:09:59.000000000 -0500
-+++ libs/gcu/spectrumdoc.cc 2009-05-09 15:06:20.000000000 -0400
-@@ -1898,7 +1899,7 @@ static double logm (double val, double f
-
- static double expm (double val, double f, double offset)
- {
-- return exp10 (-val) * f + offset;
-+ return pow (10, -val) * f + offset;
- }
-
- double (*SpectrumDocument::GetConversionFunction (SpectrumUnitType oldu, SpectrumUnitType newu, double &factor, double &shift)) (double, double, double)
diff --git a/science/gchemutils/files/patch-libs_gcu_application.cc b/science/gchemutils/files/patch-libs_gcu_application.cc
new file mode 100644
index 000000000000..174845148580
--- /dev/null
+++ b/science/gchemutils/files/patch-libs_gcu_application.cc
@@ -0,0 +1,10 @@
+--- libs/gcu/application.cc.orig 2013-04-22 13:49:38.000000000 +0000
++++ libs/gcu/application.cc 2013-04-22 13:49:53.000000000 +0000
+@@ -39,6 +39,7 @@
+ #include <cstring>
+ #include <clocale>
+ #include <netinet/in.h>
++#include <sys/socket.h>
+ #include <sys/un.h>
+ #include <unistd.h>
+ #include <set>
diff --git a/science/gchemutils/pkg-plist b/science/gchemutils/pkg-plist
index 7c6515d42926..98692cf2a4f1 100644
--- a/science/gchemutils/pkg-plist
+++ b/science/gchemutils/pkg-plist
@@ -16,6 +16,9 @@ lib/gchemutils/%%VER%%/plugins/cdxml/plugin.xml
lib/gchemutils/%%VER%%/plugins/cdx/cdx.la
lib/gchemutils/%%VER%%/plugins/cdx/cdx.so
lib/gchemutils/%%VER%%/plugins/cdx/plugin.xml
+lib/gchemutils/%%VER%%/plugins/nuts/nuts.la
+lib/gchemutils/%%VER%%/plugins/nuts/nuts.so
+lib/gchemutils/%%VER%%/plugins/nuts/plugin.xml
lib/gchemutils/%%VER%%/plugins/paint/arrows.la
lib/gchemutils/%%VER%%/plugins/paint/arrows.so
lib/gchemutils/%%VER%%/plugins/paint/atoms.la
@@ -38,32 +41,35 @@ lib/gchemutils/%%VER%%/plugins/paint/templates.la
lib/gchemutils/%%VER%%/plugins/paint/templates.so
lib/gchemutils/%%VER%%/plugins/paint/text.la
lib/gchemutils/%%VER%%/plugins/paint/text.so
-lib/gchemutils/%%VER%%/plugins/paint/wikipedia.la
-lib/gchemutils/%%VER%%/plugins/paint/wikipedia.so
-%%GNUMERIC%%lib/gnumeric/%%GNUMERIC_VER%%/plugins/gchemutils/plugin.la
-%%GNUMERIC%%lib/gnumeric/%%GNUMERIC_VER%%/plugins/gchemutils/plugin.so
-%%GNUMERIC%%lib/gnumeric/%%GNUMERIC_VER%%/plugins/gchemutils/plugin.xml
lib/goffice/%%GOFFICE%%/plugins/gchemutils/gchemutils.la
lib/goffice/%%GOFFICE%%/plugins/gchemutils/gchemutils.so
lib/goffice/%%GOFFICE%%/plugins/gchemutils/plugin.xml
lib/libgccv-%%VER%%.la
lib/libgccv-%%VER%%.so
-lib/libgccv-%%VER%%.so.12
+lib/libgccv-%%VER%%.so.14
+lib/libgcugtk-%%VER%%.la
+lib/libgcugtk-%%VER%%.so
+lib/libgcugtk-%%VER%%.so.14
lib/libgcp-%%VER%%.la
lib/libgcp-%%VER%%.so
-lib/libgcp-%%VER%%.so.12
+lib/libgcp-%%VER%%.so.14
+lib/libgcrystal-%%VER%%.la
+lib/libgcrystal-%%VER%%.so
+lib/libgcrystal-%%VER%%.so.14
lib/libgcu-%%VER%%.la
lib/libgcu-%%VER%%.so
-lib/libgcu-%%VER%%.so.12
+lib/libgcu-%%VER%%.so.14
%%XUL%%lib/xulrunner/plugins/libmozgcu.la
%%XUL%%lib/xulrunner/plugins/libmozgcu.so
%%XUL%%libexec/chem-viewer
+libexec/babelserver
share/applications/gchem3d-%%VER%%.desktop
share/applications/gchemcalc-%%VER%%.desktop
share/applications/gcrystal-%%VER%%.desktop
share/applications/gchempaint-%%VER%%.desktop
share/applications/gspectrum-%%VER%%.desktop
share/applications/gchemtable-%%VER%%.desktop
+share/gchemutils/%%VER%%/databases.xml
share/gchemutils/%%VER%%/elecprops.xml
share/gchemutils/%%VER%%/elements.xml
share/gchemutils/%%VER%%/space-groups.xml
@@ -81,6 +87,8 @@ share/gchemutils/%%VER%%/ui/libgcu/gcuperiodic.ui
share/gchemutils/%%VER%%/ui/libgcu/image-resolution.ui
share/gchemutils/%%VER%%/ui/libgcu/image-size.ui
share/gchemutils/%%VER%%/ui/libgcu/print-setup.ui
+share/gchemutils/%%VER%%/ui/libgcu/stringdlg.ui
+share/gchemutils/%%VER%%/ui/libgcu/stringinputdlg.ui
share/gchemutils/%%VER%%/ui/paint/H-pos.ui
share/gchemutils/%%VER%%/ui/paint/arrow-object.ui
share/gchemutils/%%VER%%/ui/paint/arrow.png
@@ -92,15 +100,16 @@ share/gchemutils/%%VER%%/ui/paint/plugins/atoms/orbital-prop.ui
share/gchemutils/%%VER%%/ui/paint/plugins/atoms/orbital.ui
share/gchemutils/%%VER%%/ui/paint/plugins/bonds/bond.ui
share/gchemutils/%%VER%%/ui/paint/plugins/bonds/chain.ui
+share/gchemutils/%%VER%%/ui/paint/plugins/bonds/newman.ui
share/gchemutils/%%VER%%/ui/paint/plugins/cycles/cycle.ui
share/gchemutils/%%VER%%/ui/paint/plugins/cycles/cyclen.ui
share/gchemutils/%%VER%%/ui/paint/plugins/residues/residues.ui
+share/gchemutils/%%VER%%/ui/paint/plugins/selection/brackets.ui
share/gchemutils/%%VER%%/ui/paint/plugins/selection/group.ui
share/gchemutils/%%VER%%/ui/paint/plugins/templates/new-template.ui
share/gchemutils/%%VER%%/ui/paint/plugins/templates/templates.ui
share/gchemutils/%%VER%%/ui/paint/plugins/text/fontsel.ui
share/gchemutils/%%VER%%/ui/paint/preferences.ui
-share/gchemutils/%%VER%%/ui/paint/stringdlg.ui
share/gchemutils/%%VER%%/ui/paint/tools.ui
share/gchemutils/%%VER%%/ui/paint/zoom.ui
share/gchemutils/%%VER%%/ui/table/acidity.ui
@@ -113,22 +122,27 @@ share/gchemutils/%%VER%%/isotopes.xml
share/gchemutils/%%VER%%/paint/templates/haworth.xml
share/gchemutils/%%VER%%/paint/templates/templates.xml
share/gchemutils/%%VER%%/paint/themes/ACS_Document_1996
+share/gchemutils/%%VER%%/paint/themes/Gcp-Modern
share/gchemutils/%%VER%%/paint/themes/Wikipedia
share/gchemutils/%%VER%%/pixmaps/gcrystal_logo.png
share/gchemutils/%%VER%%/pixmaps/gchempaint_logo.png
share/gchemutils/%%VER%%/radii.xml
share/gchemutils/%%VER%%/residues.xml
-share/gnome/help/gchem3d-%%VER%%/C/legal.xml
-share/gnome/help/gchem3d-%%VER%%/C/gchem3d-%%VER%%.xml
share/gnome/help/gchem3d-%%VER%%/C/figures/ball-and-stick.png
share/gnome/help/gchem3d-%%VER%%/C/figures/cylinders.png
+share/gnome/help/gchem3d-%%VER%%/C/figures/gchemcalc.png
+share/gnome/help/gchem3d-%%VER%%/C/figures/gchempaint1.png
+share/gnome/help/gchem3d-%%VER%%/C/figures/gchempaint2.png
share/gnome/help/gchem3d-%%VER%%/C/figures/main-window.png
share/gnome/help/gchem3d-%%VER%%/C/figures/page-setup.png
share/gnome/help/gchem3d-%%VER%%/C/figures/print-scale.png
+share/gnome/help/gchem3d-%%VER%%/C/figures/smiles1.png
+share/gnome/help/gchem3d-%%VER%%/C/figures/smiles2.png
+share/gnome/help/gchem3d-%%VER%%/C/figures/smiles3.png
share/gnome/help/gchem3d-%%VER%%/C/figures/spacefill.png
share/gnome/help/gchem3d-%%VER%%/C/figures/wireframe.png
-share/gnome/help/gchemcalc-%%VER%%/C/legal.xml
-share/gnome/help/gchemcalc-%%VER%%/C/gchemcalc-%%VER%%.xml
+share/gnome/help/gchem3d-%%VER%%/C/gchem3d-%%VER%%.xml
+share/gnome/help/gchem3d-%%VER%%/C/legal.xml
share/gnome/help/gchemcalc-%%VER%%/C/figures/braces.png
share/gnome/help/gchemcalc-%%VER%%/C/figures/composition.png
share/gnome/help/gchemcalc-%%VER%%/C/figures/formula.png
@@ -136,21 +150,8 @@ share/gnome/help/gchemcalc-%%VER%%/C/figures/page-setup.png
share/gnome/help/gchemcalc-%%VER%%/C/figures/pattern.png
share/gnome/help/gchemcalc-%%VER%%/C/figures/print-scale.png
share/gnome/help/gchemcalc-%%VER%%/C/figures/start.png
-share/gnome/help/gcrystal-%%VER%%/C/legal.xml
-share/gnome/help/gcrystal-%%VER%%/C/gcrystal-%%VER%%.xml
-share/gnome/help/gcrystal-%%VER%%/C/figures/atoms-dlg.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/cleavages-dlg.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/default-view.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/lattice-dlg.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/lines-dlg.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/main-window.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/page-setup.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/print-res.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/print-scale.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/size-dlg.png
-share/gnome/help/gcrystal-%%VER%%/C/figures/view-settings.png
-share/gnome/help/gchempaint-%%VER%%/C/legal.xml
-share/gnome/help/gchempaint-%%VER%%/C/gchempaint-%%VER%%.xml
+share/gnome/help/gchemcalc-%%VER%%/C/gchemcalc-%%VER%%.xml
+share/gnome/help/gchemcalc-%%VER%%/C/legal.xml
share/gnome/help/gchempaint-%%VER%%/C/figures/Hposdlg.png
share/gnome/help/gchempaint-%%VER%%/C/figures/arrow-heads.png
share/gnome/help/gchempaint-%%VER%%/C/figures/arrow-object-dlg.png
@@ -161,26 +162,30 @@ share/gnome/help/gchempaint-%%VER%%/C/figures/arrow-opts.png
share/gnome/help/gchempaint-%%VER%%/C/figures/arrows.png
share/gnome/help/gchempaint-%%VER%%/C/figures/bond-opts.png
share/gnome/help/gchempaint-%%VER%%/C/figures/bond.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/brackets-opt.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/brackets.png
share/gnome/help/gchempaint-%%VER%%/C/figures/chain-opt.png
share/gnome/help/gchempaint-%%VER%%/C/figures/chain.png
share/gnome/help/gchempaint-%%VER%%/C/figures/charges.png
share/gnome/help/gchempaint-%%VER%%/C/figures/choose-elt.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/curved-arrow-end.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/curved-arrow-opts.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/curved-arrow.png
share/gnome/help/gchempaint-%%VER%%/C/figures/cycle-opt.png
share/gnome/help/gchempaint-%%VER%%/C/figures/cyclentool-opt.png
share/gnome/help/gchempaint-%%VER%%/C/figures/cyclentool.png
share/gnome/help/gchempaint-%%VER%%/C/figures/cycletools.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/delocalized-bond.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/element.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/downbond.png
share/gnome/help/gchempaint-%%VER%%/C/figures/electrons.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/element.png
share/gnome/help/gchempaint-%%VER%%/C/figures/elt-menu.png
share/gnome/help/gchempaint-%%VER%%/C/figures/eraser.png
share/gnome/help/gchempaint-%%VER%%/C/figures/fragment.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/ghemical1.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/ghemical2.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/ghemical3.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/ghemical.png
share/gnome/help/gchempaint-%%VER%%/C/figures/group.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/lasso-prop.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/lasso.png
share/gnome/help/gchempaint-%%VER%%/C/figures/main-window.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/mechanism-arrows.png
share/gnome/help/gchempaint-%%VER%%/C/figures/merge.png
share/gnome/help/gchempaint-%%VER%%/C/figures/merge1.png
share/gnome/help/gchempaint-%%VER%%/C/figures/merge2.png
@@ -189,13 +194,20 @@ share/gnome/help/gchempaint-%%VER%%/C/figures/mesomery-arrow.png
share/gnome/help/gchempaint-%%VER%%/C/figures/mesomery1.png
share/gnome/help/gchempaint-%%VER%%/C/figures/mesomery2.png
share/gnome/help/gchempaint-%%VER%%/C/figures/mesomery3.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/mol-menu-bases.png
share/gnome/help/gchempaint-%%VER%%/C/figures/mol-menu.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/mol-menu3d.png
share/gnome/help/gchempaint-%%VER%%/C/figures/new-template.png
share/gnome/help/gchempaint-%%VER%%/C/figures/newfile.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/newman-opt.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/newman.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/orbital-prop.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/orbital-sample.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/orbital-toolbox.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/orbital.png
share/gnome/help/gchempaint-%%VER%%/C/figures/page-setup.png
share/gnome/help/gchempaint-%%VER%%/C/figures/phenyl-residue.png
share/gnome/help/gchempaint-%%VER%%/C/figures/phenyl-structure.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/plus.png
share/gnome/help/gchempaint-%%VER%%/C/figures/preferences.png
share/gnome/help/gchempaint-%%VER%%/C/figures/prefs-arrows.png
share/gnome/help/gchempaint-%%VER%%/C/figures/prefs-atoms-font.png
@@ -221,30 +233,16 @@ share/gnome/help/gchempaint-%%VER%%/C/figures/selection.png
share/gnome/help/gchempaint-%%VER%%/C/figures/stereobonds.png
share/gnome/help/gchempaint-%%VER%%/C/figures/templates-tools.png
share/gnome/help/gchempaint-%%VER%%/C/figures/templates.png
+share/gnome/help/gchempaint-%%VER%%/C/figures/text-opt.png
share/gnome/help/gchempaint-%%VER%%/C/figures/text.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/texttools-bar.png
share/gnome/help/gchempaint-%%VER%%/C/figures/toolbox.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/wikipedia.png
-share/gnome/help/gspectrum-%%VER%%/C/legal.xml
-share/gnome/help/gspectrum-%%VER%%/C/gspectrum-%%VER%%.xml
-share/gnome/help/gspectrum-%%VER%%/C/figures/gspectrum.png
-share/gnome/help/gspectrum-%%VER%%/C/figures/ir-tools.png
-share/gnome/help/gspectrum-%%VER%%/C/figures/nmr-tools.png
-share/gnome/help/gspectrum-%%VER%%/C/figures/page-setup.png
-share/gnome/help/gspectrum-%%VER%%/C/figures/print-scale.png
-share/gnome/help/gspectrum-%%VER%%/C/figures/simple-toolbar.png
-share/gnome/help/gspectrum-%%VER%%/C/figures/uv-vis-tools.png
-share/gnome/help/gchemtable-%%VER%%/C/legal.xml
-share/gnome/help/gchemtable-%%VER%%/C/gchemtable-%%VER%%.xml
+share/gnome/help/gchempaint-%%VER%%/C/gchempaint-%%VER%%.xml
+share/gnome/help/gchempaint-%%VER%%/C/legal.xml
share/gnome/help/gchemtable-%%VER%%/C/figures/add-plot.png
share/gnome/help/gchemtable-%%VER%%/C/figures/atomic-radii.png
share/gnome/help/gchemtable-%%VER%%/C/figures/blocs.png
share/gnome/help/gchemtable-%%VER%%/C/figures/choose-data.png
share/gnome/help/gchemtable-%%VER%%/C/figures/curve.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/curved-arrow-end.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/curved-arrow-opts.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/curved-arrow.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/downbond.png
share/gnome/help/gchemtable-%%VER%%/C/figures/elec.png
share/gnome/help/gchemtable-%%VER%%/C/figures/electronegativity.png
share/gnome/help/gchemtable-%%VER%%/C/figures/family.png
@@ -252,16 +250,38 @@ share/gnome/help/gchemtable-%%VER%%/C/figures/graph-guru.png
share/gnome/help/gchemtable-%%VER%%/C/figures/main.png
share/gnome/help/gchemtable-%%VER%%/C/figures/new-chart-guru.png
share/gnome/help/gchemtable-%%VER%%/C/figures/new-chart.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/orbital-prop.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/orbital-sample.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/orbital-toolbox.png
-share/gnome/help/gchempaint-%%VER%%/C/figures/orbital.png
share/gnome/help/gchemtable-%%VER%%/C/figures/page-setup.png
share/gnome/help/gchemtable-%%VER%%/C/figures/print-scale.png
share/gnome/help/gchemtable-%%VER%%/C/figures/radii.png
share/gnome/help/gchemtable-%%VER%%/C/figures/start.png
share/gnome/help/gchemtable-%%VER%%/C/figures/state.png
share/gnome/help/gchemtable-%%VER%%/C/figures/thermo.png
+share/gnome/help/gchemtable-%%VER%%/C/figures/tip.png
+share/gnome/help/gchemtable-%%VER%%/C/gchemtable-%%VER%%.xml
+share/gnome/help/gchemtable-%%VER%%/C/legal.xml
+share/gnome/help/gcrystal-%%VER%%/C/figures/atoms-dlg.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/cleavages-dlg.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/default-view.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/lattice-dlg.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/lines-dlg.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/main-window.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/page-setup.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/print-res.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/print-scale.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/size-dlg.png
+share/gnome/help/gcrystal-%%VER%%/C/figures/view-settings.png
+share/gnome/help/gcrystal-%%VER%%/C/gcrystal-%%VER%%.xml
+share/gnome/help/gcrystal-%%VER%%/C/legal.xml
+share/gnome/help/gspectrum-%%VER%%/C/figures/fid-tools.png
+share/gnome/help/gspectrum-%%VER%%/C/figures/gspectrum.png
+share/gnome/help/gspectrum-%%VER%%/C/figures/ir-tools.png
+share/gnome/help/gspectrum-%%VER%%/C/figures/nmr-tools.png
+share/gnome/help/gspectrum-%%VER%%/C/figures/page-setup.png
+share/gnome/help/gspectrum-%%VER%%/C/figures/print-scale.png
+share/gnome/help/gspectrum-%%VER%%/C/figures/simple-toolbar.png
+share/gnome/help/gspectrum-%%VER%%/C/figures/uv-vis-tools.png
+share/gnome/help/gspectrum-%%VER%%/C/gspectrum-%%VER%%.xml
+share/gnome/help/gspectrum-%%VER%%/C/legal.xml
share/omf/gchem3d-%%VER%%/gchem3d-%%VER%%-C.omf
share/omf/gchemcalc-%%VER%%/gchemcalc-%%VER%%-C.omf
share/omf/gchempaint-%%VER%%/gchempaint-%%VER%%-C.omf
@@ -270,41 +290,18 @@ share/omf/gcrystal-%%VER%%/gcrystal-%%VER%%-C.omf
share/omf/gspectrum-%%VER%%/gspectrum-%%VER%%-C.omf
share/mimelnk/application/x-gchempaint.desktop
share/mimelnk/application/x-gcrystal.desktop
-share/icons/hicolor/128x128/apps/gchem3d.png
-share/icons/hicolor/128x128/apps/gchemcalc.png
-share/icons/hicolor/128x128/apps/gchempaint.png
-share/icons/hicolor/128x128/apps/gchemtable.png
-share/icons/hicolor/128x128/apps/gcrystal.png
-share/icons/hicolor/128x128/apps/gspectrum.png
-share/icons/hicolor/128x128/mimetypes/application-x-gchempaint.png
-share/icons/hicolor/128x128/mimetypes/application-x-gcrystal.png
-share/icons/hicolor/32x32/apps/gchem3d.png
-share/icons/hicolor/32x32/apps/gchemcalc.png
-share/icons/hicolor/32x32/apps/gchempaint.png
-share/icons/hicolor/32x32/apps/gchemtable.png
-share/icons/hicolor/32x32/apps/gcrystal.png
-share/icons/hicolor/32x32/apps/gspectrum.png
-share/icons/hicolor/32x32/mimetypes/application-x-gchempaint.png
-share/icons/hicolor/32x32/mimetypes/application-x-gcrystal.png
-share/icons/hicolor/48x48/apps/gchem3d.png
-share/icons/hicolor/48x48/apps/gchemcalc.png
-share/icons/hicolor/48x48/apps/gchempaint.png
-share/icons/hicolor/48x48/apps/gchemtable.png
-share/icons/hicolor/48x48/apps/gcrystal.png
-share/icons/hicolor/48x48/apps/gspectrum.png
-share/icons/hicolor/48x48/mimetypes/application-x-gchempaint.png
-share/icons/hicolor/48x48/mimetypes/application-x-gcrystal.png
-share/icons/hicolor/72x72/apps/gchem3d.png
-share/icons/hicolor/72x72/apps/gchemcalc.png
-share/icons/hicolor/72x72/apps/gchempaint.png
-share/icons/hicolor/72x72/apps/gchemtable.png
-share/icons/hicolor/72x72/apps/gcrystal.png
-share/icons/hicolor/72x72/apps/gspectrum.png
-share/icons/hicolor/72x72/mimetypes/application-x-gchempaint.png
-share/icons/hicolor/72x72/mimetypes/application-x-gcrystal.png
+share/icons/hicolor/scalable/apps/gchem3d.svg
+share/icons/hicolor/scalable/apps/gchemcalc.svg
+share/icons/hicolor/scalable/apps/gchempaint.svg
+share/icons/hicolor/scalable/apps/gchemtable.svg
+share/icons/hicolor/scalable/apps/gcrystal.svg
+share/icons/hicolor/scalable/apps/gspectrum.svg
+share/icons/hicolor/scalable/mimetypes/application-x-gcrystal.svg
+share/icons/hicolor/scalable/mimetypes/application-x-gchempaint.svg
share/locale/de/LC_MESSAGES/gchemutils-%%VER%%.mo
share/locale/el/LC_MESSAGES/gchemutils-%%VER%%.mo
share/locale/es/LC_MESSAGES/gchemutils-%%VER%%.mo
+share/locale/eu/LC_MESSAGES/gchemutils-%%VER%%.mo
share/locale/fr/LC_MESSAGES/gchemutils-%%VER%%.mo
share/locale/it/LC_MESSAGES/gchemutils-%%VER%%.mo
share/locale/pl/LC_MESSAGES/gchemutils-%%VER%%.mo
@@ -362,8 +359,11 @@ share/mime/packages/gchemutils.xml
@dirrmtry share/mime/chemical
@dirrmtry share/mimelnk/application
@dirrmtry share/mimelnk
+%%XUL%%@dirrmtry lib/xulrunner/plugins
+%%XUL%%@dirrmtry lib/xulrunner
@dirrm lib/goffice/%%GOFFICE%%/plugins/gchemutils
@dirrm lib/gchemutils/%%VER%%/plugins/paint
+@dirrm lib/gchemutils/%%VER%%/plugins/nuts
@dirrm lib/gchemutils/%%VER%%/plugins/cml
@dirrm lib/gchemutils/%%VER%%/plugins/cif
@dirrm lib/gchemutils/%%VER%%/plugins/cdxml
@@ -371,5 +371,3 @@ share/mime/packages/gchemutils.xml
@dirrm lib/gchemutils/%%VER%%/plugins
@dirrm lib/gchemutils/%%VER%%
@dirrm lib/gchemutils
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime