aboutsummaryrefslogtreecommitdiff
path: root/science/getdp/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-11-15 22:18:09 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-11-15 22:18:09 +0000
commit52ec56ba801b536f4751afff295c98e92865c342 (patch)
tree46c71b413026ecb4853c4d4fb962560aa3b7883c /science/getdp/Makefile
parent29e92be35318cc3be37848dda1e72fbc5c4693da (diff)
downloadports-52ec56ba801b536f4751afff295c98e92865c342.tar.gz
ports-52ec56ba801b536f4751afff295c98e92865c342.zip
Notes
Diffstat (limited to 'science/getdp/Makefile')
-rw-r--r--science/getdp/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
new file mode 100644
index 000000000000..a8d41ccc397a
--- /dev/null
+++ b/science/getdp/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: getdp
+# Date created: 25 September 2004
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= getdp
+PORTVERSION= 1.0.0
+CATEGORIES= science
+MASTER_SITES= http://www.geuz.org/getdp/src/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A rather general finite element solver using mixed finite elements
+
+LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw \
+ gsl.6:${PORTSDIR}/math/gsl
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-fftw-prefix=${LOCALBASE} \
+ --with-gsl-prefix=${LOCALBASE}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= getdp.1
+
+EXAMPLES= Magnetostatics.pro README solver.par test.geo test.msh test.pro
+
+.if defined(WITH_MULTIHARMONIC)
+CONFIGURE_ARGS+= --enable-multiharmonic
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if !defined(NOPORTDOCS)
+. if ${PERL_LEVEL} < 500600
+NOPORTDOCS= yes
+. else
+ALL_TARGET= all doc
+BUILD_DEPENDS+= texi2pdf:${PORTSDIR}/print/teTeX-base
+USE_PERL5_BUILD= yes
+. endif
+.endif
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/bin/getdp
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${DOCSDIR} && ${TAR} xfz ${WRKSRC}/${PORTNAME}-${PORTVERSION}-doc.tgz
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/demos/|} ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.if defined(MAINTAINER_MODE)
+test: install
+ cd ${WRKSRC}/demos && ${PORTNAME} test.pro -solve MagSta_phi
+.endif
+
+.include <bsd.port.post.mk>