aboutsummaryrefslogtreecommitdiff
path: root/science/gromacs/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-24 16:27:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-24 16:27:23 +0000
commit5e0dac513e152d08d284b399b0cdaa370580c882 (patch)
tree4ca7b3d4dc080f4a3993e11667d97356bce11d74 /science/gromacs/Makefile
parentcdfbf346e791f849350649e87820776ffcae9dbf (diff)
downloadports-5e0dac513e152d08d284b399b0cdaa370580c882.tar.gz
ports-5e0dac513e152d08d284b399b0cdaa370580c882.zip
Notes
Diffstat (limited to 'science/gromacs/Makefile')
-rw-r--r--science/gromacs/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 97a8b6c0dc7b..392d45a79756 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gromacs
-PORTVERSION= 4.6
+PORTVERSION= 4.6.1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
@@ -22,10 +22,10 @@ GSL_DESC= Extra analysis using math/gsl
MPICH_DESC= MPI support using net/mpich2
OMPI_DESC= MPI support using net/openmpi
+USES= cmake
USE_FORTRAN= yes
USE_PERL5= yes
USE_PKGCONFIG= build
-USES= cmake
CMAKE_ARGS= -DBLAS_LIBRARIES:FILEPATH="${BLAS_LIBS}" \
-DLAPACK_LIBRARIES:FILEPATH="${LAPACK_LIBS}"
USE_LDCONFIG= yes
@@ -127,7 +127,7 @@ post-patch:
@${FIND} ${WRKSRC} -name "CMakeLists.txt" | ${XARGS} \
${REINPLACE_CMD} -e \
's|share/man|man| ; \
- s|-lpthread|${PTHREAD_LIBS}| ; \
+ s|-lpthread|-pthread| ; \
/pkgconfig/s|LIB_INSTALL_DIR}|CMAKE_INSTALL_PREFIX}/libdata|'
@${FIND} ${WRKSRC} -name "GMXRC.*" | ${XARGS} ${REINPLACE_CMD} -e \
's|LDLIB/pkgconfig|LDLIB/../libdata/pkgconfig| ; \