aboutsummaryrefslogtreecommitdiff
path: root/science/gromacs/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-05-30 16:17:14 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-05-30 16:17:14 +0000
commit1c688417c5aae62a6d9b58c792469aa4a25a2032 (patch)
tree9b77ddd4188e9e85ce6f576d22e5c4149cfd75f0 /science/gromacs/Makefile
parent245b2d94e3079c574f059aec3cc3f2d07de00f00 (diff)
downloadports-1c688417c5aae62a6d9b58c792469aa4a25a2032.tar.gz
ports-1c688417c5aae62a6d9b58c792469aa4a25a2032.zip
Notes
Diffstat (limited to 'science/gromacs/Makefile')
-rw-r--r--science/gromacs/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 326c53c28a9e..918c5c8c0ed4 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -11,7 +11,7 @@ PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
-MAINTAINER= stephen@missouri.edu
+MAINTAINER= flo@kasimir.com
COMMENT= Compute molecular dynamics
USE_GNOME= libxml2
@@ -28,21 +28,17 @@ OPTIONS= FFTW3 "Use FFT routines from math/fftw3" on \
GSL "Enable extra analysis using math/gsl" on \
FLOAT "Use single instead of double precision" off \
X11 "Build and install X11 programs" on \
- MPICH "Enable MPI support using net/mpich" off \
+ MPICH "Enable MPI support using net/mpich2" off \
OMPI "Enable MPI support using net/openmpi" off
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
.if !defined(WITHOUT_FFTW3) && defined(WITH_FFTW2)
-IGNORE= Cannot build with FFTW3 and FFTW2. Run 'make config' again and choose only one of them.
+IGNORE= cannot build with FFTW3 and FFTW2. Run 'make config' again and choose only one of them
.endif
.if defined(WITH_MPICH) && defined(WITH_OMPI)
-IGNORE= Cannot build with MPICH and OpenMPI support. Run 'make config' again and choose only one of them.
+IGNORE= cannot build with MPICH and OpenMPI support. Run 'make config' again and choose only one of them
.endif
.if !defined(WITHOUT_FFTW3)
@@ -90,15 +86,15 @@ PLIST_SUB+= SUFFIX_D=_d SUFFIX_DOUBLE=_double
.if defined(WITH_MPICH) || defined(WITH_OMPI)
CONFIGURE_ARGS+= --enable-mpi
-. if defined(WITH_MPICH)
-CONFIGURE_ENV+= MPICC=${PREFIX}/mpich/bin/mpicc
-BUILD_DEPENDS+= ${PREFIX}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
-RUN_DEPENDS+= ${PREFIX}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
-. else
+.if defined(WITH_MPICH)
+CONFIGURE_ENV+= MPICC=${PREFIX}/mpich2/bin/mpicc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+.elif defined(WITH_OMPI)
CONFIGURE_ENV+= MPICC=${PREFIX}/mpi/openmpi/bin/mpicc
-BUILD_DEPENDS+= ${PREFIX}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
-RUN_DEPENDS+= ${PREFIX}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
-. endif
+BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
+RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
+.endif
PLIST_SUB+= SUFFIX_MPI="_mpi" MPI=""
.else
PLIST_SUB+= SUFFIX_MPI="" MPI="@comment "