aboutsummaryrefslogtreecommitdiff
path: root/science/gwyddion/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-04 07:59:58 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-04 07:59:58 +0000
commit7f2c75738dbdd65ec138743a6759d0bf9a6c8f26 (patch)
tree17ca2032681fe8aa46ae2d3aba36c60c15cf3ceb /science/gwyddion/Makefile
parentd1840f426fec13d9b49506d467bdcc1eb0b7906c (diff)
Notes
Diffstat (limited to 'science/gwyddion/Makefile')
-rw-r--r--science/gwyddion/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/science/gwyddion/Makefile b/science/gwyddion/Makefile
index c223b01de68a..a9876b32783e 100644
--- a/science/gwyddion/Makefile
+++ b/science/gwyddion/Makefile
@@ -6,15 +6,11 @@
#
PORTNAME= gwyddion
-PORTVERSION= 1.99.9
+PORTVERSION= 2.0
CATEGORIES= science graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
-PATCHFILES= gwyddion-1-99-9-crashes.patch
-PATCH_SITES= ${MASTER_SITES}
-PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
-
MAINTAINER= yeti@gwyddion.net
COMMENT= A gtk2 based SPM data visualization and analysis tool
@@ -63,4 +59,15 @@ post-patch:
@${REINPLACE_CMD} -e '/# Install the pseudo-library/,/^$$/d' ${WRKSRC}/ltmain.sh
@${REINPLACE_CMD} -e '/^SUBDIRS =/,/[^\]$$/d' ${WRKSRC}/devel-docs/Makefile.in
-.include <bsd.port.mk>
+# Remove private header installed by mistake
+post-install:
+ ${RM} ${PREFIX}/include/gwyddion/libgwydgets/gwydgetmarshals.h
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${LOCALBASE}/bin/pod2man:${PORTSDIR}/textproc/p5-podlators
+CONFIGURE_ENV+= POD2MAN="${LOCALBASE}/bin/pod2man"
+.endif
+
+.include <bsd.port.post.mk>