aboutsummaryrefslogtreecommitdiff
path: root/science/h5utils/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-03-18 19:42:35 +0000
committerSteve Wills <swills@FreeBSD.org>2011-03-18 19:42:35 +0000
commitcae009169cdf7015f5d7c0c2d8eb8e330464c613 (patch)
treebb250dd36470b367fec3e3fab70d2c3f9d2e7219 /science/h5utils/Makefile
parentf748b9776a65db59909f6a26310413b76271a905 (diff)
downloadports-cae009169cdf7015f5d7c0c2d8eb8e330464c613.tar.gz
ports-cae009169cdf7015f5d7c0c2d8eb8e330464c613.zip
Notes
Diffstat (limited to 'science/h5utils/Makefile')
-rw-r--r--science/h5utils/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/science/h5utils/Makefile b/science/h5utils/Makefile
new file mode 100644
index 000000000000..93d885c16c57
--- /dev/null
+++ b/science/h5utils/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: h5utils
+# Date created: Mar 11, 2011
+# Whom: Klaus Aehlig <aehlig@linta.de>
+# $FreeBSD$
+
+PORTNAME= h5utils
+PORTVERSION= 1.12.1
+CATEGORIES= science
+MASTER_SITES= http://ab-initio.mit.edu/${PORTNAME}/
+
+MAINTAINER= aehlig@linta.de
+COMMENT= A set of utilities for visualization and conversion of HDF5 format
+
+LICENSE= MIT GPLv2
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+MAN1= h5totxt.1 h5fromtxt.1 h5tovtk.1 h5topng.1 h5math.1
+
+GNU_CONFIGURE= YES
+CFLAGS += -L${LOCALBASE}/lib -I${LOCALBASE}/include ${PTHREAD_LIBS}
+
+BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
+LIB_DEPENDS += hdf5:${PORTSDIR}/science/hdf5 \
+ png:${PORTSDIR}/graphics/png \
+ matheval.1:${PORTSDIR}/devel/libmatheval
+
+.include <bsd.port.mk>