aboutsummaryrefslogtreecommitdiff
path: root/science/h5utils
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /science/h5utils
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'science/h5utils')
-rw-r--r--science/h5utils/Makefile6
-rw-r--r--science/h5utils/files/patch-writepng.c19
2 files changed, 23 insertions, 2 deletions
diff --git a/science/h5utils/Makefile b/science/h5utils/Makefile
index 93d885c16c57..a267d8f9023e 100644
--- a/science/h5utils/Makefile
+++ b/science/h5utils/Makefile
@@ -5,6 +5,7 @@
PORTNAME= h5utils
PORTVERSION= 1.12.1
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://ab-initio.mit.edu/${PORTNAME}/
@@ -18,11 +19,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
MAN1= h5totxt.1 h5fromtxt.1 h5tovtk.1 h5topng.1 h5math.1
GNU_CONFIGURE= YES
-CFLAGS += -L${LOCALBASE}/lib -I${LOCALBASE}/include ${PTHREAD_LIBS}
+CFLAGS += -L${LOCALBASE}/lib -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/libpng15 ${PTHREAD_LIBS}
BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
LIB_DEPENDS += hdf5:${PORTSDIR}/science/hdf5 \
- png:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
matheval.1:${PORTSDIR}/devel/libmatheval
.include <bsd.port.mk>
diff --git a/science/h5utils/files/patch-writepng.c b/science/h5utils/files/patch-writepng.c
new file mode 100644
index 000000000000..fa98cfe9ea8b
--- /dev/null
+++ b/science/h5utils/files/patch-writepng.c
@@ -0,0 +1,19 @@
+--- writepng.c.orig 2009-06-12 22:58:50.000000000 +0200
++++ writepng.c 2012-05-06 06:49:53.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include <string.h>
+
+ #include <png.h>
++#include <pngpriv.h>
+
+ #include "writepng.h"
+
+@@ -309,7 +310,7 @@
+ }
+ /* Set error handling. REQUIRED if you aren't supplying your own *
+ * error hadnling functions in the png_create_write_struct() call. */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* If we get here, we had a problem reading the file */
+ fclose(fp);
+ png_destroy_write_struct(&png_ptr, (png_infopp) NULL);