aboutsummaryrefslogtreecommitdiff
path: root/science/hdf/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:41:13 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:41:13 +0000
commit1b9e13a9ecee51c559290ebe9441d7a48ebc905c (patch)
tree3a3f0dfce1f0fe22f69fc9227d11fbeec3d8682d /science/hdf/Makefile
parent0d5f28b877e4dcd33ab8faa4a71ff0cfc18f86a5 (diff)
downloadports-1b9e13a9ecee51c559290ebe9441d7a48ebc905c.tar.gz
ports-1b9e13a9ecee51c559290ebe9441d7a48ebc905c.zip
Notes
Diffstat (limited to 'science/hdf/Makefile')
-rw-r--r--science/hdf/Makefile47
1 files changed, 19 insertions, 28 deletions
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index c8b0ddf06be3..5c9346b1eda7 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -1,16 +1,12 @@
-# New ports collection makefile for: HDF_lib
-# Date created: 17 November 1996
-# Whom: mi
-#
+# Created by: mi
# $FreeBSD$
-#
PORTNAME= hdf
-DISTVERSION= 4.2.7-patch1
+DISTVERSION= 4.2.8
PORTEPOCH= 1
CATEGORIES= science archivers graphics
-MASTER_SITES= ftp://ftp.hdfgroup.org/HDF/HDF_Current/src/ \
- ftp://ftp.hdfgroup.org/HDF/prev-releases/HDF${PORTVERSION:R}/src/
+MASTER_SITES= http://www.hdfgroup.org/ftp/HDF/releases/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME:U}${PORTVERSION}/src/
MAINTAINER= ports@FreeBSD.org
COMMENT= Hierarchical Data Format library (from NCSA)
@@ -22,31 +18,15 @@ CONFLICTS= netcdf-*
USE_BZIP2= yes
USE_FORTRAN= yes
-MAKE_JOBS_SAFE= yes
-# XXX Our libtool breaks, when building this:
-# XXX can't link libraries with fortran
-#USE_AUTOTOOLS= libtool
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-jpeg="${LOCALBASE}" \
- --with-szlib="${LOCALBASE}"\
+CONFIGURE_ARGS= --with-jpeg="${LOCALBASE}" \
+ --with-szlib="${LOCALBASE}" \
--enable-shared
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
MAN1= hdf.1 hdfunpac.1 ncdump.1 ncgen.1
MAN3= gr_chunk.3
-MANCOMPRESSED= no
-
-USE_LDCONFIG= yes
-
-check regression-test test: build
- ${MAKE} ${_MAKE_JOBS} -C ${WRKSRC}/hdf/test check
-
-post-install:
- # Install man-pages omitted by HDF's own install process
- ${INSTALL_MAN} ${WRKSRC}/man/hdfunpac.1 ${MAN1PREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/man/gr_chunk.3 ${MAN1PREFIX}/man/man3/
- # Removing useless .la files from ${PREFIX}/lib
- ${RM} -f ${PREFIX}/lib/libdf.la ${PREFIX}/lib/libmfhdf.la
.include <bsd.port.pre.mk>
@@ -54,4 +34,15 @@ post-install:
BROKEN= Does not compile on powerpc
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/PROD_/s|=.*|=""|' ${WRKSRC}/config/freebsd
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/man/hdfunpac.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/gr_chunk.3 ${MAN3PREFIX}/man/man3
+
+check regression-test test: build
+ ${MAKE} -C ${WRKSRC}/hdf/test check
+
.include <bsd.port.post.mk>