aboutsummaryrefslogtreecommitdiff
path: root/science/hdf/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-07-08 14:49:02 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-07-08 14:49:02 +0000
commit05f5fc5134df22fba81be02f5917a4a097013efe (patch)
tree154b811e3c02f8524c7f9e5c336d06a556579e16 /science/hdf/Makefile
parent7645bf0c5c8c75203b8c7f788a274e96d3d0f992 (diff)
downloadports-05f5fc5134df22fba81be02f5917a4a097013efe.tar.gz
ports-05f5fc5134df22fba81be02f5917a4a097013efe.zip
Notes
Diffstat (limited to 'science/hdf/Makefile')
-rw-r--r--science/hdf/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index fbab29160381..c59fca853183 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hdf
DISTVERSION= 4.2.8
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= science archivers graphics
MASTER_SITES= http://www.hdfgroup.org/ftp/HDF/releases/%SUBDIR%/
@@ -17,12 +17,12 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
CONFLICTS= netcdf-*
-USES= fortran
-USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jpeg="${LOCALBASE}" \
--with-szlib="${LOCALBASE}" \
--enable-shared
+INSTALL_TARGET= install-strip
+USES= fortran libtool tar:bzip2
USE_LDCONFIG= yes
BROKEN_powerpc= Does not compile on powerpc
@@ -36,6 +36,7 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/man/gr_chunk.3 ${STAGEDIR}${MAN3PREFIX}/man/man3
check regression-test test: build
- ${MAKE} -C ${WRKSRC}/hdf/test check
+ @(cd ${WRKSRC}/hdf/test && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
.include <bsd.port.mk>