aboutsummaryrefslogtreecommitdiff
path: root/science/hdf5-18
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-24 05:29:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-24 05:29:55 +0000
commit67de49e0561a2726c2c4761aaf6c0f9bfb5b5dce (patch)
tree0da85300c5bd80b16bad3fa7b8bb1f3c9e2e4f88 /science/hdf5-18
parent021896b4958157c5ec9c605def394f87ad5070c8 (diff)
downloadports-67de49e0561a2726c2c4761aaf6c0f9bfb5b5dce.tar.gz
ports-67de49e0561a2726c2c4761aaf6c0f9bfb5b5dce.zip
Notes
Diffstat (limited to 'science/hdf5-18')
-rw-r--r--science/hdf5-18/Makefile39
-rw-r--r--science/hdf5-18/distinfo6
-rw-r--r--science/hdf5-18/files/patch-c++::commence.in31
-rw-r--r--science/hdf5-18/files/patch-commence.in32
-rw-r--r--science/hdf5-18/files/patch-fortran_H5f90i.h11
-rw-r--r--science/hdf5-18/files/patch-fortran_commence.in31
-rw-r--r--science/hdf5-18/files/patch-fortran_configure10
-rw-r--r--science/hdf5-18/files/patch-fortran_freebsd23
-rw-r--r--science/hdf5-18/files/patch-src-H5FDdirect.c11
-rw-r--r--science/hdf5-18/pkg-plist153
10 files changed, 100 insertions, 247 deletions
diff --git a/science/hdf5-18/Makefile b/science/hdf5-18/Makefile
index 514a31a3a6d8..ef05751ca02b 100644
--- a/science/hdf5-18/Makefile
+++ b/science/hdf5-18/Makefile
@@ -1,41 +1,34 @@
-# ex:ts=8
-# New ports collection makefile for: HDF5
-# Date created: Jul 7, 2002
-# Whom: ijliao
+# New ports collection makefile for: hdf5-18
+# Date created: Nov 20, 2008
+# Whom: Wen Heping <wenheping@gmail.com>
#
# $FreeBSD$
#
PORTNAME= hdf5
-PORTVERSION= 1.6.8
+PORTVERSION= 1.8.2
CATEGORIES= science archivers graphics
-MASTER_SITES= ftp://ftp.hdfgroup.org/HDF5/current16/src/ \
- ftp://ftp.hdfgroup.org/HDF5/prev-releases/ \
- ftp://ftp.hdfgroup.org/HDF5/prev-releases/hdf5-${PORTVERSION}/src/ \
- LOCAL/chinsan
+MASTER_SITES= ftp://ftp.hdfgroup.org/HDF5/current/src/
MAINTAINER= koziol@hdfgroup.org
COMMENT= Hierarchical Data Format library (from NCSA)
+CONFLICTS= hdf5-1.6.*
+
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-LIBTOOLFILES= configure c++/configure
CONFIGURE_ARGS= --disable-debug \
--enable-cxx \
--enable-instrument \
--enable-production \
--enable-strict-format-checks \
- --enable-threadsafe \
--with-pthread=/usr \
--with-ssl=/usr \
--with-zlib=/usr
-ALL_TARGET= lib progs
.include <bsd.port.pre.mk>
.if defined(WITH_FORTRAN)
-LIBTOOLFILES+= fortran/configure
USE_FORTRAN= yes
CONFIGURE_ENV+= F9X=${FC}
CONFIGURE_ARGS+= --enable-fortran
@@ -50,22 +43,14 @@ BROKEN= Does not compile on ${ARCH}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g' \
- -e 's|[\$$]LDFLAGS -pthread|\$$LDFLAGS ${PTHREAD_LIBS}|g' \
- ${WRKSRC}/config/freebsd ${WRKSRC}/c++/config/freebsd
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/config/gnu-flags
- @${REINPLACE_CMD} -e 's|objformat=|#objformat=|g' \
- -e 's|\(version_type=freebsd\)-.*|\1-elf|g' \
- ${WRKSRC}/aclocal.m4 ${WRKSRC}/configure
-.if defined(NOPORTEXAMPLES)
-.for i in . c++ hl fortran
- @${REINPLACE_CMD} \
- -e 's,\((cd examples && $$(MAKE) $$@) || exit 1;\),#\1,g' \
- ${WRKSRC}/${i}/Makefile.in
-.endfor
-.endif
post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
.for i in gif2h5 h52gif h5debug h5diff h5dump h5import h5jam h5ls h5repack h5repart h5unjam
@${STRIP_CMD} ${PREFIX}/bin/${i}
.endfor
diff --git a/science/hdf5-18/distinfo b/science/hdf5-18/distinfo
index 00638289010d..2c5c2f1d811b 100644
--- a/science/hdf5-18/distinfo
+++ b/science/hdf5-18/distinfo
@@ -1,3 +1,3 @@
-MD5 (hdf5-1.6.8.tar.gz) = a822babf2810b509cc6779de739debd3
-SHA256 (hdf5-1.6.8.tar.gz) = 8226c12bc224ac9454d51921b2cda591f094c1c25ca96d67504ca21bb3f6b7e2
-SIZE (hdf5-1.6.8.tar.gz) = 5346975
+MD5 (hdf5-1.8.2.tar.gz) = af92ef65ef495dbd205131574ad4eee1
+SHA256 (hdf5-1.8.2.tar.gz) = 795db1a98cd4effde3309efbbc118e1f5ae112369c1202f3f74dba4654bfbaf5
+SIZE (hdf5-1.8.2.tar.gz) = 7094386
diff --git a/science/hdf5-18/files/patch-c++::commence.in b/science/hdf5-18/files/patch-c++::commence.in
deleted file mode 100644
index 393adc30cc0f..000000000000
--- a/science/hdf5-18/files/patch-c++::commence.in
+++ /dev/null
@@ -1,31 +0,0 @@
---- c++/config/commence.in.orig Mon Jun 30 16:19:35 2003
-+++ c++/config/commence.in Mon Oct 20 23:44:08 2003
-@@ -27,7 +27,7 @@
- RM=rm -f
- CP=cp
- INSTALL=@INSTALL@
--INSTALL_PROGRAM=@INSTALL_PROGRAM@
-+INSTALL_PROGRAM=@INSTALL_SCRIPT@
- INSTALL_DATA=@INSTALL_DATA@
- TRACE=:
-
-@@ -37,7 +37,7 @@
- bindir=@bindir@
- libdir=@libdir@
- includedir=@includedir@
--docdir=@exec_prefix@/doc
-+docdir=@exec_prefix@/share
- PUB_LIB=$(LIB)
-
- ## Obtain default library; the current version of libtool does not fully
-@@ -60,8 +60,8 @@
- ## Optional variables. We must declare them here because Irix pmake
- ## complains if it sees a reference to a variable which has never been
- ## defined. The main makefile is free to redefine these to something else.
--DOCDIR=$(docdir)
--EXAMPLEDIR=$(docdir)/hdf5/examples/c++
-+DOCDIR=$(docdir)/doc/hdf5
-+EXAMPLEDIR=$(docdir)/examples/hdf5/c++
- LIB=
- LIB_SRC=
- LIB_OBJ=
diff --git a/science/hdf5-18/files/patch-commence.in b/science/hdf5-18/files/patch-commence.in
deleted file mode 100644
index 0795dcb37f66..000000000000
--- a/science/hdf5-18/files/patch-commence.in
+++ /dev/null
@@ -1,32 +0,0 @@
---- config/commence.in.orig Tue Jul 22 23:39:43 2003
-+++ config/commence.in Mon Oct 20 23:45:00 2003
-@@ -26,7 +26,7 @@
- RM=rm -f
- CP=cp
- INSTALL=@INSTALL@
--INSTALL_PROGRAM=@INSTALL_PROGRAM@
-+INSTALL_PROGRAM=@INSTALL_SCRIPT@
- INSTALL_DATA=@INSTALL_DATA@
- RUNSERIAL=@RUNSERIAL@
- RUNPARALLEL=@RUNPARALLEL@
-@@ -39,7 +39,7 @@
- bindir=@bindir@
- libdir=@libdir@
- includedir=@includedir@
--docdir=@exec_prefix@/doc
-+docdir=@exec_prefix@/share
- PUB_LIB=$(LIB)
-
- ## Shared libraries
-@@ -57,9 +57,9 @@
- ## Optional variables. We must declare them here because Irix pmake
- ## complains if it sees a reference to a variable which has never been
- ## defined. The main makefile is free to redefine these to something else.
--DOCDIR=$(docdir)
-+DOCDIR=$(docdir)/doc/hdf5
- SUBDOCDIR=
--EXAMPLEDIR=$(docdir)/hdf5/examples/c
-+EXAMPLEDIR=$(docdir)/examples/hdf5/c
- LIB=
- LIB_SRC=
- LIB_OBJ=
diff --git a/science/hdf5-18/files/patch-fortran_H5f90i.h b/science/hdf5-18/files/patch-fortran_H5f90i.h
deleted file mode 100644
index 83f5855b8993..000000000000
--- a/science/hdf5-18/files/patch-fortran_H5f90i.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- fortran/src/H5f90i.h.orig Thu Jul 12 21:26:46 2007
-+++ fortran/src/H5f90i.h Thu Jul 12 21:27:18 2007
-@@ -71,7 +71,7 @@
- #endif /*APPLE*/
-
- /* LINUX definitions */
--#if (defined(linux) || defined(__gnu_linux__) || defined(__linux__))
-+#if (defined(linux) || defined(__gnu_linux__) || defined(__linux__) || defined(__FreeBSD__))
-
- /* Common definitions */
- typedef char *_fcd;
diff --git a/science/hdf5-18/files/patch-fortran_commence.in b/science/hdf5-18/files/patch-fortran_commence.in
deleted file mode 100644
index 3331f07ce406..000000000000
--- a/science/hdf5-18/files/patch-fortran_commence.in
+++ /dev/null
@@ -1,31 +0,0 @@
---- fortran/config/commence.in.orig Thu Jul 12 21:28:40 2007
-+++ fortran/config/commence.in Thu Jul 12 21:33:56 2007
-@@ -47,7 +47,7 @@
- RM=rm -f
- CP=cp
- INSTALL=@INSTALL@
--INSTALL_PROGRAM=@INSTALL_PROGRAM@
-+INSTALL_PROGRAM=@INSTALL_SCRIPT@
- INSTALL_DATA=@INSTALL_DATA@
- PARALLEL=@PARALLEL@
- RUNSERIAL=@RUNSERIAL@
-@@ -62,7 +62,7 @@
- bindir=@bindir@
- libdir=@libdir@
- includedir=@includedir@
--docdir=@exec_prefix@/doc
-+docdir=@exec_prefix@/share
- PUB_LIB=$(LIB)
-
- ## Shared libraries
-@@ -85,8 +85,8 @@
- ## Optional variables. We must declare them here because Irix pmake
- ## complains if it sees a reference to a variable which has never been
- ## defined. The main makefile is free to redefine these to something else.
--DOCDIR=$(docdir)
--EXAMPLEDIR=$(docdir)/hdf5/examples/fortran
-+DOCDIR=$(docdir)/doc/hdf5
-+EXAMPLEDIR=$(docdir)/examples/hdf5/fortran
- LIB=
- LIB_SRC=
- LIB_OBJ=
diff --git a/science/hdf5-18/files/patch-fortran_configure b/science/hdf5-18/files/patch-fortran_configure
deleted file mode 100644
index 7244f4e4f10a..000000000000
--- a/science/hdf5-18/files/patch-fortran_configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- fortran/configure.orig Thu Jul 12 21:36:24 2007
-+++ fortran/configure Thu Jul 12 21:36:49 2007
-@@ -7602,6 +7602,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/science/hdf5-18/files/patch-fortran_freebsd b/science/hdf5-18/files/patch-fortran_freebsd
deleted file mode 100644
index 329de570663c..000000000000
--- a/science/hdf5-18/files/patch-fortran_freebsd
+++ /dev/null
@@ -1,23 +0,0 @@
---- fortran/config/freebsd.orig Thu Jul 12 21:23:06 2007
-+++ fortran/config/freebsd Thu Jul 12 21:25:09 2007
-@@ -27,3 +27,20 @@
-
- # Figure out compiler flags
- . $srcdir/config/gnu-flags
-+
-+#
-+# HDF5 integers
-+#
-+# R_LARGE is the number of digits for the bigest integer supported.
-+# R_INTEGER is the number of digits in INTEGER
-+#
-+# (for the Linux architechture)
-+#
-+R_LARGE=18
-+R_INTEGER=9
-+HADDR_T='SELECTED_INT_KIND(R_LARGE)'
-+HSIZE_T='SELECTED_INT_KIND(R_LARGE)'
-+HSSIZE_T='SELECTED_INT_KIND(R_LARGE)'
-+HID_T='SELECTED_INT_KIND(R_INTEGER)'
-+SIZE_T='SELECTED_INT_KIND(R_INTEGER)'
-+OBJECT_NAMELEN_DEFAULT_F=-1
diff --git a/science/hdf5-18/files/patch-src-H5FDdirect.c b/science/hdf5-18/files/patch-src-H5FDdirect.c
new file mode 100644
index 000000000000..f46dbe251b5a
--- /dev/null
+++ b/science/hdf5-18/files/patch-src-H5FDdirect.c
@@ -0,0 +1,11 @@
+--- src/H5FDdirect.c.orig 2008-09-24 22:02:07.000000000 +0800
++++ src/H5FDdirect.c 2008-09-24 22:02:38.000000000 +0800
+@@ -29,6 +29,8 @@
+ * this file. */
+ /* #define _XOPEN_SOURCE 600 */
+
++#define O_DIRECT 0x00010000
++
+ #include "H5private.h" /* Generic Functions */
+ #include "H5Eprivate.h" /* Error handling */
+ #include "H5Fprivate.h" /* File access */
diff --git a/science/hdf5-18/pkg-plist b/science/hdf5-18/pkg-plist
index ba8217caef46..911c72b85e12 100644
--- a/science/hdf5-18/pkg-plist
+++ b/science/hdf5-18/pkg-plist
@@ -1,3 +1,7 @@
+bin/h5mkgrp
+bin/h5copy
+bin/h5stat
+bin/h5perf_serial
bin/gif2h5
bin/h52gif
bin/h5c++
@@ -13,13 +17,13 @@ bin/h5redeploy
bin/h5repack
bin/h5repart
bin/h5unjam
+include/hdf5_hl.h
include/H5ACpublic.h
include/H5AbstractDs.h
include/H5Apublic.h
include/H5ArrayType.h
include/H5AtomType.h
include/H5Attribute.h
-include/H5Bpublic.h
include/H5Classes.h
include/H5CommonFG.h
include/H5CompType.h
@@ -31,11 +35,14 @@ include/H5DataSpace.h
include/H5DataType.h
include/H5DcreatProp.h
include/H5Dpublic.h
+include/H5DSpublic.h
include/H5DxferProp.h
include/H5EnumType.h
+include/H5Epubgen.h
include/H5Epublic.h
include/H5Exception.h
include/H5FDcore.h
+include/H5FDdirect.h
include/H5FDfamily.h
include/H5FDlog.h
include/H5FDmpi.h
@@ -52,115 +59,103 @@ include/H5FloatType.h
include/H5Fpublic.h
include/H5Gpublic.h
include/H5Group.h
-include/H5HGpublic.h
-include/H5HLpublic.h
-include/H5IM.h
include/H5IdComponent.h
+include/H5IMpublic.h
include/H5Include.h
include/H5IntType.h
include/H5Ipublic.h
-include/H5LT.h
include/H5Library.h
+include/H5LTpublic.h
+include/H5Lpublic.h
include/H5MMpublic.h
include/H5Object.h
include/H5Opublic.h
+include/H5PTpublic.h
+include/H5PacketTable.h
include/H5Ppublic.h
include/H5PredType.h
include/H5PropList.h
include/H5Rpublic.h
include/H5Spublic.h
include/H5StrType.h
-include/H5TA.h
+include/H5TBpublic.h
include/H5Tpublic.h
include/H5VarLenType.h
include/H5Zpublic.h
include/H5api_adpt.h
-include/H5cxx_pubconf.h
include/H5pubconf.h
-%%FORTRAN%%include/H5pubconf_fortran.h
include/H5public.h
+include/H5version.h
include/hdf5.h
-%%FORTRAN%%lib/h5a.mod
-%%FORTRAN%%lib/h5d.mod
-%%FORTRAN%%lib/h5e.mod
-%%FORTRAN%%lib/h5f.mod
-%%FORTRAN%%lib/h5fortran_flags.mod
-%%FORTRAN%%lib/h5fortran_types.mod
-%%FORTRAN%%lib/h5g.mod
-%%FORTRAN%%lib/h5global.mod
-%%FORTRAN%%lib/h5i.mod
-%%FORTRAN%%lib/h5lib.mod
-%%FORTRAN%%lib/h5p.mod
-%%FORTRAN%%lib/h5r.mod
-%%FORTRAN%%lib/h5s.mod
-%%FORTRAN%%lib/h5t.mod
-%%FORTRAN%%lib/h5z.mod
-%%FORTRAN%%lib/hdf5.mod
+%%FORTRAN%%include/h5a.mod
+%%FORTRAN%%include/h5d.mod
+%%FORTRAN%%include/h5e.mod
+%%FORTRAN%%include/h5f.mod
+%%FORTRAN%%include/h5fortran_flags.mod
+%%FORTRAN%%include/h5fortran_types.mod
+%%FORTRAN%%include/h5g.mod
+%%FORTRAN%%include/h5global.mod
+%%FORTRAN%%include/h5i.mod
+%%FORTRAN%%include/h5lib.mod
+%%FORTRAN%%include/h5p.mod
+%%FORTRAN%%include/h5r.mod
+%%FORTRAN%%include/h5s.mod
+%%FORTRAN%%include/h5t.mod
+%%FORTRAN%%include/h5z.mod
+%%FORTRAN%%include/hdf5.mod
+%%FORTRAN%%include/h5_dble_interface.mod
+%%FORTRAN%%include/h5o.mod
+%%FORTRAN%%include/h5l.mod
+%%FORTRAN%%include/h5tb.mod
+%%FORTRAN%%include/h5lt.mod
+%%FORTRAN%%include/h5im.mod
+%%FORTRAN%%lib/libhdf5_fortran.so
+%%FORTRAN%%lib/libhdf5_fortran.so.0
+%%FORTRAN%%lib/libhdf5hl_fortran.so
+%%FORTRAN%%lib/libhdf5hl_fortran.so.0
+%%FORTRAN%%lib/libhdf5hl_fortran.la
+%%FORTRAN%%lib/libhdf5hl_fortran.a
+lib/libhdf5_cpp.so
+lib/libhdf5_cpp.so.0
+lib/libhdf5_hl_cpp.so
+lib/libhdf5_hl_cpp.so.0
+lib/libhdf5_hl_cpp.la
+lib/libhdf5_hl_cpp.a
lib/libhdf5.a
lib/libhdf5.la
lib/libhdf5.settings
lib/libhdf5.so
-lib/libhdf5.so.0
+lib/libhdf5.so.6
lib/libhdf5_cpp.a
lib/libhdf5_cpp.la
%%FORTRAN%%lib/libhdf5_fortran.a
%%FORTRAN%%lib/libhdf5_fortran.la
-%%FORTRAN%%lib/libhdf5_fortran.settings
lib/libhdf5_hl.a
lib/libhdf5_hl.la
lib/libhdf5_hl.so
lib/libhdf5_hl.so.0
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/chunks.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/compound.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/create.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/extend_ds.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/h5group.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/readdata.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/strtype.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/writedata.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_image1.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_image2.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_lite1.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_lite2.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_lite3.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_01.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_02.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_03.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_04.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_05.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_06.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_07.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_08.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_09.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_10.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_11.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/ex_table_12.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_attribute.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_chunk_read.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_compound.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_drivers.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_extend_write.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_group.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_mount.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_read.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_reference.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_select.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c/h5_write.c
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/attrexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/compound.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/dsetexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/fileexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/groupexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/grpdsetexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/grpit.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/grpsexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/hyperslab.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/mountexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/refobjexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/refregexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/rwdsetexample.f90
-%%FORTRAN%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fortran/selectele.f90
-%%FORTRAN%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/fortran
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/c++
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Attributes.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.am
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_attribute.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_chunk_read.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_compound.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_drivers.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_dtransform.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_elink_unix2win.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_extend_write.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_extlink.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_group.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_interm_group.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_mount.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_read.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_ref2reg.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_reference.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_select.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_shared_mesg.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/h5_write.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ph5example.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testh5cc.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testh5cc.sh.in
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%