aboutsummaryrefslogtreecommitdiff
path: root/science/iboview
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-02-11 10:11:41 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-02-11 10:11:41 +0000
commitb28580bffcb695f9e645119b9dda60d5b11da04e (patch)
tree2aa0e7736bdd5f7a24bbaadb6f7cbfad9a4b3614 /science/iboview
parentd2afba21650ee6968b1aa1a15bc633031ff8e5ef (diff)
downloadports-b28580bffcb695f9e645119b9dda60d5b11da04e.tar.gz
ports-b28580bffcb695f9e645119b9dda60d5b11da04e.zip
Fix dependency on gcc runtime:
- lang/gcc is a metaport that doesn't provide any lib - libgcc_s is already provided in base so LIB_DEPENDS can't be used
Notes
Notes: svn path=/head/; revision=461483
Diffstat (limited to 'science/iboview')
-rw-r--r--science/iboview/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/science/iboview/Makefile b/science/iboview/Makefile
index 6007142ee0ce..11f10583f678 100644
--- a/science/iboview/Makefile
+++ b/science/iboview/Makefile
@@ -3,7 +3,7 @@
PORTNAME= iboview
PORTVERSION= 20150427
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= science
MASTER_SITES= http://www.iboview.org/bin/
DISTNAME= ibo-view.20150427
@@ -15,9 +15,10 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= qt5-buildtools>=0:devel/qt5-buildtools \
- boost-libs>=0:devel/boost-libs
-LIB_DEPENDS= libgcc_s.so:lang/gcc
-RUN_DEPENDS= boost-libs>=0:devel/boost-libs
+ boost-libs>=0:devel/boost-libs \
+ ${LOCALBASE}/lib/gcc${GCC_DEFAULT}/libgcc_s.so:lang/gcc${GCC_DEFAULT}
+RUN_DEPENDS= boost-libs>=0:devel/boost-libs \
+ ${LOCALBASE}/lib/gcc${GCC_DEFAULT}/libgcc_s.so:lang/gcc${GCC_DEFAULT}
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON_amd64= only builds and is supported on amd64